Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Для установки флажка нужно чтобы проверялись значения во второй таб. части.

Для установки флажка нужно чтобы проверялись значения во второй таб. части.
Я
   1сЮлия
 
29.07.19 - 17:56
Добрый день! У меня две табличных части нужно в зависимости от значения флажка во второй табличной части,заполнялось значение в первой при выбранном  Виде операции  МехИспытания.Если хотя бы одно значение нет тогда нет.У меня только ставит по последнему если последний флажок да, то всем ставит да и наоборот  
Процедура СерииПриПолученииДанных(Элемент, ОформленияСтрок)
    
Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    
    СерияНоменклатуры = ОформлениеСтроки.ДанныеСтроки.СерияНоменклатуры;
      
    Если ЗначениеЗаполнено(СерияНоменклатуры) Тогда
         Плавка=ПолучитьПлавку(СерияНоменклатуры);
         ОформлениеСтроки.Ячейки.Плавка.ОтображатьТекст = Истина;
         ОформлениеСтроки.Ячейки.Плавка.Текст = Плавка;
    иначе    
         ОформлениеСтроки.Ячейки.Плавка.ОтображатьТекст = Истина;
         ОформлениеСтроки.Ячейки.Плавка.Текст = "";
    КонецЕсли;
    
    Если (ВидОперации = Перечисления.аэсВидыОперацийКВЛ.МеханическиеИспытания)  тогда
         ОформлениеСтроки.Ячейки.Состояние.Флажок = 0;
       Для Каждого стр из Анализы цикл
          
          Если НЕ стр.СоответствуетНормативу тогда
                ОформлениеСтроки.Ячейки.Состояние.Флажок = 0;
                ОформлениеСтроки.Ячейки.Состояние.Значение=Ложь;

          Иначе
                ОформлениеСтроки.Ячейки.Состояние.Значение=Истина;
                ОформлениеСтроки.Ячейки.Состояние.Флажок = 1;
          КонецЕсли;    
       КонецЦикла;    
КонецЕсли;  
КонецЦикла;
КонецПроцедуры
 
 
   1сЮлия
 
1 - 30.07.19 - 09:37
Я доработала.Спасибо большое!
   Fish
 
2 - 30.07.19 - 09:54
(1) Да не за что, обращайся :))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.