Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как воспользоваться функцией ПолноеНаименование();

v7: Как воспользоваться функцией ПолноеНаименование();
Я
   Косяк
 
26.07.19 - 10:57
Стоит задача вывести только папки справочника. Хочу вывести полные пути, но не знаю как. Вот код

Процедура Сформировать()    
    
СпрН = СоздатьОбъект("Справочник.Номенклатура");

Запрос = СоздатьОбъект("Запрос");    

ТекстЗапроса = "    
|Обрабатывать НеПомеченныеНаУдаление;
|Номенклатура =Справочник.Номенклатура.ТекущийЭлемент;
|Родитель =Справочник.Номенклатура.ТекущийЭлемент.Родитель;
//|ПолноеНаименование =Справочник.Номенклатура.ПолноеНаименование();
|Группировка Родитель;";


Если Запрос.Выполнить(ТекстЗапроса) = 1 Тогда

ПН = Запрос.Номенклатура.ПолноеНаименование();
    
Пока Запрос.Группировка(1) = 1 Цикл
  //сообщить(Запрос.Родитель);
  Сообщить(Запрос.Родитель+" // "+ПН);
КонецЦикла;

КонецЕсли;


КонецПроцедуры
 
 
   garmosha
 
1 - 26.07.19 - 10:59
ПН = Запрос.Номенклатура.ПолноеНаименование();  внутри цикла ..
   Builder
 
2 - 26.07.19 - 11:14
ПолноеНаименование()
Синтаксис:
ПолноеНаименование()
Назначение:
Возвращает строку, содержащую полное наименование выбранного элемента справочника со всеми вышестоящими уровнями, разделенными символом /.
   Косяк
 
3 - 26.07.19 - 11:52
(1) Спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.