Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Нужно чтобы при добавлении страницы с табличной частью еще одной очищалось значение флажка

Нужно чтобы при добавлении страницы с табличной частью еще одной очищалось значение флажка
Я
   1сЮлия
 
26.07.19 - 10:47
Доброе утро! У меня в документе две табличной части,вторая табличная часть появляется при выборе определенного вида операции,когда этот вид операции выбран нужно чтобы в первой табличной части очистилось значение флажкка, и устанавливалось в зависимости от значения СоответствуетНормативу в другой табличной части,если там хоть одно значение  СоответствуетНормативу = Ложь,тогда Соответствует тоже Ложь,если все Истина тогда все Истина. Как тут проверить доступность второй табличной части и очистить флажок и присвоить значение в зависимости от значений во второй таб части?
Процедура СерииПриПолученииДанных(Элемент, ОформленияСтрок)
Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    
    СерияНоменклатуры = ОформлениеСтроки.ДанныеСтроки.СерияНоменклатуры;
      
    Если ЗначениеЗаполнено(СерияНоменклатуры) Тогда
         Плавка=ПолучитьПлавку(СерияНоменклатуры);
         ОформлениеСтроки.Ячейки.Плавка.ОтображатьТекст = Истина;
         ОформлениеСтроки.Ячейки.Плавка.Текст = Плавка;
    иначе    
         ОформлениеСтроки.Ячейки.Плавка.ОтображатьТекст = Истина;
         ОформлениеСтроки.Ячейки.Плавка.Текст = "";
     КонецЕсли;
    
  Для Каждого стр из Анализы цикл
      
      Если НЕ стр.СоответствуетНормативу тогда
            
         ОформлениеСтроки.Ячейки.Состояние.УстановитьТекст("");
  
      Иначе
         ОформлениеСтроки.Ячейки.Состояние.УстановитьФлажок(ОформлениеСтроки.ДанныеСтроки.Состояние);
          КонецЕсли;    
     КонецЦикла;    

КонецЦикла;

КонецПроцедуры
 
 
   lodger
 
1 - 26.07.19 - 11:16
вряд ли это получится сделать в событии ПриПолученииДанных
   1сЮлия
 
2 - 26.07.19 - 11:18
В каком событии это будет вернее сделать?
   lodger
 
3 - 26.07.19 - 11:18
"когда этот вид операции выбран"©

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.