Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Заполнение субконто

Заполнение субконто
Я
   жабка
 
24.07.19 - 17:37
Ребят, помогите! Что я делаю не так?
В подписке на событие пишу код:
    Если Отказ = Ложь Тогда
        Если ТипЗнч(Источник.Ссылка)=Тип("ДокументСсылка.ПлатежныйОрдерПоступлениеДенежныхСредств") Тогда
            РасчетыСПоставщикамиИПодрядчиками = ПланыСчетов.Хозрасчетный.РасчетыСПоставщикамиИПодрядчиками;
            
            Для Каждого Проводка Из Источник.Движения.Хозрасчетный Цикл
                Если Проводка.СчетДт = РасчетыСПоставщикамиИПодрядчиками ИЛИ Проводка.СчетДт.Родитель = РасчетыСПоставщикамиИПодрядчиками Тогда
                    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, "Контрагенты", Источник.Контрагент);
                    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, "Договоры", Источник.Договор);
                    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, "ДокументыРасчетовСКонтрагентами", Источник.Ссылка);    
                КонецЕсли;
            КонецЦикла;
            
        ИначеЕсли ТипЗнч(Источник.Ссылка)=Тип("ДокументСсылка.ПоступлениеДопРасходов") Тогда
            ПрочиеМатериалы = ПланыСчетов.Хозрасчетный.ПрочиеМатериалы;
            
            Для Каждого Проводка Из Источник.Движения.Хозрасчетный Цикл
                Если Проводка.СчетКт = ПрочиеМатериалы Тогда
                    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "Номенклатура", Источник.Номенклатура);
                    БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "Склады"         , Источник.Склад);    
                КонецЕсли;
            КонецЦикла;
            
        КонецЕсли;
    КонецЕсли;
    
Все, хорошо, все классно. В отладчике Проводка.СубконтоКт.Номенклатура заполняется. Но в итоге субконто все равно пустое. Словно где-то потом перетирается. Но база вроде пустая, только эта моя дописулина и по сути все.
Это я так пытаюсь заполнить аналитику по счету 10.6 у которого субконто Номенклатура и склады. Подскажите, пожалуйста, на что мне обратить внимание, чтобы решить этот вопрос.
 
 
   sqr4
 
1 - 24.07.19 - 17:38
Конфа то какая?
   жабка
 
2 - 24.07.19 - 17:39
Бухгалтерия для Беларуси, редакция 2.1
   жабка
 
3 - 24.07.19 - 17:40
(1) Бухгалтерия для Беларуси, редакция 2.1
   hhhh
 
4 - 24.07.19 - 17:44
(3) это вы где заполняете?
   жабка
 
5 - 24.07.19 - 17:47
(4) при подписке на событие: Обработка проведения - источник составной тип из двух документов: ПлатежныйОрдерПоступлениеДенежныхСредств и ПоступлениеДопРасходов. В первом случае все работает, во втором в отладчике заполняется, а на деле нет.
   Жан Пердежон
 
6 - 24.07.19 - 17:47
(0) что за подписка?
   жабка
 
7 - 24.07.19 - 17:48
(6) Сама добавила: ОбработкаПроведения, источник составной тип из двух документов: ПлатежныйОрдерПоступлениеДенежныхСредств и ПоступлениеДопРасходов.
   жабка
 
8 - 24.07.19 - 17:56
Единственное за что я чуть-чуть зацепилась, так это за то, что у счета 10.6 в предопределенных нет этих видов субконто, они добавлялись уже в 1с:Преприятие. Может с этим быть как-то связано?
   Жан Пердежон
 
9 - 24.07.19 - 17:56
Источник.Движения.Хозрасчетный.Записывать = ИСТИНА;

В Поступлении доп.расходов движения записываются непосредственно (Движения.Записать()) 
в модуле объекта, а в платежном ордере, видимо, после проведения.
   жабка
 
10 - 24.07.19 - 17:57
(9) Спасибуленки)
   жабка
 
11 - 24.07.19 - 18:02
(9) Да! Получилось, добавила записывать = истина, и все заполнилось. В жизни не догадалась бы, спасибо огромное))) Вы мой супергерой!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.