Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КД2: Не выгружается справочник СерииНоменклатуры из КА1.1 в КА2.4

КД2: Не выгружается справочник СерииНоменклатуры из КА1.1 в КА2.4
Я
   Mikhail Volkov
 
24.07.19 - 14:02
Правила выгрузки в основном типовые, УПП-УП (1.3.116, 2.4.8, v.1) https://jpegshare.net/3a/42/3a42bac1251365ea1fc180a4e6c5e203.jpg.html. Дописывал правила для документов, для справочников лишь незначительные, комментарии для отладки:
- в ПКО_СерииНоменклатуры_ПередВыгрузкойОбъекта
Если Параметры.Комментировать Тогда
    Сообщить("Выгрузили серию: " + СокрЛП(Источник) + ?(Источник.ПометкаУдаления, " (помечен на удаление)", "") + " номенклатуры: " + СокрЛП(Источник.Владелец) + ", вид: " + СокрЛП(Источник.Владелец.ВидНоменклатуры) + ", GUID: " + Источник.УникальныйИдентификатор(), СтатусСообщения.Информация);
КонецЕсли;
КлючВыгружаемыхДанных = Источник.Наименование;

- в ПКС_СерииНоменклатуры_ВидНоменклатуры_ПередВыгрузкойСвойства_3_17 (использует ВидыНоменклатуры)
Если ТипЗнч(Источник) <> Тип("Структура") Тогда
    Значение = Источник.Владелец.ВидНоменклатуры;
    ИсходящиеДанные = Новый Структура;
    ИсходящиеДанные.Вставить("Наименование",                Источник.Владелец.ВидНоменклатуры.Наименование);
    ИсходящиеДанные.Вставить("ИспользованиеХарактеристик",    Источник.Владелец.ВестиУчетПоХарактеристикам);
    ИсходящиеДанные.Вставить("ИспользоватьСерии",            Истина);
КонецЕсли;
Сообщить("Источник: " + СокрЛП(Источник.Наименование) + " " + ?(ТипЗнч(Источник) = Тип("Структура"), "тип Структура", "Владелец: " + СокрЛП(Источник.Владелец) + ", тип: " + ТипЗнч(Источник.Владелец) + ", вид: " + СокрЛП(Источник.Владелец.ВидНоменклатуры)), СтатусСообщения.Информация);

- ПКО_ВидыНоменклатуры_ПередВыгрузкойОбъекта
Если ТипЗнч(Источник) = Тип("Структура") Тогда
    Если Не Источник.Свойство("АлкогольнаяПродукция") Тогда
        Источник.Вставить("АлкогольнаяПродукция", Ложь);
    КонецЕсли;
    Если Не Источник.Свойство("ИмпортнаяАлкогольнаяПродукция") Тогда
        Источник.Вставить("ИмпортнаяАлкогольнаяПродукция", Ложь);
    КонецЕсли;
    Если Не Источник.Свойство("ВидАлкогольнойПродукции") Тогда
        Источник.Вставить("ВидАлкогольнойПродукции", Справочники.ВидыАлкогольнойПродукции.ПустаяСсылка());
    КонецЕсли;
КонецЕсли;    

Если ТипЗнч(Источник) = Тип("Структура") Тогда
    
    ВходящиеДанные.Вставить("Наименование",                    Лев(Источник.Наименование, 50));
    ВходящиеДанные.Вставить("ИспользованиеХарактеристик",    Источник.ИспользованиеХарактеристик);
    ВходящиеДанные.Вставить("ИспользоватьСерии",            Источник.ИспользоватьСерии);
    
ИначеЕсли ТипЗнч(Источник) = Тип("СправочникСсылка.ВидыНоменклатуры") Тогда    //+МВ 11.08.2018
    
    Если Параметры.Комментировать Тогда
        Сообщить("Выгрузили вид номенклатуры: " + ВходящиеДанные.Наименование + ", ИспользованиеХарактеристик: " + ВходящиеДанные.ИспользованиеХарактеристик + ", ИспользоватьСерии: " + ВходящиеДанные.ИспользоватьСерии + ", GUID: " + Источник.УникальныйИдентификатор(), СтатусСообщения.Информация);
    КонецЕсли;
ИначеЕсли ТипЗнч(Источник) <> Тип("Строка") Тогда
    
    // Если передали объект, то на данный вид номенклатуры нет ссылок, выгружаем все по-минимуму
    ВходящиеДанные.Вставить("ИспользованиеХарактеристик", "НеИспользовать");
    ВходящиеДанные.Вставить("Наименование", Лев(Источник.Наименование + " " + "(" + НСтр("ru='б/х б/с'") + ")", 50));
    ВходящиеДанные.Вставить("ИспользоватьСерии", Ложь);
    
КонецЕсли;

В выгружаемом документе есть 2-е номенклатуры с сериями одинаковыми по наименованию, но разными по виду номенклатуры. В комментариях ПКО_СерииНоменклатуры_ПередВыгрузкойОбъекта пишет, что обе серии выгрузились:
Выгрузили требование-накладная: Требование-накладная СИП00000029 от 10.07.2019 12:23:37
- Оправка поршневых колец универсал., артикул: ЦБ000006297, вид: Материалы и спецоснастка, серия: с/н 04/03/2019, GUID: 8bc4e391-3e31-11e9-a56b-28924acd4010
- Съемник стопорных колец, артикул: ЦБ000004297, вид: Инструменты, серия: с/н 04/03/2019, GUID: 8bc4e393-3e31-11e9-a56b-28924acd4010
Выгрузили серию: с/н 04/03/2019 номенклатуры: Оправка поршневых колец универсал., вид: Материалы и спецоснастка, GUID: 8bc4e391-3e31-11e9-a56b-28924acd4010
Источник: с/н 04/03/2019 Владелец: Оправка поршневых колец универсал., тип: Номенклатура, вид: Материалы и спецоснастка
Выгрузили вид номенклатуры: Материалы и спецоснастка, ИспользованиеХарактеристик: Нет, ИспользоватьСерии: Да, GUID: b5a7bacc-9a24-4e9b-b3f3-dae9461b55b4
Выгрузили серию: с/н 04/03/2019 номенклатуры: Съемник стопорных колец, вид: Инструменты, GUID: 8bc4e393-3e31-11e9-a56b-28924acd4010

А в файле выгрузки только одна серия. Меняю в документе позиции:
Выгрузили требование-накладная: Требование-накладная СИП00000029 от 10.07.2019 12:23:37
- Съемник стопорных колец, артикул: ЦБ000004297, вид: Инструменты, серия: с/н 04/03/2019, GUID: 8bc4e393-3e31-11e9-a56b-28924acd4010
- Оправка поршневых колец универсал., артикул: ЦБ000006297, вид: Материалы и спецоснастка, серия: с/н 04/03/2019, GUID: 8bc4e391-3e31-11e9-a56b-28924acd4010
Выгрузили серию: с/н 04/03/2019 номенклатуры: Съемник стопорных колец, вид: Инструменты, GUID: 8bc4e393-3e31-11e9-a56b-28924acd4010
Источник: с/н 04/03/2019 Владелец: Съемник стопорных колец, тип: Номенклатура, вид: Инструменты
Выгрузили вид номенклатуры: Инструменты, ИспользованиеХарактеристик: Нет, ИспользоватьСерии: Да, GUID: 8c15f90d-eab0-47db-9460-65e0d98d19bc
Выгрузили серию: с/н 04/03/2019 номенклатуры: Оправка поршневых колец универсал., вид: Материалы и спецоснастка, GUID: 8bc4e391-3e31-11e9-a56b-28924acd4010

В файле выгрузки другая (но только одна) серия. Из-за чего не пойму!?
 
 
   Йохохо
 
1 - 24.07.19 - 14:19
вероятно из-за "КлючВыгружаемыхДанных = Источник.Наименование;" КлючВыгружаемыхДанных = "СправочникСерии" + Источник.Код + ИсточникИсточник.Наименование;
   Mikhail Volkov
 
2 - 24.07.19 - 14:53
(1) > КлючВыгружаемыхДанных = "СправочникСерии" + Источник.Код + ИсточникИсточник.Наименование;
Может не "СправочникСерии", а "СправочникСерииНоменклатуры", или без разницы?
   Mikhail Volkov
 
3 - 24.07.19 - 14:59
+ Вроде получилось:
Выгрузили требование-накладная: Требование-накладная СИП00000029 от 10.07.2019 12:23:37
 - Съемник стопорных колец, артикул: ЦБ000004297, вид: Инструменты, серия: с/н 04/03/2019, GUID: 8bc4e393-3e31-11e9-a56b-28924acd4010
 - Оправка поршневых колец универсал., артикул: ЦБ000006297, вид: Материалы и спецоснастка, серия: с/н 04/03/2019, GUID: 8bc4e391-3e31-11e9-a56b-28924acd4010
Выгрузили серию: с/н 04/03/2019 номенклатуры: Съемник стопорных колец, вид: Инструменты, GUID: 8bc4e393-3e31-11e9-a56b-28924acd4010
Источник: с/н 04/03/2019 Владелец: Съемник стопорных колец, тип: Номенклатура, вид: Инструменты
Выгрузили вид номенклатуры: Инструменты, ИспользованиеХарактеристик: Нет, ИспользоватьСерии: Да, GUID: 8c15f90d-eab0-47db-9460-65e0d98d19bc
Выгрузили серию: с/н 04/03/2019 номенклатуры: Оправка поршневых колец универсал., вид: Материалы и спецоснастка, GUID: 8bc4e391-3e31-11e9-a56b-28924acd4010
Источник: с/н 04/03/2019 Владелец: Оправка поршневых колец универсал., тип: Номенклатура, вид: Материалы и спецоснастка
Выгрузили вид номенклатуры: Материалы и спецоснастка, ИспользованиеХарактеристик: Нет, ИспользоватьСерии: Да, GUID: b5a7bacc-9a24-4e9b-b3f3-dae9461b55b4
Спс!
   Mikhail Volkov
 
4 - 24.07.19 - 16:40
(1) Все же, почему при старом КлючВыгружаемыхДанных = Источник.Наименование; не все СерииНоменклатуры выгружались? Каким образом КлючВыгружаемыхДанных влияет на выгрузку? Как-то пытался с этим разобраться КД2: Получить значение из входящих данных
   Йохохо
 
5 - 24.07.19 - 16:43
(4) по старому ключу находились значения в соответствии выгруженных объектов и в дубли просто писалось нпп=НППСтарого вместо выгрузки объекта
   Mikhail Volkov
 
6 - 24.07.19 - 17:41
(5) А если в настройках поставить галочку "Не запоминать выгруженные объекты", тогда никакой КлючВыгружаемыхДанных не нужен?
Считал, что КлючВыгружаемыхДанных как-то связан с галочкой "Получить значение из входящих данных" https://jpegshare.net/3a/42/3a42bac1251365ea1fc180a4e6c5e203.jpg.html Нет?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.