Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Закрасить дни в календаре

Закрасить дни в календаре
Я
   JuixyJes
 
23.07.19 - 17:44
Доброго вечера вам, товарищи программисты! Сегодня  я вас помучаю вопросом о календаре. У меня в регистр попадают записи с Датой Начала и Датой окончания. Как при изменении реквизитов документа, в котором есть календарик закрасить в календарике те дни, которые попадают в период записи регистра?
 
 
   sqr4
 
1 - 23.07.19 - 17:59
путем выкладывания фото в купальнике
   JuixyJes
 
2 - 23.07.19 - 18:04
(1) не время
   novichok79
 
3 - 23.07.19 - 18:15
посмотрите в типовых работу с календарем, например в ЗУП 3.1
   JuixyJes
 
4 - 25.07.19 - 09:50
И все же, как мне закрасить периоды, которые уже попали в регистр сведений? Выборку из регистра понятно, сделать легко, а вот календарь красить пока не знаю как.
   JuixyJes
 
5 - 25.07.19 - 09:53
Так полагаю делать это нужно в процедуре ПриВыводеПериода.
   МимохожийОднако
 
6 - 25.07.19 - 09:53
(4) В форме используй режим условного оформления
   JuixyJes
 
7 - 25.07.19 - 10:02
(6) По подробнее можно? Я с календарем столкнулась впервые
   Greeen
 
8 - 25.07.19 - 11:07
(0) Если реквизит на форме - Поле календаря, тогда

Процедура КалендарьПриВыводеПериода(Элемент, ОформлениеПериода)
     Для Каждого ТекДата Из ОформлениеПериода.Даты Цикл
        Если ТекДата.Дата < ТекущаяДата() Тогда
            ТекДата.ЦветФона = Новый Цвет(83,106,194);
            ТекДата.ЦветТекста = Новый Цвет(255,255,255);
        КонецЕсли; 
    КонецЦикла;
КонецПроцедуры


Если реквизит  - Дата, и нужно ограничить календарик при изменении - нужно рисковать свою форму с календарем, и делать как выше (вроде еще 1с не сделало по другому возможности)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.