Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Выбрать корсчета

v7: Выбрать корсчета
Я
   Work1
 
23.07.19 - 10:31
Подскажите как выбрать корсчета по счету

                                                                                                              
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица2");

Таб.ВывестиСекцию("Шапка");

БИ=СоздатьОбъект("БухгалтерскиеИтоги");
БИ.ИспользоватьСубконто("Плательщик");


БИ.ВключатьСубсчета(1,1);
БИ.ВыполнитьЗапрос(НачДата,КонДата,Счет);
БИ.ВыбратьСчета();
Ном=0;
НачДБ=0;
НачКР=0;
ОБДБ=0;
ОБКР=0;
КонДБ=0;
КонКР=0;

Пока БИ.ПолучитьСчет()=1 Цикл


    БИ.ВыбратьКорСчета(1);
Пока БИ.ПолучитьКорСчет()=1 Цикл

Сообщить("Наз==");
КонецЦикла;    
// КонецЦикла;
  КонецЦикла;
    
Таб.ВывестиСекцию("Итог");
    Таб.Показать();
 
 
   Work1
 
1 - 23.07.19 - 10:43
Подскажите почему не выбирает кор счет и не выводит сообщение
   Work1
 
2 - 23.07.19 - 10:54
Может есть идеи что не так в коде
   Lazy Stranger
 
3 - 23.07.19 - 11:05
ВыполнитьЗапрос(<?>,,,,,,,)
Синтаксис:
ВыполнитьЗапрос(<НачалоПериода>,<КонецПериода>,<Счет>,<КоррСчет>,<Валюта>,<ТипИтогов>,<Периодичность>,<ТипСуммы>)
Назначение:
Выполнить отбор и расчет итогов по параметрам.
Возвращает число 1 -  запрос выполнен; 0 -  запрос не выполнен.
Параметры:
<ТипИтогов> - число - тип отбираемых итогов. Может принимать следующие значения: 1 - остатки и обороты по счету в целом; 2 - обороты между счетами; 3 - первое и второе вместе. По умолчанию: 1.

Попробуй поменять параметр "ТипИтогов"
   mistеr
 
4 - 23.07.19 - 11:07
(1) А что выводится?
   Work1
 
5 - 23.07.19 - 11:08
Спасибо.
   NikVars
 
6 - 23.07.19 - 11:16
(5) БИ.ИспользоватьСубконто("Плательщик"); 
Это что еще за субконто такое?
Из баланса
ИтСубк.ИспользоватьСубконто(ВидыСубконто.НематериальныеАктивы,, 1);

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.