Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Поддержка сертификата GOST R 34.10-2012 на старых (уже не поддерживаемых) конфигурациях 1с

Поддержка сертификата GOST R 34.10-2012 на старых (уже не поддерживаемых) конфигурациях 1с
Я
   Orenburg156
 
23.07.19 - 10:22
1с уже не поддерживает Зарплаты и кадры бюджетного учреждения (ЗКБУ) 1.0 (1.0.119.1). Соответственно там нет поддержки GOST R 34.10-2012, а только старый за 2001 год. Есть ли у кого ручная дописка модулей для данной конфигурации. Вручную пытался менять код в названиях алгоритмов и шифрований в модулях ДокументооборотСКонтролирующимиОрганами и РегламентированнаяОтчетность. Модули содержат много кода и собрать без ошибок не удалось. При получении ЭЛН из ФСС выдает ошибку 0x80090009 (80090009). Указан неверный алгоритм. Не удалось подписать файл запроса ЭЛН.

У кого есть измененные модули или подскажите где необходимо менять и на что. Буду очень благодарен.
 
 
   ptiz
 
1 - 23.07.19 - 10:28
(0) Платформа нужна с поддержкой ГОСТ 2012 - 8.3.12 и выше. Такая стоит?
   Orenburg156
 
2 - 23.07.19 - 10:34
(1) Да стоит. Есть такая же конфигурация но 2.0 там все прекрасно работает с новым гостом
   arsik
 
3 - 23.07.19 - 11:22
Может мешает режим совместимости? Сейчас какой в конфигурации стоит?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.