Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка "В обработчике не был сформирован табличный документ"

Ошибка "В обработчике не был сформирован табличный документ"
Я
   MegaBoom
 
23.07.19 - 08:49
Не могу понять в чем причина. Переделывала из типовой во внешнюю.
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
    ПараметрыРегистрации.Вставить("Назначение", ПолучитьНазначениеОбработки());
    ПараметрыРегистрации.Вставить("Наименование", НСтр("ru = 'УПД(Внешний)'"));
    ПараметрыРегистрации.Вставить("Версия", "1.1");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", НСтр("ru = 'УПД(Внешний)'"));
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    
    ДобавитьКоманду(ТаблицаКоманд,
    НСтр("ru = 'УПД'"),
    "УПД",
    "ВызовСерверногоМетода",
    Истина,
    "ПечатьMXL");
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    Возврат ПараметрыРегистрации;
        
КонецФункции
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    ЕстьСчетаФактурыВыданные = Ложь;
    ЕстьСчетаФактурыПолученные = Ложь;
    //МассивСФ = ПоискСФ(МассивОбъектов);

    
    Для каждого Объект Из МассивОбъектов Цикл
        Если ТипЗнч(Объект) = Тип("ДокументСсылка.СчетФактураВыданный") Тогда
            ЕстьСчетаФактурыВыданные = Истина;
            Прервать;
        ИначеЕсли ТипЗнч(Объект) = Тип("ДокументСсылка.СчетФактураПолученный") Тогда
            ЕстьСчетаФактурыПолученные = Истина;
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    ПараметрыПечати = Новый Структура;
    ПараметрыПечати.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", Ложь);
    ПараметрыПечати.Вставить("ИдентификаторВКомплекте", "УниверсальныйПередаточныйДокументКомплект");

    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "УПДСтатус2_981") Тогда
        ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов = "";
        Для каждого Объект Из МассивОбъектов Цикл
            Если ТипЗнч(Объект) <> Тип("ДокументСсылка.СчетФактураВыданный")
               И ТипЗнч(Объект) <> Тип("ДокументСсылка.СчетФактураПолученный") Тогда
                ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов =
                    Документы[Объект.Метаданные().Имя].ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов(Истина);
                Прервать;
            КонецЕсли;
        КонецЦикла;
        Если НЕ ПустаяСтрока(ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов) Тогда
            УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПД", "УПД",
                    ПечатьУниверсальныхПередаточныхДокументов981(МассивОбъектов, ОбъектыПечати,
                    ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов, Истина,,ПараметрыПечати ),,
                    "ПФ_MXL_УниверсальныйПередаточныйДокумент981");
        КонецЕсли;
    КонецЕсли;

Может в параметрах какие то ошибки?
 
 
   MegaBoom
 
1 - 24.07.19 - 08:23
разобралась) все работает

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.