Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как из формы выбора в УФ передать выделенные строки в обработку заполнения табл частей?

Как из формы выбора в УФ передать выделенные строки в обработку заполнения табл частей?
Я
   Босечка
 
22.07.19 - 11:12
выбирается только одна строка, как сделать передачу выделенных строк?
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Проведен", истина);
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Отбор", ПараметрыОтбора);
    ОткрытьФорму("Документ.РеализацияТоваровУслуг.ФормаВыбора", ПараметрыФормы, ЭтаФорма,,,, Новый ОписаниеОповещения("ВыполнитьПослеВыбора", ЭтаФорма),
        РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);                        
КонецПроцедуры    





&НаКлиенте
Процедура ВыполнитьПослеВыбора(ВыбранноеЗначение, Параметры) Экспорт
    
    ЗаполнитьПоВыбраннымДокументам(ВыбранноеЗначение);
    
    
КонецПроцедуры
 
 
   olegves
 
1 - 22.07.19 - 11:23
(0) в обработке выбора поместить массив структур с нужными полями строки во временное хранилище. Адрес хранилища возвращать в родительскую форму
   Cyberhawk
 
2 - 22.07.19 - 11:33
В параметры открываемой формы признак множественного выбора передать надо
   Босечка
 
3 - 22.07.19 - 11:41
(2) попробую, спасибо
   Босечка
 
4 - 22.07.19 - 13:54
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Проведен", истина);
    ПараметрыОтбора.Вставить("ЗакрыватьПриВыборе", ложь);
    ПараметрыОтбора.Вставить("МножественныйВыбор", истина);
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Отбор", ПараметрыОтбора);
    ОткрытьФорму("Документ.РеализацияТоваровУслуг.ФормаВыбора", ПараметрыФормы, ЭтаФорма,,,, Новый ОписаниеОповещения("ВыполнитьПослеВыбора", ЭтаФорма), 
    РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);                         
КонецПроцедуры    








&НаКлиенте
Процедура ВыполнитьПослеВыбора(ВыбранноеЗначение, Параметры) Экспорт
    
    ЗаполнитьПоВыбраннымДокументам(ВыбранноеЗначение);
    
    
КонецПроцедуры
   Босечка
 
5 - 22.07.19 - 13:55
все равно не получается, в выбранном значении ОДИН документ, а не массив
   Cyberhawk
 
6 - 23.07.19 - 09:43
Не туда суешь. ИТС поиск.
   lodger
 
7 - 23.07.19 - 10:22
(4) параметры неправильно собираешь.
в ПараметрыОтбора МножественныйВыбор ненужный есть
а в ПараметрыФормы МножественныйВыбор  нужный нету

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.