Вход | Регистрация
 

Как взять данные из регистра бухгалтерии и вывести параметры в печ форму?

Как взять данные из регистра бухгалтерии и вывести параметры в печ форму?
Я
   Айрат_116
 
19.07.19 - 17:00
Помогите как дальше писать?
Проводки = РегистрыБухгалтерии.Хозрасчетный.ВыбратьПоРегистратору(Ссылка);
     Пока Проводки.Следующий() Цикл
    ??    
    КонецЦикла;

Мне нужно получить сумму из регистра бух и вывести в печ форму
https://wampi.ru/image/60XJF9f
Помогите пжл
 
 
   shuhard
 
1 - 19.07.19 - 17:00
   Айрат_116
 
2 - 19.07.19 - 17:00
Или где есть пример? Гуглел , не нашел(
   Greeen
 
3 - 19.07.19 - 17:16
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    СУММА(ХозрасчетныйДвиженияССубконто.Сумма) КАК Сумма
        |ИЗ
        |    РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
        |            ,
        |            ,
        |            Регистратор = &Ссылка
        |                И СчетДт = &СчетДТ
        |                И СчетКт = &СчетКТ,
        |            ,
        |            ) КАК ХозрасчетныйДвиженияССубконто";
    
    Запрос.УстановитьПараметр("Ссылка", Ссылка); 
    Запрос.УстановитьПараметр("СчетДТ", СчетДТ);// Тута ссылку на 10.07

    Запрос.УстановитьПараметр("СчетКТ", СчетКТ);// Сдеся ссылку на 10.05

    
    РезультатЗапроса = Запрос.Выполнить();
        СуммаПроводки  = 0;
    Если РезультатЗапроса.Пустой() Тогда
        Сообщить ("Что то не то случилось");
    Иначе
        СуммаПроводки = РезультатЗапроса.Выгрузить()[0].Сумма;    
    КонецЕсли;
   Айрат_116
 
4 - 19.07.19 - 19:33
(3) Спасибо
   Айрат_116
 
5 - 20.07.19 - 10:33
Помогите что за ошибка 
Как правильно должно быть?

Неверные параметры в операции сравнения. Нельзя сравнивать поля
 неограниченной длины и поля несовместимых типов.
РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(, , Регистратор <<?>>= &Ссылка, , ) КАК ХозрасчетныйДвиженияССубконто
   hhhh
 
6 - 20.07.19 - 11:18
(5) ну наверно в &Ссылка не ссылку передаешь
   Айрат_116
 
7 - 20.07.19 - 14:14
Я в модуле менеджара (Документа.Дефект) пишу
 
Функция ПечатьОтчетДефект (Ссылка) Экспорт 
    
    Макет = Документы.тн_ДефектнаяВедомость.ПолучитьМакет("Дефект");
    Об = Макет.ПолучитьОбласть("Строка");
    ТабДок = Новый ТабличныйДокумент;
    
    
    Запрос = Новый Запрос;
    Запрос.Текст =     
      "ВЫБРАТЬ
     |    ХозрасчетныйДвиженияССубконто.Сумма КАК Сумма
     |ИЗ
     |    РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(, , Регистратор = &Ссылка, , ) КАК ХозрасчетныйДвиженияССубконто";
     Запрос.УстановитьПараметр("Ссылка",Ссылка);//Тут документ "ПередачаТовара" должно быть пробывал (ДДокументы.ПередачаТовара) 

     РезультатЗапроса = Запрос.Выполнить();
        СуммаПроводки  = 0;
    Если РезультатЗапроса.Пустой() Тогда
        Сообщить ("123");
    Иначе
        СуммаПроводки = РезультатЗапроса.Выгрузить()[0].Сумма;    
    КонецЕсли;
     
     Об.Параметры.Номер = Ссылка.Номер;

     Для каждого стр из Ссылка.Товар Цикл
    Об.Параметры.Номенклатура = стр.Номенклатура;
    Об.Параметры.Количество = стр.Количество; 
    ТабДок.Вывести(Об);
     
     КонецЦикла;
         
    
        Возврат ТабДок;
КонецФункции// ()
   hhhh
 
8 - 20.07.19 - 14:39
(7) может там наоборот тн_ДефектнаяВедомость. а не передача товара.
   Айрат_116
 
9 - 20.07.19 - 14:52
(8) Дефект доку создается на основе док передача товаров
   Айрат_116
 
10 - 20.07.19 - 14:53
(8) А надо взять движение с док "ПередачаТовара"
   hhhh
 
11 - 20.07.19 - 16:25
(10) да, поэтому не надо туда ссылку на тн_ДефектнаяВедомость
   Айрат_116
 
12 - 21.07.19 - 19:25
(11)  Вот так написал. Но никак не могу понять как получить движения док "ПередачаТоваров"
Щас сумма 0 пишет( 


СсылкаТов = Документы.ПередачаТоваров.НайтиПоНомеру("0б00-000102");
    Запрос = Новый Запрос;
    Запрос.Текст =     
      "ВЫБРАТЬ
     |    ХозрасчетныйДвиженияССубконто.Сумма КАК Сумма
     |ИЗ
     |    РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(, , Регистратор = &Ссылка, , ) КАК ХозрасчетныйДвиженияССубконто";
     Запрос.УстановитьПараметр("Ссылка",СсылкаТов);
     РезультатЗапроса = Запрос.Выполнить();
        СуммаПроводки  = 0;
    Если РезультатЗапроса.Пустой() Тогда
        Сообщить ("123");
    Иначе
        СуммаПроводки = РезультатЗапроса.Выгрузить()[0].Сумма;    
    КонецЕсли;
     
     Об.Параметры.Номер = Ссылка.Номер;
     Об.Параметры.Сумма = СсылкаТов.СуммаДокумента;
   Айрат_116
 
13 - 21.07.19 - 23:40
Что надо написать чтоб получить ссылку. Подскажите пжл.
СсылкаТов = Документы.ПередачаТоваров.ПолучитьСсылку(???);
   Айрат_116
 
14 - 22.07.19 - 10:53
(11) А как тогда ссылку документа "ПередачаТоваров" передать?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.