Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Показать элементы подчиненного справочника

Показать элементы подчиненного справочника
Я
   JuixyJes
 
19.07.19 - 09:12
На форме справочника Номера есть 2 табличных части. В первую выводятся элементы подчиненного справочника Комнаты, а во вторую нужно при активации строки вывести список элементов подчиненного справочника Койки, подчиненного Комнатам, как сделать в условии отбора для второй ТЧ Владельца - активную строку из 1 ТЧ?
 
 
   Mukrob
 
1 - 19.07.19 - 09:15
Правильно понимать..
Справочник.Номера
1.Таб.часть (Комнаты)
2.Таб.часть (Койки)

Койки должны быть связаны по комнатам? 

Можно выключить стандартную обработку и написать свой фильтр в начало выбора.
   Aleksey
 
2 - 19.07.19 - 09:21
посмотри в типовой
   JuixyJes
 
3 - 19.07.19 - 09:27
(1) Да, койки связаны по комнатам. А смысл в начале выбора? У меня при открытии справочника Номера ТЧ1 заполняется элементами справочника Комнаты. Как бы там же уже на Активацию строки нужно процедуру писать, как я поняла.
   JuixyJes
 
4 - 19.07.19 - 09:46
как говорит sqr4, дай клиенту время, сам решит свою проблему.
   JuixyJes
 
5 - 19.07.19 - 09:46
&НаСервере
Функция  КомнатыПриАктивизацииСтрокиНаСервере(ТекущиеДанные)
    Объект.Койки.Очистить();
    
    Выб = Справочники.Койки.Выбрать(,ТекущиеДанные);
    Пока Выб.Следующий() Цикл
        НСТР = Объект.Койки.Добавить();
        НСТР.Койка = Выб.Ссылка;
    КонецЦикла;
КонецФункции

&НаКлиенте
Процедура КомнатыПриАктивизацииСтроки(Элемент)
    ТекущиеДанные = Элементы.Комнаты.ТекущиеДанные;
    КомнатыПриАктивизацииСтрокиНаСервере(ТекущиеДанные.Комната);
КонецПроцедуры
   JuixyJes
 
6 - 19.07.19 - 09:47
Решила так
   sqr4
 
7 - 19.07.19 - 09:48
(4) о sqr4 еще говорит, даешь фото в купальнике.
   JuixyJes
 
8 - 19.07.19 - 09:52
(7) ахах, будет потеплее, то может быть) Но тогда подскажи мне, Вадим, могу ли я добавлять через обе ТЧ  записи в справочники Комнаты и Койки?
   zva
 
9 - 19.07.19 - 10:05
(6) Садись, два...
СП:
ПриАктивизацииСтроки (OnActivateRow)
Синтаксис:
ПриАктивизацииСтроки()
Описание:
Вызывается при активизации строки таблицы.
Примечание:
В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
   JuixyJes
 
10 - 19.07.19 - 10:06
(9) Но все же, оно работает. И функции вроде как вызываются вообще без Клиент/Сервер
   JuixyJes
 
11 - 19.07.19 - 10:08
(9) И работает к тому же замечательно. И все же, теперь возник вопрос. Как добавить новые элементы справочника при добавлении их в тч?
   hhhh
 
12 - 19.07.19 - 10:13
(11) методом нажимания пользователем на клавишу плюс там. Создать. Ты не поверишь. Пользователь нажимает на кнопку создать и элемент создается.
   zva
 
13 - 19.07.19 - 10:20
(10) Работает, работает, а потом бац и "ЗапонитьНадои" получаются...
https://forum.infostart.ru/forum9/topic216017/
   JuixyJes
 
14 - 19.07.19 - 10:24
(12) А автоматом указывать Владельца как будем?
   hhhh
 
15 - 19.07.19 - 10:29
(14) ну там у этого поля заполнить параметры выбора Владелец
   JuixyJes
 
16 - 19.07.19 - 10:42
(15) Ну и как я это сделаю? Владельцем является активная строка в тч1. при добавлении во 2 тч владельцем все еще является активная строка в тч1? Если так, то тогда как мне эту же строку сделать владельцем при создании нового элемента справочника?
   hhhh
 
17 - 19.07.19 - 11:02
(16) вы чего? издеваетесь? в параметрах выбора указывать.  это у вас уже мозг расплавился, пятница, отдохнуть надо.

Посмотрите в типовой поле договор, как связан с полем Контрагент.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.