Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка преобразование к типу Булево не может быть выполнено

Ошибка преобразование к типу Булево не может быть выполнено
Я
   Niraterra
 
18.07.19 - 13:42
Добрый день! выводит ошибку преобразования после того как добавила процедуру:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    Если ЭтотОбъект.ОтправитьНаСогласованиеДД и РежимЗаписи тогда
        ВыполнитьПроверки(Отказ);
        Если Не Отказ тогда            
            ПроцедураОбщегоМодуля.ОтправитьУведомление(, ЭтотОбъект.Ссылка, "ТекстСообщения") ;
            КонецЕсли;
    КонецЕсли;
КонецПроцедуры

что не так?
 
 
   Euguln
 
1 - 18.07.19 - 13:44
ДокументОбъект.<Имя документа> (DocumentObject.<Имя документа>)
ПередЗаписью (BeforeWrite)
Синтаксис:
ПередЗаписью(<Отказ>, <РежимЗаписи>, <РежимПроведения>)
Параметры:
<Отказ>
Тип: Булево.
Признак отказа от записи. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись выполнена не будет и будет вызвано исключение.
Значение по умолчанию: Ложь.
<РежимЗаписи>
Тип: РежимЗаписиДокумента.
В параметр передается текущий режим записи документа. Позволяет определить в теле процедуры режим записи. Изменение значения параметра позволяет изменить режим записи.
<РежимПроведения>
Тип: РежимПроведенияДокумента.
В данный параметр передается текущий режим проведения.
Изменение значения параметра позволяет изменить режим проведения.

РежимЗаписиДокумента (DocumentWriteMode)
Значения
Запись (Write)
ОтменаПроведения (UndoPosting)
Проведение (Posting)
Описание:
Определяет набор режимов записи документа.
   ИУБиПовиц
 
2 - 18.07.19 - 13:45
и РежимЗаписи.
По моему в этом:)
   ДенисЧ
 
3 - 18.07.19 - 13:45
Можно ещё вот так

https://yadi.sk/i/jjgMP8Rc2uy5hA
   PiotrLoginov
 
4 - 18.07.19 - 15:09
подозреваю, тип значения в ЭтотОбъект.ОтправитьНаСогласованиеДД - не Булево
   PiotrLoginov
 
5 - 18.07.19 - 15:09
аа стоп. тип значения РежимЗаписи - не Булево

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.