Вход | Регистрация
 

Как изменить значение в одном реквизите при выборе второго? Например

Как изменить значение в одном реквизите при выборе второго?  Например
Я
   Айрат_116
 
18.07.19 - 11:39
Доброй день. Подскажите как сделать так что бы

При выборе в реквизите "Наименование объекта" - (Выбираю из справочника)

В другом реквизите подставить значение "НаименованиеОбъекта.Код"  (Код нужно вывести в другой рекв)
 
 
   ДенисЧ
 
1 - 18.07.19 - 11:40
Ну так лови ПриИзменении и пиши что хочешь, куда хочешь.. Хоть оперу...
   Айрат_116
 
2 - 18.07.19 - 11:47
(1) При изменении  "Наименование объекта" писатть?
   Айрат_116
 
3 - 18.07.19 - 13:39
https://wampi.ru/image/60Kwf84   Как сделать привязку такую в табл части? Единица измерения (заполняется автоматически из справочника номенклатура)
   hhhh
 
4 - 18.07.19 - 13:49
(3) ну, операцией присваивания. А = В;
   Айрат_116
 
5 - 18.07.19 - 13:52
(4) Процедура ТоварНоменклатураПриИзмененииНаСервере()
    Объект.Товар.ЕдиницаИзмерения = Объект.Товар.Номенклатура; 
КонецПроцедуры

Пробывал так
   hhhh
 
6 - 18.07.19 - 14:01
(5) не объект.товар, а вы должны в текущей строке поменять. Посмотрите в типовой как сделано. ТекущиеДанные - это типа текущая строка.
   Айрат_116
 
7 - 18.07.19 - 14:03
(6) Я с запросом еще пробывал. тоже что то не идет(
   Айрат_116
 
8 - 18.07.19 - 14:10
(6) Для примера в каком документе можно посмотреть?
   piter3
 
9 - 18.07.19 - 14:13
(8) в любом
   Smile 8D
 
10 - 18.07.19 - 14:23
(3) Если данный реквизит нужен только для отображение и его редактирование не планируется, то правильнее будет просто через точку вынести его в табличное поле (т.е. справа раскрыть Номенклатуру, взять оттуда единицу измерения и вынести в левую часть).
   D_E_S_131
 
11 - 18.07.19 - 14:25
Если нужно отобразить Код номенклатуры из скриншота, то просто вытащите ее в колонки, раскрыв реквизит "Объект.Номенклатура".

А так для примера:

ТекДанные = Элементы.Товар.ТекущиеДанные;

Если ТекДанные = Неопределено Тогда
   Возврат;
КонецЕсли;

ТекДанные.ЕдиницаИзмерения = ПолучитьЕИСервер(ТекДанные.Номенклатура);

&НаСервереБезКонтекста
Функция ПолучитьЕИСервер(ВыбНоменклатура)

   Возврат ВыбНоменклатура.ОсновнаяЕдиницаИзмерения;

КонецФункции
   vicof
 
12 - 18.07.19 - 14:29
(0) Попробуй купить курсы для начинающих
   Айрат_116
 
13 - 18.07.19 - 14:39
(12) Купил уже
   piter3
 
14 - 18.07.19 - 14:39
(13)А прочитать не забыл?
   Айрат_116
 
15 - 18.07.19 - 14:41
(14) Читаю. Просто много моментов не непонятных бывает
   piter3
 
16 - 18.07.19 - 14:41
(15) Привыкай
   Айрат_116
 
17 - 18.07.19 - 14:44
(16) Сложно это
   Айрат_116
 
18 - 18.07.19 - 14:55
(11) Можно вопрос. В этой функции мы получаем единица измерения с справочника "Номенклатура"?
 Функция ПолучитьЕИСервер(ВыбНоменклатура)

   Возврат ВыбНоменклатура.ОсновнаяЕдиницаИзмерения;

КонецФункции
   piter3
 
19 - 18.07.19 - 14:56
(18) яяя
   vicof
 
20 - 18.07.19 - 14:58
(18) Смотря что находится в локальной переменной ВыбНоменклатура
   Айрат_116
 
21 - 18.07.19 - 15:02
Я щас попробывал просто раскрыть номенклатуру и от туда взять единицу. И вроде получилось
   Айрат_116
 
22 - 18.07.19 - 15:12
Всем спасибо)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.