Вход | Регистрация
 

1c com соединение метод выполнить не обнаружен

1c com соединение метод выполнить не обнаружен
Я
   inkvizitr
 
18.07.19 - 11:08
написал запрос, текс которого формируется динамически, когда доходит до выполнить, говорит нет такого метода, подключаюсь к базе через com, что не так делаю

Если ТипЗнч(СоединениеСЗУП) <> Тип("Неопределено") Тогда
        ЗапросСотрудникиЗУП = СоединениеСЗУП.NewObject("Запрос");
        Текст = "";
        КолСотрудниковВМассиве = СотрудникиБПТабНомера.Количество();
        Счетчик = 0;
        Для каждого СотрудникТабНомер Из СотрудникиБПТабНомера Цикл
            
            Если (КолСотрудниковВМассиве -1) = Счетчик Тогда
                Текст = Текст +
                "ВЫБРАТЬ
                |    СотрудникиОрганизаций.Ссылка КАК Ссылка,
                |    СотрудникиОрганизаций.Код КАК Код,
                |    СотрудникиОрганизаций.Наименование КАК Наименование
                |ИЗ
                |    Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций
                |ГДЕ
                |    СотрудникиОрганизаций.Код = """ + СотрудникТабНомер +"""";
            Иначе
                Текст = Текст +
                "ВЫБРАТЬ
                |    СотрудникиОрганизаций.Ссылка КАК Ссылка,
                |    СотрудникиОрганизаций.Код КАК Код,
                |    СотрудникиОрганизаций.Наименование КАК Наименование
                |ИЗ
                |    Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций
                |ГДЕ
                |    СотрудникиОрганизаций.Код = """ + СотрудникТабНомер +"""
                |
                |ОБЪЕДИНИТЬ ВСЕ
                |";
            КонецЕсли;
            Счетчик = Счетчик + 1;
        КонецЦикла;
        
        ЗапросСотрудникиЗУП.Текст = Текст;
        Выгрузка = ЗапросСотрудникиЗУП.Выполнить().Выгрузить();
    КонецЕсли;
 
 
   inkvizitr
 
1 - 18.07.19 - 11:11
текст запроса формируется правильно, косяк именно в  Выгрузка = ЗапросСотрудникиЗУП.Выполнить().Выгрузить(); почему то не находит метод "Выполнить"
   inkvizitr
 
2 - 18.07.19 - 11:20
вопрос решился, перезапуском конфигуратора

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.