Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

EDT и новая лицензия на Java от Oracle. Нужно ли теперь покупать Java?

EDT и новая лицензия на Java от Oracle. Нужно ли теперь покупать Java?
Я
   Lama12
 
18.07.19 - 09:57
Суть вопроса.
Нужно ли покупать Java Platform для использования с EDT?
Причины вопроса.
При обновлении установленной Java обнаружил, что изменилась лицензионное соглашение. Полез на сайт. Оказывается с 16 апреля этого года, Oracle "в одностороннем порядке" поменял лицензионное соглашение. Теперь бесплатно Java Platform можно использовать только не в коммерческих целях. Поскольку я не могу считать себя знатоком английского, то надеюсь на ошибку в переводе лицензионного соглашения. Вот ссылка на новое соглашение https://www.oracle.com/downloads/licenses/javase-license1.html
 
 
   ansh15
 
1 - 18.07.19 - 10:03
https://dl03.1c.ru/content/DevelopmentTools/1_11_0_738/1cv8upd_1_11_0_738.htm
"Начиная с 16 апреля 2019 года компания Oracle изменила условия лицензирования собственных дистрибутивов Oracle Java SE — подробнее, источник. Теперь для их использования в коммерческих продуктах требуется покупка лицензии.

Мы рекомендуем устанавливать платформу Java SE с помощью свободного бесплатного пакета OpenJDK. Подробнее об установке OpenJDK вы можете прочитать в разделе Как установить Java."
   Asmody
 
2 - 18.07.19 - 10:05
Не обязательно. Но если очень хочется, то можно. https://habr.com/ru/post/424725/
   Cyberhawk
 
3 - 18.07.19 - 10:05
Есть Оракл ЖДК, есть Опен ЖДК. Первый стал платным и поддерживается долго, второй бесплатен, но с коротким сроком поддержки.
   Asmody
 
4 - 18.07.19 - 10:09
Кого стремает скачать OpenJDK, берите питерскую сборку Liberica JDK (https://bell-sw.com/pages/java-12.0.1/). Тот же OpenJDK, но, как уверяют ребята, "всё проверено за вас".
   Garykom
 
5 - 18.07.19 - 10:14
(4) А сборщик мобильных на ней работает как и Android SDK ?
   Sserj
 
6 - 18.07.19 - 10:16
(4) EDT не установится с JDK выше 10. В 11-ой удалили пакет java.xml.bind. Можно пошаманить и в ручную этот пакет подпихнуть из предыдущих, но кому это нужно :)
   Lama12
 
7 - 18.07.19 - 10:27
(2) Хм... забавно. У нас есть Atlassian. Пару недель назад писали им вопрос по какой-то ошибке. Они ответили что для исправления ошибки нужно обновить Java. Но в ответе фигурировал один момент. Они сказали что нужно использовать коммерческую версию Java. Против бесплатной они ничего не имеют, но не могут гарантировать работу своих продуктов при ее использовании.
   Cyberhawk
 
8 - 18.07.19 - 10:28
(7) Не ссы - коммерческая от открытой отличается конечно, но не так сильно. Сам Оракл вливает в опен-ветку исправления и обновления. Так что Атлассы просто перестраховываются, либо экономят не тестировании, ну или тупо политика у них такая - зачем тебе коммерческий продукт без коммерческой Жабы.
   Lama12
 
9 - 18.07.19 - 10:29
(8) Понял :-) Спасибо.
   bolero
 
10 - 18.07.19 - 11:09
(7) это вот из тех, кто до последнего цеплялся за модель поддержки "наше суперг работает только с илитной жавой отцов-основателей, хотите openjdk - ваши проблемы".

Intellij где-то год-два назад тоже так думали, а потом просто переключились диаметрально противоположно - теперь гарантируется только на openjdk
   Asmody
 
11 - 19.07.19 - 11:16
(6) А о чем тогда сыр-бор? Изменения лицензирования, насколько я понимаю, касается версий 11 и выше.
   rphosts
 
12 - 19.07.19 - 11:27
(5)Самому интересно. Когда-то нужен был лишь Java SDK (Java SE)... но альтернативы тоже должны быть годны. Если есть всё под рукой - попробуй и отпиши плиз: получилось или нет.
   Конструктор1С
 
13 - 19.07.19 - 11:32
Вот жеж... Некоторые 1сники не заморачиваются даже покупкой 1с, а ты про жаву спросил

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.