Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УПП 1.3.123.2 Не печатает из ПКО в чеке ККМ Наименование и ИНН покупателя (ШтрихМ)

УПП 1.3.123.2 Не печатает из ПКО в чеке ККМ Наименование и ИНН покупателя (ШтрихМ)
Я
   Kleo
 
18.07.19 - 05:15
Здравствуйте!

Обновили релиз УПП 1.3.123.2. Касса-онлайн с ОФД ШтрихМ, последний драйвер 4.14.772,  уже с обновленной интеграционной компонентой, Тэги 1227 и 1228 (Наименование и ИНН покупателя) в самом фискальном регистраторе включены как обязательные, согласна рекомендациям, полученным от ШтрихМ. И при печати Чека ККМ из ПКО юрлицу или ИП в чеке отсутствуют эти реквизиты Наименование и ИИН покупателя. Попробовали Корректировки долга печать чека ККМ, все отлично, вышли и Наименование покупателя и ИНН покупателя.

Подскажите, пожалуйста, кто сталкивался с такой проблемой? Может что-то нужно настроить? В ПКО указываем Заказ покупателя, может нужно Реализацию товаров и услуг, или может нужно включить в договоре Ведение взаиморасчетов включить флажок "По документам расчетов"? Может в коде что-то дописать? Я пробовала, но у меня ошибки выходили при печати чека из 1С... Трудно... эмулятор не нашла нормальный, чтобы можно было отладчиком пройтись. Модулей много, параметры прописаны эти вроде.
 
 
   Kleo
 
1 - 18.07.19 - 05:31
В общем модуле МенеджероборудованияВызовСервера - Процедура СформироватьXMLПакетДляФискализацияЧека

указано:

Если ПараметрыФискализации.РевизияИнтерфейса >= 3000 Тогда  // Версия стандарта 3.0 (ОФД 1.1)

        ЗаписьXML.ЗаписатьНачалоЭлемента("Parameters");
        ЗаписьXML.ЗаписатьАтрибут("CashierName",  XMLСтрока(ОбщиеПараметры.Кассир));
        Если Не ПустаяСтрока(ОбщиеПараметры.КассирИНН) Тогда 
            ЗаписьXML.ЗаписатьАтрибут("CashierINN", XMLСтрока(ОбщиеПараметры.КассирИНН));
        КонецЕсли;
        ЗаписьXML.ЗаписатьАтрибут("OperationType", XMLСтрока(ТипРасчета));
        ЗаписьXML.ЗаписатьАтрибут("TaxationSystem" , XMLСтрока(СистемаНалогообложения));
        
        Если Не ПустаяСтрока(ОбщиеПараметры.ОтправительEmail) И Электронно Тогда// Отправитель Email указывается только для Электронно.

            ЗаписьXML.ЗаписатьАтрибут("SenderEmail", XMLСтрока(ОбщиеПараметры.ОтправительEmail));
        КонецЕсли;
        
        Если ОбщиеПараметры.Свойство("АдресРасчетов") И НЕ ПустаяСтрока(ОбщиеПараметры.АдресРасчетов) Тогда   
            ЗаписьXML.ЗаписатьАтрибут("SaleAddres", XMLСтрока(ОбщиеПараметры.АдресРасчетов));
        КонецЕсли;
        Если ОбщиеПараметры.Свойство("МестоРасчетов") И НЕ ПустаяСтрока(ОбщиеПараметры.МестоРасчетов) Тогда  
            ЗаписьXML.ЗаписатьАтрибут("SaleLocation", XMLСтрока(ОбщиеПараметры.МестоРасчетов));
        КонецЕсли;
        
        // Email отправляет средствами 1C

        Если ОбщиеПараметры.Свойство("Отправляет1СEmail") И НЕ ОбщиеПараметры.Отправляет1СEmail Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerEmail", XMLСтрока(?(ОбщиеПараметры.Свойство("ПокупательEmail"), ОбщиеПараметры.ПокупательEmail, "")));
        КонецЕсли;
        // SMS отправляет средствами 1C

        Если ОбщиеПараметры.Свойство("Отправляет1СSMS") И НЕ ОбщиеПараметры.Отправляет1СSMS Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerPhone", XMLСтрока(?(ОбщиеПараметры.Свойство("ПокупательНомер"), ОбщиеПараметры.ПокупательНомер, "")));
        КонецЕсли;
        
        Если Не ПустаяСтрока(ОбщиеПараметры.Получатель) Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerInfo", XMLСтрока(ОбщиеПараметры.Получатель));
        КонецЕсли;
        Если Не ПустаяСтрока(ОбщиеПараметры.ПолучательИНН) Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerINN", XMLСтрока(ОбщиеПараметры.ПолучательИНН));
        КонецЕсли;
        
        Если ОбщиеПараметры.Свойство("ПризнакАгента") И НЕ ПустаяСтрока(ОбщиеПараметры.ПризнакАгента) Тогда
            ПризнакАгента = МенеджерОборудованияКлиентСервер.КодПризнакаАгента(ОбщиеПараметры.ПризнакАгента);
            ЗаписьXML.ЗаписатьАтрибут("AgentType", XMLСтрока(ПризнакАгента));
        КонецЕсли;
        
        Если ОбщиеПараметры.Свойство("ДополнительныйРеквизит") И НЕ ПустаяСтрока(ОбщиеПараметры.ДополнительныйРеквизит) Тогда  
            ЗаписьXML.ЗаписатьАтрибут("AdditionalAttribute", XMLСтрока(ОбщиеПараметры.ДополнительныйРеквизит));
        КонецЕсли;
        
        Если ОбщиеПараметры.Свойство("ДанныеКоррекции") Тогда
            ЗаписатьДанныеКоррекции(ЗаписьXML, ОбщиеПараметры.ДанныеКоррекции);
        КонецЕсли;
.....

далее:

ИначеЕсли ПараметрыФискализации.РевизияИнтерфейса > 2001 Тогда  // Версия стандарта 2.2 и выше

        
        ЗаписьXML.ЗаписатьНачалоЭлемента("Parameters");
        ЗаписьXML.ЗаписатьАтрибут("PaymentType" , XMLСтрока(ТипРасчета));
        ЗаписьXML.ЗаписатьАтрибут("TaxVariant"  , XMLСтрока(СистемаНалогообложения));
        ЗаписьXML.ЗаписатьАтрибут("CashierName" , XMLСтрока(ОбщиеПараметры.Кассир));
        ЗаписьXML.ЗаписатьАтрибут("CashierVATIN", ?(ОбщиеПараметры.Свойство("КассирИНН"), XMLСтрока(ОбщиеПараметры.КассирИНН), ""));
        Если Не ПустаяСтрока(ОбщиеПараметры.ОтправительEmail) И Электронно Тогда// Отправитель Email указывается только для Электронно.

            ЗаписьXML.ЗаписатьАтрибут("SenderEmail", XMLСтрока(ОбщиеПараметры.ОтправительEmail));
        КонецЕсли;
        // Email отправляет средствами 1C

        Если ОбщиеПараметры.Свойство("Отправляет1СEmail") И НЕ ОбщиеПараметры.Отправляет1СEmail Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerEmail", XMLСтрока(?(ОбщиеПараметры.Свойство("ПокупательEmail"), ОбщиеПараметры.ПокупательEmail, "")));
        КонецЕсли;
        // SMS отправляет средствами 1C

        Если ОбщиеПараметры.Свойство("Отправляет1СSMS") И НЕ ОбщиеПараметры.Отправляет1СSMS Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerPhone", XMLСтрока(?(ОбщиеПараметры.Свойство("ПокупательНомер"), ОбщиеПараметры.ПокупательНомер, "")));
        КонецЕсли;
            
        Если ОбщиеПараметры.Свойство("ПризнакАгента") И НЕ ПустаяСтрока(ОбщиеПараметры.ПризнакАгента) Тогда  // Атрибут с ФФД 1.0.5 

            ПризнакАгента = МенеджерОборудованияКлиентСервер.КодПризнакаАгента(ОбщиеПараметры.ПризнакАгента);
            ЗаписьXML.ЗаписатьАтрибут("AgentSign", XMLСтрока(ПризнакАгента));
        КонецЕсли;
        
        Если ОбщиеПараметры.Свойство("АдресРасчетов") И НЕ ПустаяСтрока(ОбщиеПараметры.АдресРасчетов) Тогда   
            ЗаписьXML.ЗаписатьАтрибут("AddressSettle", XMLСтрока(ОбщиеПараметры.АдресРасчетов));
        КонецЕсли;
        Если ОбщиеПараметры.Свойство("МестоРасчетов") И НЕ ПустаяСтрока(ОбщиеПараметры.МестоРасчетов) Тогда  
            ЗаписьXML.ЗаписатьАтрибут("PlaceSettle", XMLСтрока(ОбщиеПараметры.МестоРасчетов));
        КонецЕсли;
        
        Если ОбщиеПараметры.Свойство("ДополнительныйРеквизит") И НЕ ПустаяСтрока(ОбщиеПараметры.ДополнительныйРеквизит) Тогда  
            ЗаписьXML.ЗаписатьАтрибут("AdditionalAttribute", XMLСтрока(ОбщиеПараметры.ДополнительныйРеквизит));
        КонецЕсли;
        
        ЗаписатьДанныеАгента(ЗаписьXML, ОбщиеПараметры.ДанныеАгента);
        ЗаписатьДанныеПоставщика(ЗаписьXML, ОбщиеПараметры.ДанныеПоставщика);
        
        ЗаписьXML.ЗаписатьКонецЭлемента();


У нас 100% заходит во второе условие. пробовала во втором условии добавить строки, как для ОФД 1.1, но он ругается при печати обычных Чеков ККМ в розницу.
   Kleo
 
2 - 18.07.19 - 05:32
вот эти поля добавляла во второе условие:

Если Не ПустаяСтрока(ОбщиеПараметры.Получатель) Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerInfo", XMLСтрока(ОбщиеПараметры.Получатель));
        КонецЕсли;
        Если Не ПустаяСтрока(ОбщиеПараметры.ПолучательИНН) Тогда
            ЗаписьXML.ЗаписатьАтрибут("CustomerINN", XMLСтрока(ОбщиеПараметры.ПолучательИНН));
        КонецЕсли;


Обратились в ЦТО, они сказали, что ОФД 1.1 пока нет
   CHerypga
 
3 - 18.07.19 - 07:46
123.2 явно уже не в моде, т.к есть 123.3

еще была ветка Новая УПП требует 8.3.12.
и в ней, если мне не изменяет память, речь шла не только про платформу
   Kleo
 
4 - 18.07.19 - 08:45
(3) у нас 8.3.13 и УПП 1.3.123.3 сравнила, там именно по данному вопросу нет изменений
   yavasya
 
5 - 18.07.19 - 08:54
(4) мы выдрали драйвер из бпо, вставили его в компаненту и содрали некоторые измнения из бпо, универсальныйдрайверклиент,менеджер оборудования вызовсервера и взлетело
   vvspb
 
6 - 18.07.19 - 08:58
(0) в чеке отсутствуют эти реквизиты Наименование и ИИН покупателя\\\ за отсутствие ИНН уже штрафовать будут?
   yavasya
 
7 - 18.07.19 - 08:59
(6) если будет проверка, а так нет
   CHerypga
 
8 - 18.07.19 - 09:19
в 123.3. заявлено что исправлена ошибка 00-00226573
Описание:
Не печатаются новые реквизиты "Получатель" и "ИНН получателя" из ПКО

Способ обхода:
Эти реквизиты не являются обязательными

Способ исправления:
1. Обновить подсистему БПО до 2.1.1.23.
2. Обновить  обработку обслуживания ККТ АТОЛ до работы с драйвером 10.5.0
   yavasya
 
9 - 18.07.19 - 09:21
(8) это ты по описанию или сам делал? вообще инн и наименование обязательные
   CHerypga
 
10 - 18.07.19 - 09:51
(9) открыл https://bugboard.v8.1c.ru/version/upp1/1.3.123.3 и скопировал сюда
   vvspb
 
11 - 18.07.19 - 10:25
(9) инн и наименование обязательные\\\на основании чего?
   karpik666
 
12 - 18.07.19 - 10:36
(1) у меня лично все клиенты уже не заморачиваются с обновлениями, если нужно передавать инн попупателя, то передают.
   rbcvg
 
13 - 18.07.19 - 10:41
У нас взлетело после добавления в общий модуль МенеджерОборудованияВызовСервера в процедуру ПодготовитьДанныеДляФискализацииЧека:

Процедура ПодготовитьДанныеДляФискализацииЧека(Ссылка, ОбщиеПараметры, ВерсияФормата, ТО, КомуОтКого, Основание) Экспорт
    
    Если ОбщиеПараметры = Неопределено Тогда
        ОбщиеПараметры = МенеджерОборудованияКлиентСервер.ПараметрыОперацииФискализацииЧека();
    КонецЕсли;
    // КС+

    Попытка
        Если ТипЗНЧ(Ссылка.Контрагент) = Тип("СправочникСсылка.Контрагенты") Тогда
            ОбщиеПараметры.Получатель = Ссылка.Контрагент.НаименованиеПолное;
            ОбщиеПараметры.ПолучательИНН = Ссылка.Контрагент.ИНН;
        КонецЕсли;
    Исключение
    КонецПопытки;
    // КС-
   Kleo
 
14 - 18.07.19 - 10:51
(6) и (7) кто его знает... может и будут.. но лучше, чтобы были!
(8) у нас ШтрихМ - драйвер и прошивка - все самое последнее 4.14.772
(13) Спасибо! Попробую! У вас тоже УПП 1.3.123.2?
   vvspb
 
15 - 18.07.19 - 10:52
+(11) Реквизиты "покупатель (клиент)" (тег 1227) и "ИНН покупателя (клиента)" (тег 1228) включаются в состав кассового чека (БСО) с 01.07.2019. \\\ это из ПИСЬМО
от 20 февраля 2019 г. N ЕД-4-20/2929@ в 54-ФЗ этого нет?
   rbcvg
 
16 - 18.07.19 - 10:56
(14) "У вас тоже УПП 1.3.123.2?" - да.
   karpik666
 
17 - 18.07.19 - 11:01
(14) штрихм все поддерживает, проблема не в нем, если потребуется еще вывод на печать, то на штрихе нужно включить "Автопечать тегов".
   Kleo
 
18 - 22.07.19 - 08:20
(17) включено уже давным давно. думаю, что дело в релизе УПП 1.3.123.2, много ошибок. такое ощущение, что даже не тестируют, после этого обновления даже при открытии документов куча ошибок... ну как так? вообще не проверяют?
   vvspb
 
19 - 22.07.19 - 08:23
(18) проверяют, на кошках :(
На пользователях
   d4rkmesa
 
20 - 22.07.19 - 08:25
(18) Тестеров содержать накладно. )
   Kleo
 
21 - 22.07.19 - 08:28
(19) такого количества ошибок не припомню ни на одном релизе. при этом двойная оплата за ИТС. ну если поддержка существует, да еще с двойной оплатой, то неужели нужно такие релизы выпускать нужно? Что даже документ после обновления не зашли и не открыли... Корректировка реализации вообще не проводилась. Вышел релиз 1.3.124. Чек еще пробивать не пробовали. Посмотрим, будет или нет печатать ИНН и наименование покупателя из ПКО
   Kleo
 
22 - 22.07.19 - 08:30
(20) да причем тут тестеры. Добавили изменения в документ Корректировка реализации, допустили ошибку в общем модуле в процедуре проведения Корректировки реализации, ну вы же добавили изменения по комплектам, так зайдите и проведите документ. Или можно вообще написать знаки любые и будь что будет....
   DmVl76
 
23 - 22.07.19 - 08:50
(19) Обновление просто большое очень, а так подобные детские ошибки тянутся где-то с конца прошлого года (больше всего запомнилось: вместо НДС20 стало после нового года биться БезНДС, я правда выловил еще до Нового года, а они исправили числа 15-го только)
   d4rkmesa
 
24 - 22.07.19 - 09:11
(22) >>да причем тут тестеры.

)) Притом, что тестируют тестеры, конечно, если они есть. А автотесты все не покрывают, особенно в случае с УПП. А чего жаловаться? Я, благо регл. отчетность и Маркировка с ЕГАИС не нужны, отказался от платных обновлений, после того как увидел, что там за хлам в коде. Если это невозможно, ну что ж, жрать кактус не привыкать. Мы же тут все по большей части вроде как программисты, верно?
   Kleo
 
25 - 22.07.19 - 10:39
(24) так а программист вообще режим предприятия не открывает? Сейчас все обновления нужны, т.к. элементарно онлайн-кассы. Мы ведем весь учет. Соответственно, все изменения законодательства нужны
   d4rkmesa
 
26 - 22.07.19 - 11:08
(25) Сложно сказать, как "там" это работает. Может и не открывает. Или открывает, но ошибка не воспроизводилась. У меня такое было с теми же корректировками из-за разных настроек учетной политики, к примеру.
"элементарно онлайн-кассы" - онлайн-кассы пока еще можно поддерживать, имея в качестве базового релиз 1.3.99, к примеру. Ну ладно, не буду агитировать, может у вас в одном флаконе регл. учет + розница в алко-обувной сети магазинов. =)
   la luna llena
 
27 - 22.07.19 - 12:37
между тем тестируем 124
   Kleo
 
28 - 23.07.19 - 06:56
(26) у меня есть все, что сейчас нужно обновить, ведется все в базе!
В "Корректировка реализации" нужно было в Общем модуле "УправлениеЗапасамиПартионныйУчет" в Процедура ПроведениеКорректировкиРеализации

добавить строки:
...
ТаблицаПартийБУ = СтруктураПараметров.ТаблицаСписанныхПартий.Скопировать(СтруктураПараметров.ТаблицаСписанныхПартий.НайтиСтроки(Отбор));
            ТаблицаПартийБУ.Колонки.Добавить("Комиссионный");
            Для Каждого СтрокаСписания Из ТаблицаПартийБУ Цикл
                СтрокаСписания.Комиссионный = (СтрокаСписания.СчетУчета = СтрокаСписания.ПринятыеСчетУчетаБУ);
                СтрокаСписания.Количество = СтрокаСписания.Движение.Количество;
                Если СтрокаСписания.ВидОперации = "Возврат" Тогда
                    СтрокаСписания.СуммаВыручкиБУ         = - СтрокаСписания.СуммаВыручкиБУ;
                    СтрокаСписания.СуммаНДСВыручкиБУ     = - СтрокаСписания.СуммаНДСВыручкиБУ;
                    Если СтрокаСписания.ТипЗаписи = "Сторно" Тогда
                        СтрокаСписания.Количество             = - СтрокаСписания.Количество;
                        СтрокаСписания.Стоимость             = - СтрокаСписания.Стоимость;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;
            
            Отбор = Новый Структура("НомерСтрокиДокумента, ОтражатьВНалоговомУчете", СтрокаТЧ.НомерСтроки, Истина);
...

Этих строк элементарно не ыбло, их просто забыли... и в итоге при проведении ерунда получалась и документ не проводился. в 1.3.124.1 исправили эту ошибку
   Kleo
 
29 - 23.07.19 - 06:56
(27) Да, сегодня буду проверять!
   Kleo
 
30 - 23.07.19 - 07:01
а по поводу печати Наименования и ИНН покупателя в чеке из ПКО, скорее всего ошибка решается следующим кодом в модуле формы Обработки "Предпросмотр чека" в Процедуре ПослеОбработкиСостоянияСмены:

Если ТипЧека = "Чек" Тогда
        МенеджерОборудованияВызовСервера.ПодготовитьДанныеДляФискализацииЧека(ДокументСсылка, ПараметрыОперацииФискализацииЧека, ВерсияФФД, 
                ККТ, ?(ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПриходныйКассовыйОрдер"), ДокументСсылка.ПринятоОт, ДокументСсылка.Контрагент.Наименование), 
                ?(ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПриходныйКассовыйОрдер"), ДокументСсылка.Основание, 
                ?(ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОплатаОтПокупателяПлатежнойКартой"), ДокументСсылка, ДокументСсылка.ДоговорКонтрагента.Наименование)));
//добавить это:

        СтруктураРеквизитов = Новый Структура;
        СтруктураРеквизитов.Вставить("Контрагент");
        РеквизитыДокумента = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ДокументСсылка, СтруктураРеквизитов);
        ПодключаемоеОборудованиеУТ.ЗаполнитьДанныеПокупателя(ПараметрыОперацииФискализацииЧека, РеквизитыДокумента);
        Результат = ОбработкаОбслуживания.ФискализироватьЧек(ОбъектДрайвера, ПараметрыОперацииФискализацииЧека);
 
 Рекламное место пустует
   Вадя
 
31 - 23.07.19 - 08:47
(30) Эта добавочка в обработку Предпросмотр чека появилась в релизе 123.3

Задам свой вопрос: как напечатать чек коррекции с видом Исправление ошибки из Платежного поручения входящего ??? В типовой конфигурации упп 123.3 можно печатать только чек с видом Неприменение ККТ.
А если ошибка и чек нужно перепечатать ???


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.