Вход | Регистрация
 

ERP - Бесшовная интеграция с ДО - Прерывание процесса согласования

ERP - Бесшовная интеграция с ДО - Прерывание процесса согласования
Я
   zett
 
17.07.19 - 15:50
Добрый день!
В ERP настроен обмен документов по бесшовной интеграции с ДО. В ERP стартую процесс "Согласования" документа, затем в ДО нахожу этот документ и нажимаю "Прервать" выполнение этого процесса.
В ERP захожу в этот документ и нажимаю гиперссылку "Документооборот" и вижу на закладке "Процессы и задачи" дерево процесса, В КОТОРОМ НЕ ОТОБРАЖАЕТСЯ на задачах процесса пиктограмма, о том что процесс задач был "ПРЕРВАН".
Я могу зайти в любую задачу этого дерева в документе ERP и мне будут доступны кнопки согласования, хотя процесс был прерван в ДО.
Кто нибудь сталкивался с такой проблемой? Релизы ERP и ДО последние.
 
 
   zett
 
1 - 17.07.19 - 16:53
Похоже - это не автоматизировано ЗАО 1С.
   Xapac
 
2 - 17.07.19 - 16:55
(0)может кнопку обновить надо нажать?
   zett
 
3 - 17.07.19 - 17:14
Нажимал, не помагает. А вообще в ERP в перечислении "СостоянияБизнесПроцессов" нет значения "Прерван", есть только "Остановлен" и "Активен". Отсюда делаю вывод, что это не автоматизировано.
   zett
 
4 - 17.07.19 - 17:23
Придется самому доработать XDTO-пакет "DMBusinessProcess" в ДО и обработку состояния "Прерван" в ERP.
   zett
 
5 - 19.07.19 - 09:50
В итоге:
Добавил в колекцию картинки РезультатыВыполненияПроцессовИЗадачКоллекция - две иконки "Прерван" и "Остановлен" - по аналогии с ДО.
В процедуру ПостроитьДеревоЗадачИзОтветаВебСервиса пришлось вставить следующий код (после типового определения иконки) для отображения прерывания и остановки процесса:
После 1-ого типового определение иконки:
            Если ОднаСтрокаОтвета.Установлено("tasks") И ОднаСтрокаОтвета.tasks.Количество() > 0 И 
                                ОднаСтрокаОтвета.tasks[0].Свойства().Получить("state") <> Неопределено
                И ОднаСтрокаОтвета.tasks[0].state.Свойства().Получить("name") <> Неопределено Тогда
                Если ОднаСтрокаОтвета.tasks[0].state.name = "Прерван" Тогда
                    НоваяСтрока.Картинка = 5;
                КонецЕсли;
                Если ОднаСтрокаОтвета.tasks[0].state.name = "Остановлен" Тогда
                    НоваяСтрока.Картинка = 6;
                КонецЕсли;
            КонецЕсли;


После 2-ого типового определение иконки:
                    Если ОднаСтрокаОтвета.Установлено("state") И 
                                                ОднаСтрокаОтвета.state.Свойства().Получить("name") <> Неопределено Тогда
                        Если ОднаСтрокаОтвета.state.name = "Прерван" Тогда
                            НоваяСтрока.Картинка = 5;
                        КонецЕсли;
                        Если ОднаСтрокаОтвета.state.name = "Остановлен" Тогда
                            НоваяСтрока.Картинка = 6;
                        КонецЕсли;
                    КонецЕсли;


И при открытии прерванной задачи в ERP настроил недоступность формы.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.