Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1c 8 Торговля и склад . Права пользователей

1c 8 Торговля и склад . Права пользователей
Я
   JuliaT99
 
17.07.19 - 13:24
Уважаемые специалисты!  Дело в том, что у нас куча наших прописанных ролей . Методом проб и ошибок замечено, что пользователь с нашими ролями входит в систему, если у него строят еще типовые роли "Полный просмотр" или "Пользователь". Но не всем хочется давать "Полный просмотр", а в роли "Пользователь" есть доступ к справочнику "Контрагенты", что в некоторых случаях тоже нежелательно. Корректировать эти роли тоже нецелесообразно, чтобы не заморачиваться при обновлениях. Так вот,подскажите пожалуйста, какие необходимые права, на какие объекты метаданных нужно дать пользователю, чтобы он просто вошел в систему?
 
 
   ДенисЧ
 
1 - 17.07.19 - 13:48
"Пользователь" прописан в конфигурации, при старте, проверяется его наличие. Так что или править роль, или править код.
   Mukrob
 
2 - 17.07.19 - 13:53
(0) в свойствах новой роли, самая первая строка конфигурации
разрешить запуск тонкого или толстого клиента по ситуации
и по аналогии добавить на остальные которые нужны.
   JuliaT99
 
3 - 17.07.19 - 14:11
2 - запуск тонкого или толстого клиента во всех ролях стоит
   Mukrob
 
4 - 17.07.19 - 14:13
(3) тонкого или толстого? ;-) в каких всех? а в той что новую создали тоже есть?
   JuliaT99
 
5 - 17.07.19 - 14:13
1 - А как тогда работают пользователи у которых роли "Пользователь" нет , роль "Полный просмотр" есть. Я же написала в первом посте : "ИЛИ"
   ДенисЧ
 
6 - 17.07.19 - 14:13
(2) Мимо
   Mukrob
 
7 - 17.07.19 - 14:15
(5) я ничего не понял, сделайте скриншот с набором ролей пользователя, и правами доступа по этим ролям.
   JuliaT99
 
8 - 17.07.19 - 14:15
4 да во всех новых тоже.
   Mukrob
 
9 - 17.07.19 - 14:16
(8) а сообщение при запуске какое выходит?
   ДенисЧ
 
10 - 17.07.19 - 14:18
(5)
Процедура ПередНачаломРаботыСистемы(Отказ)
    
    ПараметрыПриложения = Новый Соответствие;
    
    Если НЕ РольДоступна("Пользователь")
        И (НЕ РольДоступна("ПолныеПрава")) Тогда
        
        Предупреждение("Вам не назначена роль ""Пользователь"". Запуск конфигурации невозможен.");
        Отказ = Истина;
        Возврат;
    КонецЕсли;
   ДенисЧ
 
11 - 17.07.19 - 14:18
Ещё вопросы?
   JuliaT99
 
12 - 17.07.19 - 14:33
Процедура ПередНачаломРаботыСистемы(Отказ)    
    
    УправлениеПользователями.ПроверитьВозможностьРаботыПользователя(Отказ);    
    
    Если Не Отказ Тогда
        // СтандартныеПодсистемы

        СтандартныеПодсистемыКлиент.ДействияПередНачаломРаботыСистемы(Отказ);
        // Конец СтандартныеПодсистемы

        
        // ПодключаемоеОборудование

        МенеджерОборудованияКлиент.ПередНачаломРаботыСистемы();
        // Конец ПодключаемоеОборудование

        
    КонецЕсли;
    
КонецПроцедуры
   JuliaT99
 
13 - 17.07.19 - 14:33
Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт

    Если НЕ ПолныеПрава.ЕстьДоступныеПраваДляЗапускаКонфигурации() Тогда
        Отказ = Истина;
        #Если Клиент Тогда

        Предупреждение("У текущего пользователя нет доступных ролей, для запуска информационной базы.", 10, "Недостаточно прав доступа");
        #КонецЕсли

    КонецЕсли; 
    
КонецПроцедуры
   JuliaT99
 
14 - 17.07.19 - 14:33
13 - сообщение такое
   ДенисЧ
 
15 - 17.07.19 - 14:35
А в ПолныеПрава.ЕстьДоступныеПраваДляЗапускаКонфигурации() заглянуть?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.