Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Программное заполнение формулы в Excel криво срабатывает

Программное заполнение формулы в Excel криво срабатывает
Я
   КонецЦикла
 
17.07.19 - 09:37
Пишу вот так в 1С

ЯчейкаФормулы = ExcelЛист.Cells(ПерваяСтрокаДанных + КолвоСтрок, КолонкаСуммаСтроки);
ЯчейкаФормулы.Formula = "=СУММ(R[-" + Строка(КолвоСтрок) + "]C:R[-1]C)";

Уже чего только не делал... и копировал тупо уже из готовой формулы, в общем все знаки точные
Абсолютные ссылки тоже не работают
При открытии файла вместо формулы появляется #ИМЯ?
Т.е. типа ошибка в СУММ
Становлюсь на формулу в строке формул, нажимаю Ввод - все ок, считает
 
 
   КонецЦикла
 
1 - 17.07.19 - 09:40
*вместо формулы - вместо результата суммы
   catena
 
2 - 17.07.19 - 09:48
А если .FormulaR1C1 = ?
   КонецЦикла
 
3 - 17.07.19 - 10:25
(2) то же самое
   КонецЦикла
 
4 - 17.07.19 - 10:28
Причем в той же обработке
ЯчейкаФормулы.Formula = "=RC[-1]*RC[-3]";
срабатывает корректно
   olegves
 
5 - 17.07.19 - 10:28
(0) Строка(КолвоСтрок) => XMLСтрока(КолвоСтрок)
   КонецЦикла
 
6 - 17.07.19 - 10:29
(5) Да я писал даже просто строку, копируя ее из формулы
=СУММ(R[-6]C:R[-1]C)
Может СУММ заменить на что-то англоязычное?
   olegves
 
7 - 17.07.19 - 10:33
(6) пробуй SUM
   olegves
 
8 - 17.07.19 - 10:34
+(7) но и (5) сделай, иначе будет без ошибки только до 1000строк
   olegves
 
9 - 17.07.19 - 10:38
(0) а для упрощения работы я использовал написание макроса,т.е.
1. старт записи макроса
2. добавление формул
3. остановить запись макроса
4. Alt+F11
5. Копи-паст из листинга макроса в 1С
   КонецЦикла
 
10 - 17.07.19 - 11:04
Вот так сработало, спасибо всем
ЯчейкаФормулы.Formula = "=SUM(R[-6]C:R[-1]C)";
В общем понятно, не любит русский видимо, но вручную SUM выдает ошибку

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.