Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

синхронизация не видит обработчик событий

синхронизация не видит обработчик событий
Я
   lom7000
 
16.07.19 - 23:35
Создал подписку на событие-перед записью, при проведение документа,
из программы процедура отрабатывает нормально,
но при синхронизации пишет ошибку:

{ОбщийМодуль.ОбменДаннымиXDTOСервер.Модуль(3423)}: Ошибка при вызове метода контекста (Получить)
Данные = ВыборкаИзменений.Получить();
по причине:
При подписке УдалениеРегистрацииДокументовДляОБменаСУТ на событие ПередЗаписью произошла ошибка. Метод обработчика события УдалениеРегистрации не найден."

Сам модуль:

&НаСервере
Процедура УдалениеРегистрации(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
       сообщить("Регистрация отменена");
КонецПроцедуры


Стоят галки: клиент, сервер, внешнее соединение


Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.71.69)
1С:Управление торговлей (11.4.7.141)
обмен стандартный
 
 
   catena
 
1 - 17.07.19 - 05:12
Ну так рассказывай, как обгонял, как подрезал. Ну, то есть, смотри, какие галки у модуля, каким способом синхронизация. Сравнивай, думай.
   lom7000
 
2 - 17.07.19 - 08:24
(1) Про галки уже было: Стоят галки: клиент, сервер, внешнее соединение
Синхронизация базовая, из программы метод работает, при синхронизации не находит...
   lom7000
 
3 - 17.07.19 - 15:18
Частично в БП начал работать вот в таком виде:
в подписке на события  МойМодуль.УдалениеРегистрацииКлиент  ПередЗаписью документ реализации


&НаСервере 
Процедура УдалениеРегистрации(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт 
       сообщить("Регистрация отменена"); 
КонецПроцедуры 

&НаСервере 
Процедура УдалениеРегистрацииКлиент(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт 
       МойМодуль.УдалениеРегистрации(Источник, Отказ, РежимЗаписи, РежимПроведения) ;
КонецПроцедуры 

&НаКлиенте
Процедура УдалениеРегистрацииКлиент(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт 
       МойМодуль.УдалениеРегистрации(Источник, Отказ, РежимЗаписи, РежимПроведения) ;
КонецПроцедуры 

получается что COM-соединение синхронизации идет через препроцессор &НаКлиенте, а если сохранить документ в программе то через &НаСервере Процедура УдалениеРегистрацииКлиент
   hhhh
 
4 - 17.07.19 - 17:27
(3) вот так тогда
Процедура УдалениеРегистрации(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт 
       сообщить("Регистрация отменена"); 
КонецПроцедуры 


в общих модулях никто не пишет НаКлиенте, НаСервере - это у вас бзик просто.
   lom7000
 
5 - 18.07.19 - 09:59
(4) вы правы, галка клиент в модуле была лишней, убрал галку(оставил только сервер и внешнее соединение), убрал препроцессоры, ошибка больше не появляется, спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.