Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ошибка отображения типов 1с 8.3 отсутствует отображение для типа

ошибка отображения типов 1с 8.3 отсутствует отображение для типа
Я
   JuixyJes
 
16.07.19 - 11:53
{Документ.ПриходныйКассовыйОрдер.Форма.ФормаДокумента.Форма(93)}: Ошибка при вызове метода контекста (ОплатаДопУслуг)
            ОплатаДопУслуг(Объект.ПринятоОт)
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
    форма: Элемент
    имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ФормаКлиентскогоПриложения'

Помогите пожалуйста, не могу понять в чем дело.
 
 
   JuixyJes
 
1 - 16.07.19 - 11:54
Функция ОплатаДопУслуг (ФЛ)
Выб = Документы.ДопУслуга.Выбрать();
Пока Выб.Следующий() Цикл
Если Строка(Выб.ФизЛицо) = Строка(ФЛ)  Тогда
Об = Выб.Ссылка.ПолучитьФорму("ФормаДокумента",Выб);
КонецЕсли;
КонецЦикла;
Возврат Об
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Если (Объект.СуммаДокумента = 0)  Тогда
        Ответ = Вопрос("Не оплачены дополнительные услуги, оплатить сейчас?",РежимДиалогаВопрос.ДаНет);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            ОплатаДопУслуг(Объект.ПринятоОт)
        КонецЕсли;
КонецПроцедуры
   JuixyJes
 
2 - 16.07.19 - 11:55
При попытке открыть форму созданного документа Доп Услуги выдается ошибка из (0)
   JuixyJes
 
3 - 16.07.19 - 11:56
Не понимаю, что я не так передаю на сервер?
   JuixyJes
 
4 - 16.07.19 - 11:58
Есть предположение, что я Объект.ПринятоОт передаю на сервер и на это ругается.
   sqr4
 
5 - 16.07.19 - 11:58
кто тебя научил формы на сервере открывать?
   sqr4
 
6 - 16.07.19 - 11:59
Есть предложение на фото в купальнике)
   JuixyJes
 
7 - 16.07.19 - 12:00
(5) никто, потому и спрашиваю. Мне нужно впринципе открыть документ уже созданный.
   hhhh
 
8 - 16.07.19 - 12:02
(7) открывают на &Клиенте. Запросы к базе наоборот, &НаСервере. Запиши у себя где-нибудь на бумажке.
   sqr4
 
9 - 16.07.19 - 12:03
Получаешь ссылку, возвращаешь на клиент, открываешь форму, кидаешь фото на форум! Все!
   Zmich
 
10 - 16.07.19 - 12:05
Поиск нужного документа тоже оставляет желать лучшего. Все документы перебирать один за другим, да и еще преобразовывать что-то в строку - мягко говоря, не оптимальное решение.
   hhhh
 
11 - 16.07.19 - 12:07
(4) да, там есть уже физлицо в документе, не надо ПринятоОт колбасить.
   catena
 
12 - 16.07.19 - 12:16
(4)Думаешь, он именно поэтому написал, что не умеет отображать ФормаКлиентскогоПриложения?
   D_E_S_131
 
13 - 16.07.19 - 12:25
1. Для открытия формы должно быть где-то "ОткрытьФорму()".
2. Что бы открыть форму имеющегося документа, нужно передать ссылку в параметр формы "Ключ".
3. Что бы не открывать текущую форму, нужно ПриОткрытии сделать "Отказ=Истина".

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.