Вход | Регистрация
 

Не устанавливается признак модифицированности для набора записей регистра бухгалтерии...

Не устанавливается признак модифицированности для набора записей регистра бухгалтерии...
Я
   mikecool
 
16.07.19 - 09:39
Столкнулся с сабжем
беру набор:
    пПроводки = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
    пПроводки.Отбор.Регистратор.Установить(ДокументСсылка);
    пПроводки.Прочитать();
в процессе могу изменить проводки, могу нет
когда меняются вижу, что данные в наборе изменились
проверяю
    Если пПроводки.Модифицированность() Тогда -- а вот здесь всегда ложь
        пПроводки.Записать();
    КонецЕсли;
чего я не понимаю?
 
 
   lodger
 
1 - 16.07.19 - 09:42
прям всегда ложь? а если добавить убавить строчку?
   mikecool
 
2 - 16.07.19 - 09:46
(1) на добавление еще не нарывался, хотя алгоритм предусматривает, пока только модифицирую записи
   ptiz
 
3 - 16.07.19 - 09:47
(0) "в процессе могу изменить проводки" - показывай как меняешь
   mikecool
 
4 - 16.07.19 - 09:49
(3) один из вариантов:
    Для Каждого пПроводка Из пПроводки Цикл
        
        .....        
            пПроводка.СуммаНУДт = 0;
            пПроводка.СуммаПРДт = 0;
            пПроводка.СуммаВРДт = 0;
            пПроводка.СуммаНУКт = 0;
            пПроводка.СуммаПРКт = 0;
            пПроводка.СуммаВРКт = 0;
            
        КонецЕсли;
        
    КонецЦикла;
   mikecool
 
5 - 16.07.19 - 10:27
подниму
   hhhh
 
6 - 16.07.19 - 10:30
(5) наверно всё дело в КонецЕсли; попробуй без него
   mikecool
 
7 - 16.07.19 - 10:32
(6) это я удалил проверки, не имеющие отношения...
   НЕА123
 
8 - 16.07.19 - 10:33
Для к =0 по пПроводки.Количество()-1 цикл

            пПроводки[к]СуммаНУДт = 0;
            пПроводки[к]СуммаПРДт = 0;
            пПроводки[к]СуммаВРДт = 0;
        
КонецЦикла;
   mikecool
 
9 - 16.07.19 - 10:37
(8) я ничего не удаляю, добавляю проводки отдельным циклом
   ptiz
 
10 - 16.07.19 - 10:39
(4) Может в наборе проводок нет.
   mikecool
 
11 - 16.07.19 - 10:40
(10) есть, я же пишу - изменения в наборе отслеживаю, они есть
   hhhh
 
12 - 16.07.19 - 10:50
(11) тебя же просили показать условия, а ты как настоящий партизан, всякую лабуду вывалил, а условие заменил тремя точками.
   mikecool
 
13 - 16.07.19 - 10:53
(12) вопрос то не в условии, условия все проходят, значение в наборе устанавливается, но признак модифицированности - нет
сразу после изменения значений ресурсов проверяю - нет признака, как буд то я у какой то копии набора устанавливаю, а не у прочитанного набора
   НЕА123
 
14 - 16.07.19 - 10:55
(12)+1
похоже что   Модифицированность взводится только при явном изменении(обращении) что-ли...
   RomanYS
 
15 - 16.07.19 - 10:55
(11) Могу ошибаться, но Модифицированность() нужна для отслеживания интерактивных изменений (из формы). В случае (0) - записывай без проверки.
   НЕА123
 
16 - 16.07.19 - 10:57
(13)
с тобой в разведку идти можно.
   mikecool
 
17 - 16.07.19 - 10:58
видимо так, сделаю свой признак для отслеживания...
но - мне кажется для регистров накопления Модифицированность() работает
еще пороюсь - может действительно где то копия набора получается ((

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.