Вход | Регистрация
 

Подскажите пжл. Как сделать отбор

↓ [Волшебник, 15.07.19 - 16:12]
Подскажите пжл. Как сделать отбор
Я
   Айрат_116
 
15.07.19 - 16:04
Здравствуйте. мне нужно выводить печатные формы. Но в зависимости от номенклатуры. Если номенклатура берется с "спров" Группы металлолом тогда выводить "СТавкуНДС1" Иначе СтавкаНДс
Не получаеться сделать


Металлолом = Справочники.Номенклатура.НайтиПоКоду("00009724");
                    Метал = Ложь;
                СФ = СведенияТОРГ12[0];
                    Если ТипЗнч(СФ) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
                Если СФ.Товары.Количество() > 0 Тогда
                    ДокОсн = СФ.Товары[0].Номенклатура;
            Для Каждого стрТЗ Из ДокОсн.Товар Цикл
                Если стрТЗ.Номенклатура.ПринадлежитЭлементу(Металлолом) Тогда
                    Метал = Истина;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;
        
    
    Если Метал Тогда
        ПараметрыСтроки.Вставить("СтавкаНДС1", "НДС исчисляется налоговым агентом");
    Иначе
        ПараметрыСтроки.Вставить("СтавкаНДС", СтрокаДокумента.СтавкаНДС);
    КонецЕсли;
 
 
   Айрат_116
 
1 - 15.07.19 - 16:06
Может потому что "СведенияТОРГ12" является "Табл значений"?
А не массив?
   RomaH
 
2 - 15.07.19 - 16:10
ага
   Айрат_116
 
3 - 15.07.19 - 16:11
(2) А как тогда написать условие?
   RomaH
 
4 - 15.07.19 - 16:11
ТипЗнч(СФ[имя колонки])
   Айрат_116
 
5 - 15.07.19 - 16:16
(4) СФ = СведенияТОРГ12[0];
ТипЗнч(Сф[Номенклатура]);

Так?
   Айрат_116
 
6 - 15.07.19 - 16:16
С табл части документа брать?
   RomaH
 
7 - 15.07.19 - 16:18
имя - оно строка
строка в кавычках
   RomaH
 
8 - 15.07.19 - 16:19
отладчик умеешь?
   Айрат_116
 
9 - 15.07.19 - 16:20
(8) Немного только пока

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.