Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как в документе прописать при изменени Подразделения в доке. обновлялись кнопки Подменю

Как в документе прописать при изменени Подразделения в доке. обновлялись кнопки Подменю
Я
   1сЮлия
 
12.07.19 - 13:39
Добрый день! Как в документе прописать при изменении реквизита дока Подразделения в доке. обновлялись кнопки Подменю
Процедура ПодразделениеПриИзменении(Элемент)
    Если Не ЗначениеЗаполнено(Подразделение)Тогда
        Участок=Справочники.аэсУчастки.ПустаяСсылка();
    КонецЕсли;    
    Если ЗначениеЗаполнено(Подразделение)Тогда
        
            ЭлементыФормы.ДействияФормы.Доступность = Истина;

      МассивКВЛ=Новый Массив();
    МассивКВЛ=ПолучитьМассивОпераций(Подразделение);
                            
    РаботаСДиалогами.УстановитьПодменюВыбораВидаОперации(ЭлементыФормы.ДействияФормы.Кнопки.ПодменюВидаОперации,
                                        МассивКВЛ,
                                        Новый Действие("ДействияФормыДействиеУстановитьОперацию"));
        
    иначеЕсли не ЗначениеЗаполнено(Подразделение)Тогда
               ВидОперации = Перечисления.аэсВидыОперацийКВЛ.ПустаяСсылка();
            Новый Действие("ДействияФормыДействиеУстановитьОперацию"));

            РаботаСДиалогами.УстановитьЗаголовокФормыДокумента(Строка(ВидОперации), ЭтотОбъект, ЭтаФорма);
            ЭлементыФормы.ДействияФормы.Доступность = Ложь;
   КонецЕсли;    
КонецПроцедуры
Ругается сдесь,нужно чтобы  кнопики удалась из ЭлементыФормы.ДействияФормы.Кнопки.ПодменюВидаОперации
 
 
   Сияющий в темноте
 
1 - 12.07.19 - 14:05
Если число действий в подменю фиксировано,то может поиграться с видимостью?
   1сЮлия
 
2 - 12.07.19 - 14:25
Как удалить все кнопки из подменю операции независимо от наименования, просто все?
   butterbean
 
3 - 12.07.19 - 14:28
(2) проще у подменю убрать видимость/доступность
   1сЮлия
 
4 - 12.07.19 - 15:23
Вот все ЭлементыФормы.ДействияФормы.Кнопки.ПодменюВидаОперации.Кнопки.Очистить();

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует