Вход | Регистрация
 

Диадок и доп. реквизиты счета-фактуры

Диадок и доп. реквизиты счета-фактуры
Я
   Mary01
 
11.07.19 - 15:15
Здравствуйте!)

Кто-нибудь добавлял программно доп. реквизиты для выгрузки в Диадок?
Для некоторых контрагентов нужно, чтобы мы выгружали в шапке счета-фактуры дополнительный реквизит - Номер заказа.
Я добавила этот реквизит в доп. сведения документа Счет-фактура выданный, но в Диадоке в поле "Доп. сведения" этот реквизит не подтягивается.
Конфигурация Бухгалтерия предприятия, редакция 3.0.70.33. Обработка Диадок 5_33_04.
 
 
   piter3
 
1 - 11.07.19 - 15:31
открыть обработку и посмотреть
   Aleksandr N
 
2 - 11.07.19 - 15:31
(0) это делается через дополнительный модуль.
   Mary01
 
3 - 11.07.19 - 15:42
(1) посмотрела. непосредственно в самой обработке этот реквизит не заполняется. Там программно генерируется модуль и все данные заполняются в нем, при этом сам модуль не открывается и не видно что в нем происходит. На выходе я вижу уже готовую таблицу значений с данными этого документа - номер, дату и т.д., поле ДопЗначение там пустое.
   Mary01
 
4 - 11.07.19 - 15:43
(2) ок, а где его взять?
Сейчас есть только внешняя обработка.
   sitex
 
5 - 11.07.19 - 15:46
(3) Если  видете готовую таблицу что мешает ее заполнить ?
   sitex
 
6 - 11.07.19 - 15:49
(3)Там программно генерируется модуль ---> где ? в Обработка Диадок 5_33_04 ?
   Mary01
 
7 - 11.07.19 - 15:50
(5) ничего) но это как костыль. Вначале хочу выяснить, может быть для этого уже предусмотрен удобный способ заполнения.
   sitex
 
8 - 11.07.19 - 15:51
(7) Тогда что мешает обратиться в Диадок?
   Mary01
 
9 - 11.07.19 - 15:53
(8) то, что нужно будет им платить за эту работу
   sitex
 
10 - 11.07.19 - 15:54
(9) ну тогда все ясно) Либо Костыль либо платить. выбор за вами
 
 Рекламное место пустует
   piter3
 
11 - 11.07.19 - 15:55
(2) Закрыт наверняка?
   Mary01
 
12 - 11.07.19 - 15:59
(11) может быть и закрыт, но даже непонятно, где он.
   saaken
 
13 - 11.07.19 - 16:05
(0) там отладка есть в настройках.
доп. модули выгружаются на диск в нужную тебе папку.
   Mary01
 
14 - 11.07.19 - 16:06
(13) ок, но откуда они выгружаются?
   Mary01
 
15 - 11.07.19 - 16:09
(6) Да, в этой обработке. примерно так:
ТаблицыДляВыгрузкиВДиадок= МетодСервера("Модуль_ИнтеграцияУниверсальный", "СформироватьТаблицыДляВыгрузкиВДиадок",....


&НаСервере
Функция МетодСервера(Знач ИмяМодуля= "", Знач ИмяМетода,
        Параметр0= NULL, Параметр1= NULL, Параметр2= NULL, Параметр3= NULL, Параметр4= NULL, 
        Параметр5= NULL, Параметр6= NULL, Параметр7= NULL, Параметр8= NULL, Параметр9= NULL) Экспорт
    
    Возврат ОбработкаОбъект().МетодСервера(ИмяМодуля, ИмяМетода, 
    Параметр0, Параметр1, Параметр2, Параметр3, Параметр4,
    Параметр5, Параметр6, Параметр7, Параметр8, Параметр9);
    
КонецФункции
 
То есть, "СформироватьТаблицыДляВыгрузкиВДиадок" - это имя метода, но в этой обработке я не нахожу этого метода
   saaken
 
16 - 11.07.19 - 16:22
(14) зайди в конфигуратор и ткни два раза мышкой в макет нужной конфигурации и сохрани его на диск как внешнюю обработку
   Aleksandr N
 
17 - 11.07.19 - 16:27
(11) Не знаю как в диадоке для БП 3.0, для 2.0 в настройках диадока можно указать дополнительный модуль, в котором можно дописать свои реквизиты.
   Mary01
 
18 - 11.07.19 - 18:41
(16) спасибо! оказалось, там несколько модулей в макетах. сохранила, открыла)) не знала что так можно.
В общем, нужная функция нашлась в этом модуле)
но как теперь в отладку этого модуля попасть?
   Mary01
 
19 - 11.07.19 - 18:42
(17) в 3.0 тоже такое есть, вопрос в том, где взять модуль этот. Я так поняла, что этот внешний модуль надо у Диадока запрашивать, но он платный
   Фрэнки
 
20 - 11.07.19 - 20:27
(19) у него цены невысокие. Смешно просто писать из Москвы о том, что не хочется использовать платный релиз.
У вас стоимость труда программиста в пересчете на стоимость апгрейда в разы выше
   palsergeich
 
21 - 11.07.19 - 23:08
(20) Программист - со ставкой 1000 в час забюджетирован, а на модуль ценой в 500 рублей - бюджета нет. Можем на следующий год поставить.
А пока пусть посидит месяцок - попробует.
True story
   palsergeich
 
22 - 11.07.19 - 23:09
(21) А если еще это какой нибудь холдинг с юристами - параноиками, то совсем труба, годами договор согласовывать будут.
   zak555
 
23 - 12.07.19 - 00:09
Типа 1с в сервис 1с-эдо может передавать допсведения, в шапку, подвал или в ТЧ

Через ж, но можно
   Mary01
 
24 - 12.07.19 - 07:15
(20) я пишу из глухой провинции...
   4St
 
25 - 12.07.19 - 16:10
Вот инструкция про подключаемый модуль: где взять шаблон и как подключить.
https://wiki.diadoc.ru/pages/viewpage.action?pageId=7668852
Код в вашем случае будет примерно такой:

Функция ОбработатьСобытиеПослеЗаполненияКонтента(Параметры)

    
    //...
    
    ИначеЕсли DocumentType = "XmlUTD" Тогда
        
        // описание полей - http://diadocsdk-1c.readthedocs.io/ru/latest/UtdSellerContent.html
        
        //...
        
        // Для контрагента задано дополнительное свойство - "Адрес доставки".
        // Добавим его в произвольные поля шапки документа
        АдресДоставки = ЗначениеДопСвойстваПоИмени(Параметры.ДокументСсылка.Контрагент, "Адрес доставки");
        ДополнитьМассивKeyValue(Content.AdditionalInfoId.StructedAdditionalInfos, "Адрес доставки", Строка(АдресДоставки));
        
        Возврат Content;
        
    КонецЕсли;    
    
КонецФункции // ОбработатьСобытиеПослеЗаполненияКонтента()


Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует