Вход | Регистрация
 

Ошибка подключения к ВЕТИС.

Ошибка подключения к ВЕТИС.
Я
   Zombi
 
11.07.19 - 08:52
УТ 11.4.8.79. Пытаюсь настроить подключение к ВЕТИС.API. Ввожу все данные, полученные в письме, жму далее и получаю ошибку на этапе "Заполнение служебных данных" "не удалось заполнить виды продукции по группам приказа ветис по причине индекс находится за границами массива". Иду в отладчик, нахожу такой код в функции ПереченьПродукцииАттестованныхСпециалистов(ГруппыПродукции) общего модуля "ДопустимыеЦелиВЕТИС":         ГруппаПриказаСтрока       = СокрЛП(СтрРазделить(ГруппаПриказаСтрока, ".")[1]); В переменной ГруппаПриказаСтрока строка из макета, которую код пытается разложить в массив, открываю макет, вижу там везде значения типа "Приказ 647. Группа 05, 96, 97, строка 4. Рыба и морепродукты.", то есть он нормально раскладывает эту строку в массив с 3 элементами, а в 2 строках "Группа 04, строка 5", на них он валится, так как раскладывает в массив только с одним элементом с индексом "0", а в коде пытается обратиться к элементу с индексом "1". Что это? Косяк релиза? Что делать? Обновляться? Править код? Править макет? С Меркурием только начинаю разбираться.
 
 
   ChMikle
 
1 - 11.07.19 - 09:01
Вроде как с февраля справочники номенклатуры должны быть заполнены до наименования , видимо не весь классификатор еще актуализировали .
   Zombi
 
2 - 11.07.19 - 09:08
https://yadi.sk/i/aPnPYMuziM_lmQ

Вот скрин макета. На строке 11456 получается ошибка. Не пойму как корректнее обойти. Вот полный код функции:

Функция ПереченьПродукцииАттестованныхСпециалистов(ГруппыПродукции)
    
    Таблица = Новый ТаблицаЗначений;
    Таблица.Колонки.Добавить("ГруппаПриказа",             Новый ОписаниеТипов("ПеречислениеСсылка.ГруппыПродукцииАттестованныхСпециалистов"));
    Таблица.Колонки.Добавить("ВидПродукцииИдентификатор", Метаданные.ОпределяемыеТипы.УникальныйИдентификаторВЕТИС.Тип);
    Таблица.Колонки.Добавить("ВидПродукцииНаименование",  Метаданные.ОпределяемыеТипы.СтрокаВЕТИС.Тип);
    
    Макет = Обработки.КлассификаторыВЕТИС.ПолучитьМакет("ПереченьПродукцииАттестованныхСпециалистов");
    КоличествоСтрок = Макет.ВысотаТаблицы;
    
    ДобавленныеСтроки = Новый Соответствие;
    Для НомерСтроки = 2 По КоличествоСтрок Цикл
        
        ГруппаПриказаСтрока       = СокрЛП(Макет.Область(НомерСтроки, 1).Текст);
        ГруппаПриказаСтрока       = СокрЛП(СтрРазделить(ГруппаПриказаСтрока, ".")[1]);
        ТипПродукцииНаименование  = СокрЛП(Макет.Область(НомерСтроки, 2).Текст);
        
        ВидПродукцииИдентификатор = СокрЛП(Макет.Область(НомерСтроки, 9).Текст);
        ВидПродукцииНаименование  = СокрЛП(Макет.Область(НомерСтроки, 7).Текст);
        
        ГруппаПриказа = ГруппыПродукции.Получить(ГруппаПриказаСтрока);
        Если ГруппаПриказа = Неопределено Тогда
            СтрокаПоиска = ГруппаПриказаСтрока + " / " + ТипПродукцииНаименование;
            ГруппаПриказа = ГруппыПродукции.Получить(СтрокаПоиска);
        КонецЕсли;
        
        ЗаполненныеВиды = ДобавленныеСтроки.Получить(ГруппаПриказа);
        Если ЗаполненныеВиды = Неопределено Тогда
            ЗаполненныеВиды = Новый Соответствие;
            ДобавленныеСтроки.Вставить(ГруппаПриказа, ЗаполненныеВиды);
        КонецЕсли;
        
        СтрокаТаблицы = ЗаполненныеВиды.Получить(ВидПродукцииИдентификатор);
        Если СтрокаТаблицы <> Неопределено Тогда
            Если СтрНайти(СтрокаТаблицы.ВидПродукцииНаименование, ВидПродукцииНаименование) = 0 Тогда
                СтрокаТаблицы.ВидПродукцииНаименование = СтрокаТаблицы.ВидПродукцииНаименование + ", "+ ВидПродукцииНаименование;
            КонецЕсли;
            Продолжить;
        КонецЕсли;
        
        НоваяСтрока = Таблица.Добавить();
        
        НоваяСтрока.ГруппаПриказа             = ГруппаПриказа;
        НоваяСтрока.ВидПродукцииИдентификатор = ВидПродукцииИдентификатор;
        НоваяСтрока.ВидПродукцииНаименование  = ВидПродукцииНаименование;
        
        ЗаполненныеВиды.Вставить(ВидПродукцииИдентификатор, НоваяСтрока);
        
    КонецЦикла;
    
    Возврат Таблица;
    
КонецФункции

Подправить код и пропускать эти косячные строки? Чем это черевато? Подправить макет? Как править? То есть что писать в эту колонку?
   ChMikle
 
3 - 11.07.19 - 09:12
(2) если я правильно понял , то из макета заполняется справочник номенклатуры зарегистрированной в ВЕТИС . До февраля 2019 года регистрировали кто во что горазд , сейчас вроде как должны быть номенклатурные позиции однозначно идентифицированные т.е. до наименования продукции . Исходя из этой логики - можно и пропустить , ВЕТИС и Меркурий такая мутная штука, ни россельхознадзор ни ветеринарные службы не могут толком объяснить порядок работы в этой системе
   Zombi
 
4 - 11.07.19 - 09:17
(3) Понял. Спасибо.
   ChMikle
 
5 - 11.07.19 - 09:28
Обращу внимание , не гасите ни в коем случае ветеринарные свидетельства в которых нет четкого указания товаров , отключат от системы
   Zombi
 
6 - 11.07.19 - 09:38
(5) Спасибо за совет.
   ChMikle
 
7 - 11.07.19 - 09:46
и возвраты будете отписывать выбирайте ветеринарные свидетельства заранее , чтобы сроки по ветсвидетельству еще не были просрочены , иначе тоже отключат . :) А так вроде ничего страшного ,за исключением того , что в егаис накосячить не даст сама система, а здесь наоборот , косячь сколько хочешь потом наказывают :)
   Zombi
 
8 - 11.07.19 - 09:56
(7) Если отключат, восстанавливать гемор?
   ChMikle
 
9 - 11.07.19 - 10:22
(8) пока отключают учетную запись на полгода , но могут и штрафануть . Информация меняется , мы сами только неделю назад узнали , что теперь в обязательном порядке гасить ветсвидетельства только на конкретные товары , а не на группы . На вопрос , почему вет. врачи по прежнему выписывают ветсвидетельства некорректные , ответили : "Не ошибается тот, кто ничего не делает. А спрос с вас как с грузополучателя"
   Zombi
 
10 - 11.07.19 - 10:23
(9) Весело))
   vvspb
 
11 - 11.07.19 - 10:44
сплошное веселье
http://vetrf.ru/vetrf/news/30957.html
   ChMikle
 
12 - 11.07.19 - 10:48
(11) И так по всем вопросам :))
   birkoFFFF
 
13 - 11.07.19 - 11:34
(11) Господи, что там они все курят?
   ChMikle
 
14 - 11.07.19 - 11:38
(13) Хотя чего удивляться, пятерочки хотят заняться доставкой почты, почта дает кредиты, сбербанк объединять допофисы с макдональдсами ....
   kda26
 
15 - 11.07.19 - 12:52
(11) ЯННП

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.