Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1с83 Как передать строку из одного модуля в другой модуль через глобальную переменную

1с83 Как передать строку из одного модуля в другой модуль через глобальную переменную
Я
   VBMADD
 
11.07.19 - 08:41
Всем Привет.
1с83 Хочу передать строку из одного модуля в другой модуль через глобальную переменную

Делаю так

В модуле ОбщиаяФорма.ПечатьДокументов

&НаКлиенте
Перем МояПеременная Экспорт;

&НаКлиенте
МояФункция()
   Сообщить("МояПеременная = " + МояПеременная);
КонецФункции


В модуле менеджера ОсновногоСредства

Процедура МояПроцедура()

    ПП = СокрЛП(Строка(Шапка.Параметры.ИнвентарныйНомер));
    Ф = ПолучитьФорму("ОбщаяФорма.ПечатьДокументов");
    Ф.МояПеременная = ПП;

КонецПроцедуры

Пишет что
Значение не является значением объектного типа (МояПеременная)
    Ф.МояПеременная = ПП;

Что нужно подправить?
 
 
   lodger
 
1 - 11.07.19 - 08:46
(0) нужно перестать мыслить стандартами ОФ в УФ.
передавайте параметры между формами через вызовы.
   VBMADD
 
2 - 11.07.19 - 09:10
(1) Ну хорошо.
Тогда более конкретно.
Мне нужно сохранить печатную форму Инвентарной карточки в файл PDF чтобы имя файла совпадало с инвентарным номером карточки без ручного ввода имени файла.

Я пытаюсь это сделать через процедуру "СохранитьПечатныеФормыВПапку"  подставив вместо УникальногоИмениФайла  инвентарный номер карточки

&НаКлиенте
Процедура СохранитьПечатныеФормыВПапку
...
ДвоичныеДанные.Записать(УникальноеИмяФайла(Папка + ФайлДляЗаписи.Представление));
...
КонецПроцедуры
   VBMADD
 
3 - 11.07.19 - 09:12
Подскажи пож-ста
Как мне получить номер инвентарной карточки в модуле ФормаПечатьДокументов
   DrWatson
 
4 - 11.07.19 - 09:15
(3) Его нужно передать в форму из места вызова. А в форме организовать хранение и использование.
   catena
 
5 - 11.07.19 - 09:21
   VBMADD
 
6 - 11.07.19 - 09:23
(4) Вот именно, 
я для этого в форме ПечатьДокументов создаю Глобальную переменную

которую использую для хранения и использования НомераИнвентарнойКарточки

а из Модуля МенеджераОсновногоСредства хочу передать НомерИнвентарнойКарточки в эту 

Глобальную переменную
   VBMADD
 
7 - 11.07.19 - 09:27
(4)Как мне установить значение этой Глобальной переменной в Модуле ПечатьДокументов

из Модуля менеджера ОсновногоСредства

Подскажи пож-ста
   DrWatson
 
8 - 11.07.19 - 09:27
(6) Не понял. Модуль менеджера - это сервер. Форма - открывается с клиента. Как Вы форму открываете с сервера?
Параметры можно передавать в ОткрытьФорму. Но что у Вас происходит непонятно.
   Провинциальный 1сник
 
9 - 11.07.19 - 09:31
На сервере нет глобальных переменных. Селяви. Можно только в хранилище хранить, или в файле. Соответственно, с несериализуемыми значениями полный пролёт - способа их сохранить между серверными вызовами официально нет. Неофициальные способы не советую, ибо рискуем получить вылет серверного процесса в самый подходящий момент.
   lodger
 
10 - 11.07.19 - 09:59
напомните, какой там стек вызовов?
форма объекта - форма печати - модульменеджера.
т.е. автору не из модульменеджера надо передать в форма печати, а из форма объекта в форма печати.
 
 Рекламное место пустует
   VBMADD
 
11 - 11.07.19 - 11:25
Всем огромное спасибо  спасибо(9) за общение и хорошего дня.
Все получилось как я хотел!!!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует