Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

База данных заблокирована

База данных заблокирована
Я
   Mukrob
 
09.07.19 - 13:04
Подскажите куда еще можно покопать..

ситуация: отраслевая конфигурация, зависших сеансов нету, в консоле проверял база не заблокирована
зайти одновременно может только 1ин человек, под любой учетной записью, второй зайти уже не может, пишет указанную ошибку.
сервер ребутали кэш пользователя чистил, пробовали с разных машин и локально, максимум 1 человек.

до этой ошибки все работало корректно, ну разве еще что кэш сервера не чистил.
 
 
   Mukrob
 
1 - 09.07.19 - 13:04
(0) толстый клиент, база на mysql
   shuhard
 
2 - 09.07.19 - 13:05
(1)[mysql]
не верю (с)
   piter3
 
3 - 09.07.19 - 13:05
(1) врете
   Mukrob
 
4 - 09.07.19 - 13:05
(3) с чего вдруг?
   piter3
 
5 - 09.07.19 - 13:06
(4) Потому что нельзя на mysql
   Mukrob
 
6 - 09.07.19 - 13:06
(5) а на чем можно?
   Mukrob
 
7 - 09.07.19 - 13:08
(5) ms sql server? ;-)
   DrWatson
 
8 - 09.07.19 - 13:10
Как вариант, у пользователя встаёт монопольный режим.
   Mukrob
 
9 - 09.07.19 - 13:30
(8) как он может вставать? локально на сервере запускаю тоже самое, разве где-то в УФ можно запустить монопольный режим?
   МимохожийОднако
 
10 - 09.07.19 - 13:42
(9) ты подробнее пиши. Какая конфигурация, платформа, какие права у пользователя, какой SQL. Желательно не врать и не путать.
 
 Рекламное место пустует
   shuhard
 
11 - 09.07.19 - 13:47
(9) и картинку приложи, нужны детали
   Здравый_смысл
 
12 - 09.07.19 - 13:47
Ищите в конфе УстановитьМонопольныйРежим(Истина) при запуске.
   Фрэнки
 
13 - 09.07.19 - 13:49
может это РМК какой-то самопальное?
   Йохохо
 
14 - 09.07.19 - 13:49
или ключ в ярлыке
   Mukrob
 
15 - 09.07.19 - 13:50
(12) нашел ага, переустановкаграницыитогов ссылается на эту функцию, при запуске устанавилвает монопольный режим. наверно дальше разберусь.
   Здравый_смысл
 
16 - 09.07.19 - 13:53
Я это в ТКПТ от "Раруса" видел в гениальном куске говнокода.
   Mukrob
 
17 - 09.07.19 - 14:09
(16)
  ДеньМесяцаНачалаНапоминания = 5;
    ДеньМесяцаБезусловногоПересчета = 10;
 
    ТекущийДеньМесяца = День(ТекущаяДата());    
    НадоПересчитывать = Истина;
 
    Если ТекущийДеньМесяца<ДеньМесяцаНачалаНапоминания Тогда
        НадоПересчитывать = Ложь;
    Иначе
        Если ТекущийДеньМесяца<ДеньМесяцаБезусловногоПересчета Тогда
            ЕстьПользователиВБазе = Ложь;
            Попытка
                УстановитьМонопольныйРежим(Истина);
            Исключение
                ЕстьПользователиВБазе = Истина;
            КонецПопытки;
            Если Не ЕстьПользователиВБазе Тогда
                УстановитьМонопольныйРежим(Ложь);
            КонецЕсли;
            НадоПересчитывать = Не ЕстьПользователиВБазе;
        Иначе
            НадоПересчитывать = Истина;
        КонецЕсли;
    КонецЕсли;
 
    Если Не НадоПересчитывать Тогда
        Возврат;
    КонецЕсли;
    
    ПредпочтительнаяДатаРасчетаИтогов = НачалоМесяца(ТекущаяДата())-1;
    СписокРегистровКРассчету = Новый Массив;
    Для Каждого Регистр ИЗ РегистрыНакопления Цикл                               
        МетаданныеРегистра = Метаданные.НайтиПоТипу(Тип(Регистр));
        Если МетаданныеРегистра.ВидРегистра = Метаданные.СвойстваОбъектов.ВидРегистраНакопления.Остатки Тогда
            Если ПравоДоступа("УправлениеИтогами", МетаданныеРегистра) Тогда
                Если Регистр.ПолучитьПериодРассчитанныхИтогов()<ПредпочтительнаяДатаРасчетаИтогов  Тогда
                    СписокРегистровКРассчету.Добавить(МетаданныеРегистра.ПолноеИмя());
                КонецЕсли;
            КонецЕсли;            
        КонецЕсли;
    КонецЦикла;    
    Для Каждого Регистр ИЗ РегистрыБухгалтерии Цикл                               
        МетаданныеРегистра = Метаданные.НайтиПоТипу(Тип(Регистр));
        Если ПравоДоступа("УправлениеИтогами", МетаданныеРегистра) Тогда
            Если Регистр.ПолучитьПериодРассчитанныхИтогов()<ПредпочтительнаяДатаРасчетаИтогов  Тогда
                СписокРегистровКРассчету.Добавить(МетаданныеРегистра.ПолноеИмя());
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
 
    Если СписокРегистровКРассчету.Количество()=0 Тогда
        УстановитьМонопольныйРежим(Ложь);
 
        Возврат;
    КонецЕсли;
 
    Если Вопрос("Для повышения производительности рекомендуется выполнить"+Символы.ПС+
                "расчет итогов регистров по "+Формат(ПредпочтительнаяДатаРасчетаИтогов, "ДФ=дд.ММ.гггг" )+". Выполнить его сейчас?", 
            РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Нет) = КодВозвратаДиалога.Нет Тогда
            Возврат;
    КонецЕсли;
    СписокРассчитанных = ПолныеПрава.ВыполнитьУстановкуПериодаИтогов(СписокРегистровКРассчету, ПредпочтительнаяДатаРасчетаИтогов);
    Для Каждого РегистрИзСписка ИЗ СписокРассчитанных Цикл
        Сообщить("Итоги регистра" + РегистрИзСписка + " были рассчитаны по: "+Формат(ПредпочтительнаяДатаРасчетаИтогов, "ДФ=дд.ММ.гггг" ));
    КонецЦикла;


-----------
вот он гениальный код, видно что монопольный доступ устанавливает, но не снимает.
   Mukrob
 
18 - 09.07.19 - 14:10
(17)
добавил    
    Если СписокРегистровКРассчету.Количество()=0 Тогда
        УстановитьМонопольныйРежим(Ложь);
 
        Возврат;
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует