Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Определения процедур и функций должны размещаться перед операторами тела модуля

Определения процедур и функций должны размещаться перед операторами тела модуля
Я
   Niraterra
 
09.07.19 - 12:30
Добрый день! Я создала печатную форму с помощью конструктора, при попытке сохранить выдает ошибку, что не так?

Процедура Печать(Элемент)
    //{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(Печать)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    ТабДок = Новый ТабличныйДокумент;
    Макет = Документы.ОценкаСостоянияМагазина.ПолучитьМакет("Печать");
    // Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабДок.Вывести(Область);
    // Шапка
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Заполнить(ЭтотОбъект);
    ТабДок.Вывести(Шапка);
    // Таблица
    Область = Макет.ПолучитьОбласть("ТаблицаШапка");
    ТабДок.Вывести(Область);
    ОбластьТаблица = Макет.ПолучитьОбласть("Таблица");
    Для Каждого ТекСтрокаТаблица Из Таблица Цикл
        ОбластьТаблица.Параметры.Заполнить(ТекСтрокаТаблица);
        ТабДок.Вывести(ОбластьТаблица);
    КонецЦикла;

    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();
    //}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ
КонецПроцедуры
 
 
   Вафель
 
1 - 09.07.19 - 12:31
после КонецПроцедуры где то есть точка с запятой
   Ёпрст
 
2 - 09.07.19 - 12:32
(0) вам же пишут в какой строке ошибка, туда и смотрите
видать после этого кода есть Перем Вася
   Niraterra
 
3 - 09.07.19 - 12:32
(1) нет, там пусто(
   ice777
 
4 - 09.07.19 - 12:33
(3) значит где-то что-то есть
   Niraterra
 
5 - 09.07.19 - 12:33
(2) в самую первую строку отправляет
   CHerypga
 
6 - 09.07.19 - 12:37
(0) тогда надо контрл+a, контрл+c и сюда контрл+v
потому что в представленном куске кода ошибок нет, одни где-то перед или после
   Niraterra
 
7 - 09.07.19 - 12:39
<<?>>Процедура Печать(Элемент) (Проверка: Толстый клиент (обычное приложение)) еще пишет, где-то перед процедурой искать искать ошибку?
   Ёпрст
 
8 - 09.07.19 - 12:44
(7) сделай (6) и результат сюда
   Вафель
 
9 - 09.07.19 - 13:08
только не сюда, а лучше на
https://pastebin.com/
   Niraterra
 
10 - 09.07.19 - 13:18
(9) (8) (6) Спасибо, нашла)
   Niraterra
 
11 - 09.07.19 - 14:00
а если мне нужно в параметр вложить некоторый массив, как это написать?
   Niraterra
 
12 - 09.07.19 - 14:01
в смысле в чтобы в строке, в ячейке выводился массив
   ДенисЧ
 
13 - 09.07.19 - 14:03
(12) Ручками-сЪ
   Niraterra
 
14 - 09.07.19 - 14:05
(13) таки какой синтаксис?
   Niraterra
 
15 - 09.07.19 - 14:06
у меня есть массив с ответственными за магазин, и мне надо чтобы он выводился в печать  таблицу
   mistеr
 
16 - 09.07.19 - 14:12
(15) Через запятую, или как?
   CHerypga
 
17 - 09.07.19 - 14:34
Строка = СтрСоединить(Массив, "; ")
   sqr4
 
18 - 09.07.19 - 14:35
Так, стоп, а где фото?!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.