Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Получение строки ТЗ по Текущей строке Таблицы на управляемой форме.

Получение строки ТЗ по Текущей строке Таблицы на управляемой форме.
Я
   Rom_Kat
 
08.07.19 - 16:26
Проблема:

На форме две таблицы. Вторую таблицу необходимо заполнить на основании строки первой.

&НаСервере
Процедура ПоказатьСчетаПлатежаНаСервере(ТекущаяСтрока)
    
    ТЗСчетаОплаты = РеквизитФормыВЗначение("СчетаОплаты", Тип("ТаблицаЗначений"));
    ТЗСчетаОплаты.Очистить();
    
    СтрокаПоступленияДС = ПоступленияДС[ТекущаяСтрока];
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ПоступлениеНаРасчетныйСчетРасшифровкаПлатежа.СчетНаОплату КАК СчетНаОплату,
        |    ПоступлениеНаРасчетныйСчетРасшифровкаПлатежа.СуммаПлатежа КАК Сумма
        |ИЗ
        |    Документ.ПоступлениеНаРасчетныйСчет.РасшифровкаПлатежа КАК ПоступлениеНаРасчетныйСчетРасшифровкаПлатежа
        |ГДЕ
        |    ПоступлениеНаРасчетныйСчетРасшифровкаПлатежа.Ссылка = &Ссылка";
    
    Запрос.УстановитьПараметр("Ссылка", ПоступленияДС[ТекущаяСтрока].ПоступлениеНаРасчетныйСчет);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СтрокаТЗСчетаОплаты = ТЗСчетаОплаты.Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТЗСчетаОплаты, ВыборкаДетальныеЗаписи);
    КонецЦикла;

        ЗначениеВРеквизитФормы(ТЗСчетаОплаты, "СчетаОплаты");

КонецПроцедуры

&НаКлиенте
Процедура ПоказатьСчетаПлатежа(Команда)
    ПоказатьСчетаПлатежаНаСервере(Элементы.ПоступленияДС.ТекущаяСтрока);
КонецПроцедуры

Выполнение этой команды после первого заполнения таблицы ПоступленияДС проходит нормально. После того как повторно заполняется ПоступленияДС, при выполнении команды Элементы.ПоступленияДС.ТекущаяСтрока имеют значения не соответствующие новому составу строк.
Не могу понять, что происходит. Как это настроить?
 
 
   Александр Б
 
1 - 08.07.19 - 16:30
ТекущаяСтрока - это идентификатор. Поэтому получить текущую строку ТЗ необходимо получать функцией НайтиПоИдентификатору
   Александр Б
 
2 - 08.07.19 - 16:30
(1) Если конкретней, то ПоступленияДС[ТекущаяСтрока] заменить на ПоступленияДС.НайтиПоИдентификатору(ТекущаяСтрока)
   Rom_Kat
 
3 - 08.07.19 - 16:33
(1)пробовал

Сейчас ещё проверю.
   Rom_Kat
 
4 - 08.07.19 - 16:35
(2)Правильно. Это я не везде изменил код.

Спасибо.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.