Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Статусы в документе

Статусы в документе
Я
   progaoff
 
08.07.19 - 10:31
Добрый день, как ограничить список статусов для пользователя, на форме документа есть реквизит с перечислением статусов, вот в нем нужно убрать несколько статусов из видимости.
 
 
   Cyberhawk
 
1 - 08.07.19 - 10:49
Опасные игры
   HawkEye
 
2 - 08.07.19 - 10:50
(0) перехватит начало выбора, сформировать свой список и подсунуть его для выбора....
кода - 5-10 строк....
   shuhard
 
3 - 08.07.19 - 11:00
(2) +1
   Cyberhawk
 
4 - 08.07.19 - 11:03
Ага, а в форме списка и других АРМах оставить команды для перевода документов в любой статус :)
   progaoff
 
5 - 08.07.19 - 11:07
(4) Тут смысл ограничить список статусов. В форе списка пусть видит.
   Cyberhawk
 
6 - 08.07.19 - 11:10
Хз о чем ты
   progaoff
 
7 - 08.07.19 - 11:12
(6) Сделать для пользователя доступными только 3 из 5 статусов.
   Cyberhawk
 
8 - 08.07.19 - 11:15
После (5) неинтересно стало, ибо не в коня корм )
   serkorvin1
 
9 - 08.07.19 - 11:47
(0)

&НаКлиенте
Процедура СтатусНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
        
    МассивC = Новый Массив;
    
    Если Объект.Ссылка.Пустая() Тогда
        МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Новая"));
    Иначе
        Если Объект.Статус = ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Выполненная") Тогда
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.ВРаботе"));
        ИначеЕсли Объект.Статус = ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.ВРаботе") Тогда
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Выполненная"));
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отложенная"));
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отмененная"));
        ИначеЕсли Объект.Статус = ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Новая") Тогда
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.ВРаботе"));
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отложенная"));
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отмененная"));
        ИначеЕсли Объект.Статус = ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отложенная") Тогда
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.ВРаботе"));
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отмененная"));
        ИначеЕсли Объект.Статус = ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.Отмененная") Тогда
            МассивC.Добавить(ПредопределенноеЗначение("Перечисление.СУЗ_СтатусыЗаявок.ВРаботе"));
        КонецЕсли;
    КонецЕсли;    
    
    НовыйПараметр = Новый ПараметрВыбора("Отбор.Ссылка", МассивC);       
    Массив = Новый Массив;
    Массив.Добавить(НовыйПараметр);        
    ПараметрыВыбораС = Новый ФиксированныйМассив(Массив);        
    Элемент.ПараметрыВыбора = ПараметрыВыбораС;     
    
КонецПроцедуры
   progaoff
 
10 - 08.07.19 - 12:08
(9) Спасибо)

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.