Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Существует ли в 1с косвенная адресация?

Существует ли в 1с косвенная адресация?
Я
   Storm03
 
08.07.19 - 09:54
Не крутой спец по 1С.
Есть ТЗ, в которой Номенклатура, Контрагент, Склад и остатки.
Необходимо в зависимости от Контрагента и Склада распихать строки по разным документам ВводОстатковНоменклатуры.

Что-то типа:
Контрагенты = Новый Массив;
Склады = Новый Массив;
Нов = 0;
Стр = ТЗ.ПрочитатьСтроку();
Пока Стр <> Неопределено Цикл
Если Найти(Контрагенты, Стр.Контрагент) = Неопределено Тогда
     Контрагенты.Вставить(Стр.Контрагент);
     Нов = 1;
КонецЕсли;
Если Найти(Склады, Стр.Склад) = Неопределено Тогда
     Склады.Вставить(Стр.Склад);
     Нов = 1;
КонецЕсли;
//////////// А вот дальше то, что мне нужно, но в фантазиях:
Индекс = Найти(Контрагенты, Стр.Контрагент) + "_" + Найти(Склады, Стр.Склад);
Если Нов = 1 Тогда
     Док+Индекс = Документы.ВводОстатковНоменклатуры.СоздатьДокумент();
КонецЕсли;
////////// Заполняем ТекСтр ...
Док+Индекс.ТЧ.Вставить(ТекСтр);

Ну, как-то так...
 
 
   Cyberhawk
 
1 - 08.07.19 - 09:56
Нет
   dka80
 
2 - 08.07.19 - 09:58
Док = Новый Массив;

Док[Индекс] = Документы.ВводОстатковНоменклатуры.СоздатьДокумент();
   dka80
 
3 - 08.07.19 - 09:59
точнее
Док.Добавить(Документы.ВводОстатковНоменклатуры.СоздатьДокумент())
   Кирпич
 
4 - 08.07.19 - 10:04
Для складов и контрагентов догадался создать массив, а для документов чота вдруг осенило какой то косвенной адресацией.
   Storm03
 
5 - 08.07.19 - 10:11
Ага, значит, массив документов создать можно? Ок, это поможет! Всем спасибо!))))
   Кирпич
 
6 - 08.07.19 - 10:13
(5) лучше соответствие создай. и ключ чтобы был Склад+Контрагент
   Storm03
 
7 - 08.07.19 - 10:39
(6) А что, 1С ещё и ассоциативные массивы поддерживает? Офигеть!
   Кирпич
 
8 - 08.07.19 - 10:50
(7) см. раздел "Универсальные коллекции значений"
   Salimbek
 
9 - 08.07.19 - 11:09
Нахрена это вот все? Сортируешь выборку и в обходе - как поменялось Склад+Контрагент - записываешь текущий документ и создаешь новый.
   Storm03
 
11 - 09.07.19 - 12:49
(9) Это было б зашибись, если б было бы так просто. В обработке нужно перетасовывать товар по другим складам. Какие-то объединять, какие-то разделять.
   Salimbek
 
12 - 09.07.19 - 14:30
(11) Дык, создавай колонку новую в ТЗ и перетасовывай, как перетасуешь - сортируй  и далее (9)
   Salimbek
 
13 - 09.07.19 - 14:32
+(12) Хотя, тебе на месте виднее, может действительно удобнее все обходить. Я лишь предложил один из вариантов.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует