Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

зуп 3.1. Не запускается COM соеденение внешней печатной формы в клиент-серверном варианте.

зуп 3.1. Не запускается COM соеденение внешней печатной формы в клиент-серверном варианте.
Я
   Target1025
 
06.07.19 - 06:44
На форме такие процедуры:
  &НаКлиенте
  Процедура Сформировать(Команда)
    Сотрудники = Новый массив;
    Сотрудники.Добавить(ЭтаФорма.СОтрудник);
     ВыполняемаяКомандаИдентификатор = "ДоговорВодителиСменныйНеРазъезд";
     Печать(ВыполняемаяКомандаИдентификатор,Сотрудники);
  КонецПроцедуры
  &НаКлиенте
  Процедура Печать(ВыполняемаяКомандаИдентификатор, МассивОбъектов) Экспорт
    МассивДанных = СобратьДанные(МассивОбъектов);
    МассивИменФайлов = Неопределено;
    СервернаяПечать(ВыполняемаяКомандаИдентификатор, МассивДанных, МассивИменФайлов);
    Для Каждого ИмяФайла из МассивИменФайлов Цикл
        ОпПослеЗапускаПриложения = Новый ОписаниеОповещения("ПослеЗапускаПриложения", ЭтотОбъект, ИмяФайла);
        НачатьЗапускПриложения(ОпПослеЗапускаПриложения, ИмяФайла);
    КонецЦикла;    
  КонецПроцедуры

"Сформировать" - это отладочная процедура, она реагирует на нажите кнопке и вызывает Печать(), которую в продакшене будет вызывать сама 1ска, когда пользователь выберет печать у себя. Собираются данные, вызывается СервернаяПечать на сервере, которая сформирует файлы Word и выложит их на сетевую шару, вернув имена. А Печать() их просто откроет. В отладке на клиент-серверном режиме все работает идеально. Но когда я внедряю внутрь, чтобы 1ска штатным режимом вызывала процедуру Печать(), COM не запускается вот этот кусок процедуры СервернаяПечать():

   Word = Новый COMОбъект("Word.Application");
   Word.Displayalerts = 0;
   ДокументН = Word.Application.Documents.Add();
   ДокументН.SaveAs(ВремФайл,0);                
   Word.Quit();

>>Ошибка - Ошибка при вызове конструктора (COMОбъект) код ошибки - Word = Новый COMОбъект("Word.Application");

Если кто-то решал эту проблему, буду признателен решению.
 
 
   Провинциальный 1сник
 
1 - 06.07.19 - 06:51
Безопасный режим обработки отключить не забыли?
   Target1025
 
2 - 07.07.19 - 10:21
(1) Да, вы правы. ПОсле сняти обрамления Попытка/КонецПопытки, выскакивает ошибка - "Установлен безопасный режим. Выполнение операции запрещено"

Что тут можно сделать?
   Target1025
 
3 - 07.07.19 - 10:35
Победил, отменив установку безопасного режима в Истину. Но остался вопрос - Можно ли и оставить ее в безопасном режим, и при этом разрешить запуск внешний компонентН? ПО идее настройка РазрешениеНаИспользованиеВнешнейКомпоненты должна как-то это разрешать, но пока что не понимаю как ее использовать?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует