Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Пишет пользователю при отмене проведение Нарушение прав пользователя

Пишет пользователю при отмене проведение Нарушение прав пользователя
Я
   1сЮлия
 
05.07.19 - 10:33
Доброе утро! Хотя в документе,я уже поставила все галочки права на документ. Документ нетиповой.Добавление,Проведение нормально.
 
 
   Гипервизор
 
1 - 05.07.19 - 10:44
В "1С: Управление небольшим колхозом" такое бывает.
   ДенисЧ
 
2 - 05.07.19 - 10:46
а в журнале регистрации что пишется при этом?
   piter3
 
3 - 05.07.19 - 10:47
Вангую отмена проведения не поставила
   lxs
 
4 - 05.07.19 - 10:49
А кто нарушил права пользователя-то? ))))
   1сЮлия
 
5 - 05.07.19 - 10:51
Где в роли? Если в роли то єтому документу я уже все галочки поставила.
   lxs
 
6 - 05.07.19 - 10:53
(5) На регистры нет прав достаточных
   piter3
 
7 - 05.07.19 - 10:54
(5) Вас нужно упросить посмотреть в ЖР?
   catena
 
8 - 05.07.19 - 10:55
(5)а в журнале регистрации что пишется при этом?
   Гипервизор
 
9 - 05.07.19 - 10:57
Конфа секретная, понятно.
Проверьте еще права на последовательности. ПартионныйУчет или что-то такое.
Вообще отладкой попытайтесь воспользоваться. Может в конфе удаление движений через подписку организовано, так что смотреть надо.
   lxs
 
10 - 05.07.19 - 10:58
(9) Нетиповой документ, начинающий программист, которому лень читать инструкции и книжки..
   piter3
 
11 - 05.07.19 - 10:59
(10) офф 7 лет уже как бы)))
   1сЮлия
 
12 - 05.07.19 - 11:04
Не все 7 лет,это на форуме. В журнале регистрации нет прав на администрирование данных.
   1сЮлия
 
13 - 05.07.19 - 11:04
8 кой конкретно ну может 2ой год сейчас занимаюсь.
   1сЮлия
 
14 - 05.07.19 - 11:07
7кой тоже занималсь,ну та отличается от 8 есть схожесть но не очень.
   1сЮлия
 
15 - 05.07.19 - 11:07
Спасибо вам большое,что есть к кому обратиться?
   1сЮлия
 
16 - 05.07.19 - 11:13
ругается пишет Отказано в доступе Право : Администрирование
   catena
 
17 - 05.07.19 - 12:01
(16)Ну значит, что при отмене проведения этот документ делает какие-то действия, на которые нужно право Администрирование.
   1сЮлия
 
18 - 05.07.19 - 13:42
проваливается сюда Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    Если ОбменДанными.Загрузка  Тогда
        Возврат;
    КонецЕсли;
    
    Если Не ЗначениеЗаполнено(ВидОперации) Тогда
        Сообщить("Для документа не установлен вид операции!");
        Отказ = Истина;
    КонецЕсли;    

    
    МассивСерий =Новый Массив();
    Для Каждого Строка Из Серии Цикл
        МассивСерий.Добавить(Строка.СерияНоменклатуры);
    КонецЦикла;
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    аэсОперацияКВЛ.СерияНоменклатуры,
        |    аэсОперацияКВЛ.Ссылка
        |ИЗ
        |    Документ.аэсОперацияКВЛ.Серии КАК аэсОперацияКВЛ
        |ГДЕ
        |    аэсОперацияКВЛ.СерияНоменклатуры В(&СерияНоменклатуры)
        |    И аэсОперацияКВЛ.Ссылка <> &Ссылка
        |    И аэсОперацияКВЛ.Состояние = ИСТИНА 

        |    И аэсОперацияКВЛ.Ссылка.ВидОперации = &ВидОперации";
    
    Запрос.УстановитьПараметр("СерияНоменклатуры",МассивСерий);
    Запрос.УстановитьПараметр("Ссылка",Ссылка);
    Запрос.УстановитьПараметр("ВидОперации",ВидОперации);

    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если  ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.СерияНоменклатуры) тогда
            Сообщить("Документ с такой серией "+ВыборкаДетальныеЗаписи.СерияНоменклатуры+" уже существует!"+ВыборкаДетальныеЗаписи.Ссылка+"");
           Отказ = ИСТИНА;
           КонецЕсли;
    КонецЦикла;
 
    Запрос = Новый Запрос;
    Запрос.Текст = 
    
    "ВЫБРАТЬ
    |    аэсСертификацияСерии.СерияНоменклатуры КАК СерияНоменклатуры,
    |    аэсСертификацияСерии.Ссылка
    |ИЗ
    |    Документ.аэсСертификация.Серии КАК аэсСертификацияСерии
    |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.аэсОперацияКВЛ.Серии КАК аэсОперацияКВЛ
    |        ПО аэсСертификацияСерии.СерияНоменклатуры = аэсОперацияКВЛ.СерияНоменклатуры
    |            И (аэсСертификацияСерии.РезультатСертификации = ЗНАЧЕНИЕ(Перечисление.РезультатыСертификацииНоменклатуры.ОтказаноВСертификации))
    |ГДЕ
    |    аэсОперацияКВЛ.Ссылка = &Ссылка
    |    И аэсОперацияКВЛ.СерияНоменклатуры В(&СерияНоменклатуры)";
    
    Запрос.УстановитьПараметр("СерияНоменклатуры",МассивСерий);
    Запрос.УстановитьПараметр("Ссылка",Ссылка);
    
    Результат = Запрос.Выполнить();
    
    Выборка = Результат.Выбрать();
    
    Пока Выборка.Следующий() Цикл
            Сообщить("Деталь с таким номером "+Выборка.СерияНоменклатуры+" уже забракована "+Выборка.СерияНоменклатуры+" Документом!"+Выборка.Ссылка+"");
               Возврат;
    КонецЦикла;
    
    Для Каждого Строка Из Серии Цикл
         Строка.Количество = Число(1);
    КонецЦикла;    

    мУдалятьДвижения = НЕ ЭтоНовый();
КонецПроцедуры// ПередЗаписью

отрабатывает полностью и на выход нарушение прав доступа
   1сЮлия
 
19 - 05.07.19 - 13:45
потом сюда ОбработкаУдаленияПроведенияДокумент
   1сЮлия
 
20 - 05.07.19 - 15:11
Тут разобралсь

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.