Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отображение динамического списка

Отображение динамического списка
Я
   Alex1234
 
04.07.19 - 17:02
Столкнулся с проблемой, не обновляется динамический список после удаления отбора.

Функция УдалитьОтбор(СписокОтборов, ИмяПоля = "")
    СписокОтборов = дсСправочник.КомпоновщикНастроек.Настройки.Отбор;
    ИмяПоля = "Подработан";
    Если ПустаяСтрока(ИмяПоля) Тогда
        СписокОтборов.Элементы.Очистить();
        Возврат Истина;
    КонецЕсли;
    Поле = Новый ПолеКомпоновкиДанных(ИмяПоля);
    ОтборУдален = Ложь;
    Для каждого ЭлементОтбора Из СписокОтборов.Элементы Цикл
        Если ЭлементОтбора.Использование И ЭлементОтбора.ЛевоеЗначение = Поле Тогда
            СписокОтборов.Элементы.Удалить(ЭлементОтбора);
            //ЭлементОтбора.Использование=Ложь;
            //дсСправочник.КомпоновщикНастроек.ФиксированныеНастройки.Отбор.Элементы.Удалить(ЭлементОтбора);
            ОтборУдален = Истина;
        КонецЕсли;
    КонецЦикла;
    Элементы.дсСправочник.Обновить();
          Возврат ОтборУдален;
КонецФункции


&НаКлиенте
Процедура ОтборыОчистка()
    УдалитьОтбор(,ИмяПоля = "");
    Элементы.дсСправочник.Обновить();


КонецПроцедуры
 
 
   dubolom
 
1 - 05.07.19 - 13:23
Отладчиком смотрел - отборы-то удаляются?
   butterbean
 
2 - 05.07.19 - 13:31
ОбновитьОтображениеДанных()

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.