Вход | Регистрация
 

При выборе отмены изменений, все равно изменяет значение

При выборе отмены изменений, все равно изменяет значение
Я
   Niraterra
 
04.07.19 - 13:57
Добрый  день, у меня при изменении реквизита в шапке документа, должно всплывать окно с в выбором: принять или отменить изменения?(при этом табличная часть документа очищается), но у меня при выборе отмена, поле заполняется новым выбором и оставляет ТЧ без изменений. Что не так?

Функция ПроверкаДанныхТабличнойЧасти(Текст)
    Если Таблица.Количество()> 0 Тогда
        Кнопки = Новый СписокЗначений;
        Кнопки.Добавить("Отмена");
        Кнопки.Добавить("Продолжить");
        Ответ = Вопрос(Текст, Кнопки);
        Если Ответ = "Продолжить" Тогда
            Таблица.Очистить();
            Ответственные.Очистить();
            Возврат Истина;
        Иначе
            //Возврат Ложь;
        КонецЕсли;
    Иначе
        Возврат Истина;
    КонецЕсли;
КонецФункции
 
 
   Йохохо
 
1 - 04.07.19 - 14:03
Режим = РежимДиалогаВопрос.ДаНет;
Ответ = Вопрос(НСтр("ru = 'Запоняшить?';"
     + " en = 'Do you want to zaponyawit'?'"), Режим, 0);
Если Ответ = КодВозвратаДиалога.Нет Тогда
    Возврат;
КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует