Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отбор в форме выбора справочника для заполнения табличной части

Отбор в форме выбора справочника для заполнения табличной части
Я
   JuixyJes
 
03.07.19 - 12:15
Доброго времени суток! Сделала  процедуру для команды "Добавить", в теории для заполнения ТЧ документа.

&НаСервере
Процедура ДобавитьНаСервере()
    
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Номенклатура.ВидНоменклатуры КАК ВидНоменклатуры,
        |    Номенклатура.Наименование КАК Наименование
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |    Номенклатура.ВидНоменклатуры.ЭтоГруппа = ЛОЖЬ
        |    И Номенклатура.ВидНоменклатуры.Наименование = ""Доп. Услуги""";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    СЗ = Новый СписокЗначений;
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СЗ.Добавить(ВыборкаДетальныеЗаписи.Наименование);
    КонецЦикла;
    СЗ.ОтметитьЭлементы();
    Для каждого стр из СЗ цикл
        НСТР = Объект.Услуга.Добавить();
        НСТР.Наименование = стр.Значение;
    КонецЦикла;

КонецПроцедуры
 
 
   JuixyJes
 
1 - 03.07.19 - 12:15
Процедура сама по себе отрабатывает, но вот строки не заполняются 

 Для каждого стр из СЗ цикл 
        НСТР = Объект.Услуга.Добавить(); 
        НСТР.Наименование = стр.Значение; 
    КонецЦикла;
   JuixyJes
 
2 - 03.07.19 - 12:16
Особенно в этом моменте мне не понятно. В табличке создается 3 строки, но заполнения нет..
   JuixyJes
 
3 - 03.07.19 - 12:20
Знаю что можно через доп форму выбора сделать.
   Йохохо
 
4 - 03.07.19 - 12:27
Номенклатура.Наименование -> Номенклатура.Ссылка косяк 99%
НСТР.Наименование косяк 99%, надо проверить поля тч и тип
Вам надо во франч месяца на половину, потом перерыв и еще на полгода
   hhhh
 
5 - 03.07.19 - 12:29
(1) попробуйте
     |    И ПОДСТРОКА(Номенклатура.ВидНоменклатуры.Наименование, 1, 11) = ""Доп. Услуги"""; 

хотя это и гамнокод
   JuixyJes
 
6 - 03.07.19 - 12:30
(4) Нууу, куда мне и что надо я сама решу, хорошо?)
   Йохохо
 
7 - 03.07.19 - 12:35
(6) хорошо, Радченко под подушку рекомендую. А еще точку останова на КонецЦикла и посмотреть что в НСТР и какие типы
   JuixyJes
 
8 - 03.07.19 - 12:41
(7) НСТР.Наименование  Тип(СправочникСсылка.Номенклатура)
    стр Тип(строка)

А как в список значений вставить ссылки ?
   JuixyJes
 
9 - 03.07.19 - 12:42
(7) А вот за Радченко благодарю)
   catena
 
10 - 03.07.19 - 12:42
(8)Как строки, только ссылки.
 
 Рекламное место пустует
   sqr4
 
11 - 03.07.19 - 12:44
ФОТО!
   catena
 
12 - 03.07.19 - 12:44
А зачем сначала список заполнять, а потом по списку тч?
   Йохохо
 
13 - 03.07.19 - 12:44
|    Номенклатура.Ссылка КАК НоменклатураТутСсылкаНаСправочникНоменклатура
        |ИЗ
        |    Справочник.Номенклатура КАК Номенклатура
ВыборкаДетальныеЗаписи.НоменклатураТутСсылкаНаСправочникНоменклатура
   catena
 
14 - 03.07.19 - 12:45
(13)Так каждый может. Ты ей лучше Хаффмана так напиши.
   JuixyJes
 
15 - 03.07.19 - 12:46
(10) спасибо) решено)
   JuixyJes
 
16 - 03.07.19 - 12:46
(14) ахах, все мою тему про Хаффмана обсуждать будут?)
   Йохохо
 
17 - 03.07.19 - 12:47
(16) да, в пятницу можешь поменять Хафмана на что то еще

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует