Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Непонятное поведение управляемых форм в неуправляемой конфигурации после миграциина Centos

Непонятное поведение управляемых форм в неуправляемой конфигурации после миграциина Centos
Я
   NavigatorKZ
 
03.07.19 - 11:47
Всем привет!

В общем суть:
Конфигурации БК2.0, УТП2.0 - для Казахстана, на простых формах.
В файловом режиме и на сиквеле все формы отображаются ровно, то есть стандартные и управляемые, а вот после миграции на Postgresql9.6 на CentOS управляемые формы стали "кривыми".При этом БК3.0 на управляемых формах работает корректно :)
А есть еще вариант с ошибкой "Ошибка выполнения запроса - Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:"

Кто, что подскажет?
 
 
   Жан Пердежон
 
1 - 03.07.19 - 11:56
подскажу перейти полностью на УФ
   Cyberhawk
 
2 - 03.07.19 - 11:59
Так пади и сервер 1С был Вин, а стал Лин?
   NavigatorKZ
 
3 - 03.07.19 - 12:06
не вариант перехода на УФ, конфига дописана сильно уже давно.
раньше да, сервер Windows+MS SQL был.
   Garykom
 
4 - 03.07.19 - 12:17
Хрень какая то у вас написана если честно.
Если я скажу что думаю то обидитесь как обычно бывает.
   NavigatorKZ
 
5 - 03.07.19 - 12:48
Garykom, сумбурно? суть не ясна?
   Cyberhawk
 
6 - 03.07.19 - 12:51
Ну так у тебя значит не "после миграции на Postgresql9.6 на CentOS", а после миграции сервера 1С на Лин такое
   Garykom
 
7 - 03.07.19 - 12:56
(6) Мне интереснее есть ли RDP и где
   Garykom
 
8 - 03.07.19 - 12:57
(7)+ Потому что если клиенты на Win то кривые формы и сервер на Lin слабо связаны.
   NavigatorKZ
 
9 - 03.07.19 - 13:06
RDP нет, работаем в клиент-серверном.
релиз 1С 8.3.12.1714
сейчас экспериментальным путем выяснили, что если поставить сервер х64 и установить библиотеки (на centos) imagemagick 6 версии, то все работает, вот под х32 фиг.
у клиента как раз х32 сервер.

прорисовка УФ связана с сервером 1с на Centos… оказывается.
   Garykom
 
10 - 03.07.19 - 13:09
Понял у вас в толстых клиентах смесь ОФ и УФ.
   Garykom
 
11 - 03.07.19 - 13:12
Скорее всего у вас centos x86_64 и имаджик надо ставить не дефолтный x86_64 а именно i686 (x32) для x32 сервера 1С
   Garykom
 
12 - 03.07.19 - 13:13
Ну или centos x86 просто 32-х битный вместо 64
   NavigatorKZ
 
13 - 09.07.19 - 09:10
да, верно все.
если юзаешь ОС х32 то и сервер 1с нужен х32, ну и с х64 та же песня.
спасибо всем!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.