Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УФ заполнить ТЧ из внешней обработки заполнения объекта

УФ заполнить ТЧ из внешней обработки заполнения объекта
Я
   Septera
 
03.07.19 - 10:48
Доброго времени суток!
С горем написал внеш. обработку для заполнения ТЧ документа, но не въеду как изменить ТЧ на сервере, ничего не происходит. На форме обработки вызываю процедуру на сервере:
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    ВладелецФормы_Объект = ВладелецФормы.Объект;
    
    ДопОбработка(ВладелецФормы_Объект);
КонецПроцедуры

&НаСервере
Процедура ДопОбработка(ВладелецФормы_Объект)
    Для каждого ТекущаяСтрока из ВладелецФормы_Объект.ДелаХраненияДокументов Цикл
        ТекущаяСтрока.ДелоХраненияДокументов = Справочники.ДелаХраненияДокументов.НайтиПоНаименованию("Архив2 (том №1)", Истина);
    КонецЦикла ;
КонецПроцедуры

 
 
   aleks_default
 
1 - 03.07.19 - 10:49
на клиенте делай
   aleks_default
 
2 - 03.07.19 - 10:50
Справочники.ДелаХраненияДокументов.НайтиПоНаименованию("Архив2 (том №1)", Истина); -вынеси в серверную функцию
А обход и заполнение оставь на клиенте
   aleks_default
 
3 - 03.07.19 - 10:52
причем не надо делать нахождение элемента справочника в каждой итерации, вынеси ее сразу в переменную, ато говнокод
   Septera
 
4 - 03.07.19 - 14:32
(2) благодарю, работает!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.