Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Можно ли обратиться к экспортной переменной полученной формы?

Можно ли обратиться к экспортной переменной полученной формы?
Я
   brenli
 
03.07.19 - 09:26
Конфа УТ 10.3. Подключили пинпад и при попытке рассчитаться картой вылезла ошибка..
Посмотрел в конфигураторе и ничего не понимаю. Разработчики данной обработки пытаются обратиться к переменным объявленным в модуле формы как к полям.
Так вообще можно или я чего то не понимаю?
// ..............................
Форма = ПолучитьФорму("ФормаАвторизации");
    Форма.мОперация = "Оплата";
    Форма.мСумма = Сумма;
// ..............................

//----------Модуль формы авторизация---------
///////////////////////////////////////////////////////////////////////////////
//// ПЕРЕМЕННЫЕ МОДУЛЯ

Перем мНетОшибки;
Перем мОперация Экспорт;
Перем мСумма Экспорт;

Процедура КоманднаяПанель1Авторизовать(Кнопка)
    мСумма = ЭтаФорма.ЭлементыФормы.Сумма.Значение;
    Закрыть(КодВозвратаДиалога.ОК);
КонецПроцедуры

Процедура КоманднаяПанель1Закрыть(Кнопка)
    Закрыть(КодВозвратаДиалога.Отмена);
КонецПроцедуры

Процедура ПриОткрытии()
    ЭтаФорма.Заголовок = мОперация;
    ЭтаФорма.ЭлементыФормы.КоманднаяПанель1.Кнопки.Авторизовать.Текст = мОперация + " платежа";
    ЭтаФорма.ЭлементыФормы.Сумма.Значение = мСумма;
КонецПроцедуры

Процедура МеждународнаяПриИзменении(Элемент)
    мТипКарты = Международная;
КонецПроцедуры

мТипКарты = 0;
 
 
   ДенисЧ
 
1 - 03.07.19 - 09:30
Главное - никому никогда не говори, какая ошибка появляется...
А то вдруг все хором подумают, что ошибка у тебя в ДНК...
   toypaul
 
2 - 03.07.19 - 09:32
можно. хоть это и "не красиво"
   brenli
 
3 - 03.07.19 - 09:36
(2) а как можно?
Пример в студию?
Так же как в  приведенном примере кода?
   lodger
 
4 - 03.07.19 - 09:41
(3) так можно.
пример выше.
да.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.