Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печать ИНН контрагента в чеке ККМ

Печать ИНН контрагента в чеке ККМ
Я
   ppa32
 
02.07.19 - 05:04
Добрый день всем

В связи с изменениями в законодательстве теперь необходимо печатать ИНН контрагента в чеке. Для этого я добавил поле CustomerINN в XML, который передается драйверу ККМ. После моих доработок XML стал выглядеть примерно так:

[code]
<?xml version="1.0" encoding="UTF-8"?>
<CheckPackage>
    <Parameters PaymentType="1" TaxVariant="0" CashierName="Кассирова Кассирша Кассировна" CustomerEmail="" CustomerPhone="" CustomerInfo="ИП Пупкин Василий Васильевич" CustomerINN="650801094561">
        <AgentData/>
        <PurveyorData/>
    </Parameters>
    <Positions>
        <FiscalString Name="Принято от: ИП Пупкин Василий Васильевич Основание: Реализация товаров и услуг ТЕЦ00073076 от 25.06.19" Quantity="1" PriceWithDiscount="827.5" SumWithDiscount="827.5" DiscountSum="" Department="0" Tax="10" SignMethodCalculation="3" SignCalculationObject="1" TaxSum="75.23"/>
    </Positions>
    <Payments Cash="827.5" ElectronicPayment="0" Credit="0" AdvancePayment="0" CashProvision="0"/>
</CheckPackage>
[/code]

Эта XML-ка, которую я выловил в дебаге непосредственно перед тем, как она передаётся драйверу. Поле CustomerINN там есть, но печататься в чеке не хочет. Никаких ошибок при печати не возникает. Такое чувство, как будто этот тег просто игнорится, не понятно почему.

однако никаких отличий в распечатанном чеке не появилось. Вопрос: как заставить шайтан - машину печатать этот ИНН?

Версия драйвера ККТ АТОЛ: 10.5.0
Версия платформы: 8.3.12.1685
Конфа: сильно переписанная УТ 10.3
Версия обработки Atolkkt: 2.9
Модель ККМ: FPrint-22
Версия прошивки ККМ: 10-7733

Подскажите, пожалуйста, в чем может быть причина?
 
 
   Kremiln
 
1 - 02.07.19 - 05:17
   ppa32
 
2 - 02.07.19 - 08:06
(1) Если вы имеете в виду, что у кого - то не взлетело на версии драйвера 10.5.0, то изначально стояло 10.4.2. И да, на ней - тот же эффект.
   ppa32
 
3 - 02.07.19 - 08:06
Было 10.4.2, не взлетело. Поставил 10.5.0. Аналогично.
   rozer76
 
4 - 02.07.19 - 08:09
(3) см (1) пост 459
   ppa32
 
5 - 03.07.19 - 02:38
(1) (4) Всё отлично заработало! Проблема была именно в этом! Большое человеческое спасибо вам!
   Navnastya
 
6 - 03.07.19 - 10:39
Добрый день.
Конфигурация Бухгалтерия предприятия  3.0(3.0.71.69)


Версия драйвера ККТ АТОЛ: 10.5.0 
Атол 30ф
Версия прошивки 10-7733 

Не выводятся реквизиты покупателя в чеке. Версия драйвера отображается как  10.4.
   rozer76
 
7 - 03.07.19 - 10:41
(6) сколько платите ?
   andkr
 
8 - 10.07.19 - 22:31
Откуда в Рознице 2.2 нужно печатать чек, чтобы ИНН покупателя выводился?
Из РМК или надо документ реализацию делать?
   Сияющий в темноте
 
9 - 11.07.19 - 08:51
(8) а в рмк у нас уже юридические лица вводятся?
   andkr
 
10 - 11.07.19 - 09:12
(9) там вводится карта, которая теоретически может быть привязана к юрлицу.
Можете прямо ответить на вопрос?
Через реализацию раньше чеки не пробивали.
И там нет выбора оплаты.
Значит надо делать ПКО. Будут ли там перечень товаров и реквизиты покупателя?
Экспериментировать на действующей кассе не хочется. Поэтому и спрашиваю.
   lyumi
 
11 - 12.07.19 - 12:45
Доброго... ситуация схожа
1С ут 10.3 последняя
Обработка обслуживания последняя
Драйвер 10.5.0 отображается как 10.4.4
Атол 55Ф
Ну не печатает оно ИНН и Наименование...шо делать ?
   МаксимНижегородец
 
12 - 12.07.19 - 13:15
(11) У нас тоже АТОЛ 55ф. Нужно обновить прошивку до 7942. Драйверы до 10.5. 1С компоненту 10.5 из ДТО. Но компонента глючная и с ней могут быть проблемы (вот у меня Статус Смены не верно показывает). Но наименование клиента и ИНН точно будет выводить.
   karpik666
 
13 - 12.07.19 - 13:18
(11) все печатается, уже 10-ток тем про это.
   МаксимНижегородец
 
14 - 12.07.19 - 13:18
Да, и предыдущие драйверы 10.4.4 нужно предварительно сносить полностью (в ноль). На каждом ККМ убирать ручками.
   karpik666
 
15 - 12.07.19 - 13:20
Вот видео даже записал https://www.youtube.com/watch?v=LAiJ1Bf3z3U
   МаксимНижегородец
 
16 - 12.07.19 - 13:20
(13) Кинь ссылку про СтатусСмены, может уже кто-то решил эту проблему.
   karpik666
 
17 - 12.07.19 - 13:29
(16) уже отправил
   lyumi
 
18 - 12.07.19 - 14:10
(11) закинул компоненту и знаете что ? наименование (правда фактическое а не ооо) печатается, инн тоже, но дальше чек анулирован, а 1с выдает ошибку "Неверная длина"... фак
   mpei
 
19 - 12.07.19 - 14:36
там нужно несколько общих модулей менять, я тоже сначала только в одно месте costumer  добавил. В итоге сделал так: взял типовую бухгалетрию и все что связано с изменениями внес в свою базу
   mpei
 
20 - 12.07.19 - 14:38
(18) // По фискальному устройству определяет статус смены и проверяет ее активность. Под активностью понимается соблюдение следующих условий:
// - кассовая смена не закрыта

// - с момента открытия кассовой смены прошло не более 24 часов
//

// Параметры:
//  ФискальноеУстройство - СправочникСсылка.ПодключаемоеОборудование - фискальное устройство, для которого требуется определить активность смены

//
// Возвращаемое значение:

//  Результат - Структура
//    Открыта - Булево - Истина - смена открыта, Ложь - смена закрыта.

//    Активна - Булево - Истина - смена открыта, Ложь - смена закрыта, прошло более 24 часов с момента открытия или никогда не была открыта.
//    ТекущийНомерЧека - Число - текущий номер чека ККТ.

// 
Функция СтатусПоследнейСмены(ФискальноеУстройство) Экспорт
    
    РезультатОперации = Новый Структура();
    РезультатОперации.Вставить("Активна", Ложь);
    РезультатОперации.Вставить("Открыта", Ложь);
    РезультатОперации.Вставить("ТекущийНомерЧека");
    РезультатОперации.Вставить("НомерСмены");
    РезультатОперации.Вставить("КассоваяСмена");
    РезультатОперации.Вставить("НомерСменыККТ");
    РезультатОперации.Вставить("ДатаИстеченияСрокаДействия");
       
    ОписаниеПоследнейСмены = ОписаниеПоследнейКассовойСмены(ФискальноеУстройство);
    
    Если Не (ОписаниеПоследнейСмены = Неопределено) Тогда
        РезультатОперации.Открыта = ОписаниеПоследнейСмены.Статус = Перечисления.СтатусыКассовойСмены.Открыта; 
        РезультатОперации.Активна = РезультатОперации.Открыта 
            И ОписаниеПоследнейСмены.ДатаИстеченияСрокаДействия > МенеджерОборудованияВызовСервера.ДатаСеанса();
        Если ФискальноеУстройство.ТипОборудования <> Перечисления.ТипыПодключаемогоОборудования.ККТ Тогда
            РезультатОперации.ТекущийНомерЧека = ПолучитьТекущийНомерЧекаККТ(ФискальноеУстройство, ОписаниеПоследнейСмены.КассоваяСмена);
        КонецЕсли;
        РезультатОперации.КассоваяСмена    = ОписаниеПоследнейСмены.КассоваяСмена;
        РезультатОперации.НомерСмены       = ОписаниеПоследнейСмены.КассоваяСмена.Номер;
        РезультатОперации.НомерСменыККТ    = ОписаниеПоследнейСмены.КассоваяСмена.НомерСменыККТ;
        РезультатОперации.ДатаИстеченияСрокаДействия = ОписаниеПоследнейСмены.ДатаИстеченияСрокаДействия;
    КонецЕсли;
    
    Возврат РезультатОперации;
    
КонецФункции
   mpei
 
21 - 12.07.19 - 14:39
// По фискальному устройству определяет последнюю смену и получает ее реквизиты.

//
// Параметры:

//  ФискальноеУстройство - СправочникСсылка.ПодключаемоеОборудование - фискальное устройство, для которого требуется определить активность смены.
//

// Возвращаемое значение:
//  Структура - реквизиты кассовой смены, Неопределено - если ни одной смены не было открыто. Содержит следующие реквизиты:

//    КассоваяСмена - ДокументСсылка.КассоваяСмена - ссылка на кассовую смену
//    ФискальноеУстройство - СправочникСсылка.ПодключаемоеОборудование - ссылка на устройство, на котором открыта смена

//    НачалоКассовойСмены - Дата - дата открытия смены
//    ОкончаниеКассовойСмены - Дата - дата закрытия смены (если смена закрывалась)

//    ДатаИстеченияСрокаДействия - дата, в которую закончиться срок действия смены (дата открытия + 24 часа)
//    Организация - организация, указанная в документе КассоваяСмена

//    Статус - статус кассовой смены
Функция ОписаниеПоследнейКассовойСмены(ФискальноеУстройство) Экспорт
    
    УстановитьПривилегированныйРежим(Истина);
    
    Запрос = Новый Запрос();
    Запрос.Текст =
    "ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
    |    КассоваяСмена.Ссылка КАК КассоваяСмена,
    |    КассоваяСмена.ФискальноеУстройство КАК ФискальноеУстройство,
    |    КассоваяСмена.НачалоКассовойСмены КАК НачалоКассовойСмены,
    |    КассоваяСмена.ОкончаниеКассовойСмены КАК ОкончаниеКассовойСмены,
    |    ДОБАВИТЬКДАТЕ(КассоваяСмена.НачалоКассовойСмены, ДЕНЬ, 1) КАК ДатаИстеченияСрокаДействия,
    |    КассоваяСмена.Организация КАК Организация,
    |    КассоваяСмена.Статус КАК Статус
    |ИЗ
    |    Документ.КассоваяСмена КАК КассоваяСмена
    |ГДЕ
    |    КассоваяСмена.ФискальноеУстройство = &ФискальноеУстройство
    |    И КассоваяСмена.Проведен
    |
    |УПОРЯДОЧИТЬ ПО
    |    КассоваяСмена.НачалоКассовойСмены УБЫВ,
    |    КассоваяСмена.НомерСменыККТ УБЫВ";
    Запрос.УстановитьПараметр("ФискальноеУстройство", ФискальноеУстройство);
    Результат = Запрос.Выполнить().Выгрузить();
    
    Если Результат.Количество() = 0 Тогда
        Возврат Неопределено;
    Иначе
        СтруктураРезультат = Новый Структура();
        Для Каждого КолонкаРезультата Из Результат.Колонки Цикл
            СтруктураРезультат.Вставить(КолонкаРезультата.Имя, Результат[0][КолонкаРезультата.Имя]);
        КонецЦикла;
        Возврат СтруктураРезультат;
    КонецЕсли;
    
КонецФункции
   lyumi
 
22 - 12.07.19 - 15:06
(18) ну хелп, плиз... ошибка "Неверная длина" появляется при печати из ПКО, из реализации же печатает чек, но обрезает серию. В общем вмещает 48 символов где-то. Как это поправить ?
   lyumi
 
23 - 15.07.19 - 15:52
(22) (613) Если кому пригодится, то проблема решилась обновлением Ут до 10.3.54.4. Чеки стали печататься из ПКО с выведением нужной информации.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.