Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

QR коде из 1с

QR коде из 1с
Я
   ВикторП
 
28.06.19 - 17:21
Формирую QR коде из 1с.
Почему - то он потом не читается - ни на банкомате , ни в приложении. :)

Есть кто успешно печатает QR коды?

Я ввожу тестовый с данными Первая налоговая Москвы и плательщик Иванов Иван Иванович.
 
 
   Ц_У
 
1 - 28.06.19 - 17:22
Поклади на сюда, мы посмотрим
   Быдло замкадное
 
2 - 28.06.19 - 17:23
у нас из бартендера печатают, он тоже не читается))) зачем печатают...
   ВикторП
 
3 - 28.06.19 - 17:26
Что положить- QR code или код из 1с?
Печатаю из конфигурации Бухгалтерия гос учреждения 2.0.63.38
   Ц_У
 
4 - 28.06.19 - 17:27
(3) КР код
   ВикторП
 
5 - 01.07.19 - 11:13
ИЗ демо- конфигурации БСП - такая же история - печатаются, но не читаются
   Гипервизор
 
6 - 01.07.19 - 11:28
БП 3 - полет нормальный
   cons24
 
7 - 01.07.19 - 11:49
(0) дай угадаю, хочешь чтоб через Сбер оплату делали клиенты? А вот фиг тебе.
Надо зарегистрироваться как поставщик в Сбере.
(хотя налоговая вроде бы должна проходить...)
   ВикторП
 
8 - 01.07.19 - 12:12
Сейчас проверю БП 3
   ВикторП
 
9 - 01.07.19 - 12:16
(7) налоговая должна проходить , у меня есть QR коде , сформированный на сайте налоговой, который читается и банкоматом и приложением, из 1с пока нет :(.
   ВикторП
 
10 - 01.07.19 - 12:20
(6) В БП 3 пока не вижу ничего кроме штрихкода для товара, пусть он QR , но такая штука мне не нужна.

Не вижу для документа или справочника - что Вы имели в виду под "нормальным полетом"
 
 Рекламное место пустует
   vladmenleo
 
11 - 01.07.19 - 12:35
У нас Ут 11.4 Дорабатывал по аналогии с розницей, чтоб печатался QR код на препроводительных ведомостях к сумке при инкассации. Формат строки, которую надо сформировать давал сам банк. все печатается, все читается. Когда QR картинка была маленькая (примерно 15х15 мм) то не все сканеры читали, увеличил до примерно 20х20, все стало ОК
   Гипервизор
 
12 - 01.07.19 - 12:42
(10) Я имел ввиду что я использую типовые процедуры формирования QR-кода и спокойно вывожу эти коды в любые нужные мне квитанции.
   Hmster
 
13 - 01.07.19 - 12:57
а телефоном он хотя бы читается? Может при формировании ошибка происходит. Параметрами поиграться не пробовали?
   ВикторП
 
14 - 01.07.19 - 12:58
(12) Для формирования используются 

QRСтрока = УправлениеПечатью.ФорматнаяСтрокаУФЭБС(РеквизитыПлатежа);

и 
ДанныеQRКода = УправлениеПечатью.ДанныеQRКода(QRСтрока, 1, 190);


Проблема в корректном формировании РеквизитыПлатежа.


Я уже написал в техподдержку 1с. До истины я все равно докопаюсь.

А Вы можете прислать заполненную структуру РеквизитыПлатежа, из которой потом формируется читабельный QR code?
   ВикторП
 
15 - 01.07.19 - 13:00
(13) читаться он читается, как платеж он не разбирается
Сообщение
По отсканированному штрих-коду не найдена ни одна услуга ...
   arsik
 
16 - 01.07.19 - 13:09
(15) :) А с чего терминал сбера должен уметь парсить вашу строку зашитую в QR? Ему нужно подсунуть строку по его формату.
   arsik
 
17 - 01.07.19 - 13:13
   ВикторП
 
18 - 01.07.19 - 13:16
(15,16) Вы не в теме :)
   arsik
 
19 - 01.07.19 - 13:19
(18) Ну так проверь, что не так. Сделай строку по стандарту и свою. Ну понятно же, что у тебя там данные, которые сбер не может распарсить правильно.
   Trotter
 
20 - 01.07.19 - 13:21
из БГУ вытащите.
   ВикторП
 
21 - 01.07.19 - 13:28
(20) я поставил БГУ- такая же история :( - не читается
   ВикторП
 
22 - 02.07.19 - 14:46
В итоге я разобрался.
Причина - в формировании QR-строки функцией БСП.
Для того, чтобы QR коде читался как платеж надо ее формировать чуть по другому- нужен другой порядок некоторых из дополнительных реквизитов. в документации написано что порядок не важен, оказалось, не так.
Плюс к этому -обязательно надо добавлять индекс платежного документа и в конце еще дописывать признак разделения- без этого QR не читается мобильным приложением.
На банкомате еще не проверял, соседний банкомат сломан (не я :)), жду починку

Все это я напишу в техподдержку 1с, когда они откликнутся - вчера написал от них пока ответа нет.
   Вафель
 
23 - 02.07.19 - 15:24
у нас есть qr - читается конечно
Функция КомпонентаФормированияQRКода(Отказ)
    
    СистемнаяИнформация = Новый СистемнаяИнформация;
    Платформа = СистемнаяИнформация.ТипПлатформы;
    
    ТекстОшибки = НСтр("ru = 'Не удалось подключить внешнюю компоненту для генерации QR-кода'");
    
    Попытка
        Если ПодключитьВнешнююКомпоненту("ОбщийМакет.КомпонентаПечатиQRКода", "QR") Тогда
            QRCodeGenerator = Новый("AddIn.QR.QRCodeExtension");
        Иначе
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки, , , , Отказ);
        КонецЕсли
    Исключение
        ПодробноеПредставлениеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке());
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки + Символы.ПС + ПодробноеПредставлениеОшибки, , , , Отказ);
    КонецПопытки;
    
    Возврат QRCodeGenerator;
    
КонецФункции

   Вафель
 
24 - 02.07.19 - 15:25
Функция ДанныеQRКода(QRСтрока, УровеньКоррекции, Размер) Экспорт
    
    Отказ = Ложь;
    
    ГенераторQRКода = КомпонентаФормированияQRКода(Отказ);
    Если Отказ Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Попытка
        ДвоичныеДанныеКартинки = ГенераторQRКода.GenerateQRCode(QRСтрока, УровеньКоррекции, Размер);
    Исключение
        ЗаписьЖурналаРегистрации(НСтр("ru = 'Формирование QR-кода'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка, , , ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
    КонецПопытки;
    
    Возврат ДвоичныеДанныеКартинки;
    
КонецФункции

   arsik
 
25 - 02.07.19 - 15:52
(23) Так у него код то читается, просто внутри мусор для банкомата
   ВикторП
 
26 - 03.07.19 - 13:49
(23) я уже разобрался. Я сомневаюсь, что у вас будет читаться.
Попробуйте сформировать платеж в первую налоговую Москвы , и попробуйте потом этот код прочитать - в банкомате или приложением.
можете выложить QRстроку.
   Лефмихалыч
 
27 - 03.07.19 - 14:05
(0) ВОт так делай http://docs.cntd.ru/document/1200110981
и нормально будет.

Главное, что надо запомнить - сумма, блеать, в КОПЕЙКАХ!
   ДядяМитяй
 
28 - 03.07.19 - 14:13
(27) Все логично для 1Сника, время - в секундах, деньги - в копейках )))
   Лефмихалыч
 
29 - 03.07.19 - 14:15
(28) не, это скорее чтобы не париться с точками и запятыми
   ВикторП
 
30 - 04.07.19 - 15:03
сегодня проверил в банкомате, все- ОК.
Техподдержка 1с еще не ответила. Написал в понедельник. Небыстро, однако


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует