Вход | Регистрация
 

Обработка для изменения даты документа. ОтборРазмещенияТоваров.

Обработка для изменения даты документа. ОтборРазмещенияТоваров.
Я
   userqwerty
 
28.06.19 - 12:11
Помогите пожалуйста написать простую обработку. дайте кто нибудь код у кого есть. с обработками только начинаю знакомиться.
 
 
   butterbean
 
1 - 28.06.19 - 12:12
Держи:
а=1;
   dka80
 
2 - 28.06.19 - 12:12
конфигурация типовая? Чем не устраивает типовое групповое изменение реквизитов?
   Случайный прохожий
 
3 - 28.06.19 - 12:13
Были здесь как-то раньше телепаты, но уже все по-клиникам сидят
   userqwerty
 
4 - 28.06.19 - 12:16
(2) задание поставили, написать обработку.
   userqwerty
 
5 - 28.06.19 - 12:17
(3) есть у меня документ, ОтборРазмещениеТоваров, надо написать обработку в которой я могу выбрать документ номер 0001 например и написать нудную дату в форме, и эта дата подтянется в дату документа.
   catena
 
6 - 28.06.19 - 12:18
(4)Тебе задание поставили, а ты у нас код просишь?
   userqwerty
 
7 - 28.06.19 - 12:18
(6) с обработками только знакомлюсь.
   catena
 
8 - 28.06.19 - 12:18
"Нудная дата" - это какая? Рабочая суббота, какая-нибудь?
   catena
 
9 - 28.06.19 - 12:19
(7)Так знакомься. Начни знакомиться с чтения документации.
   aleks_default
 
10 - 28.06.19 - 12:19
Побори привычку скачивать рефераты в интернете, пробуй написать сам
   dka80
 
11 - 28.06.19 - 12:19
"могу выбрать документ номер 0001" - как ты это планируешь делать?
   userqwerty
 
12 - 28.06.19 - 12:20
(8) Нужная дата. чтоб вводить в эту дату в форме, а она подтягивалась в дату документа
   userqwerty
 
13 - 28.06.19 - 12:21
(11) поставить тип объекта формы Документы.ОтборРазмещениеТоваров
   catena
 
14 - 28.06.19 - 12:21
(12)Давай начнем с того, с кем, кроме обработок, ты уже успел познакомиться?
   userqwerty
 
15 - 28.06.19 - 12:22
(10) я же сказал что только знакомлюсь,
   userqwerty
 
16 - 28.06.19 - 12:22
(14) запросы неплохо пишу
   dka80
 
17 - 28.06.19 - 12:23
Размести на форме два реквизита:
Документ - тип твой документ
ДатаДок - тип дата (состав дата время или только дата - на твой выбор)

обДок = Документ.ПолучитьОбъект();
обДок.Дата = ДатаДок;
обДок.Записать();

Только учти, что это просто поменяется дата документа. Если у документы были движения, то нужно перепроводить документ обДок.Записать(РежимЗаписиДокумента.Проведение)
   userqwerty
 
18 - 28.06.19 - 12:25
(17) команда какая то нужна? типа применить или сформировать
   dka80
 
19 - 28.06.19 - 12:26
(18) добавь команду. Размести ее на форме. В процедуре обработки команды размести код
   userqwerty
 
20 - 28.06.19 - 12:27
(19) сделал
   userqwerty
 
21 - 28.06.19 - 12:34
&НаСервере
Процедура Сформировать() 

обДок = Обработки.Документ.ПолучитьОбъект();
обДок.Дата = ДатаДок;
обДок.Записать(); 
КонецПроцедуры 

вот  так пропускает без ошибок, на сколько это правильно?
   Случайный прохожий
 
22 - 28.06.19 - 12:35
(21) Пока не попробуешь - не узнаешь
   dka80
 
23 - 28.06.19 - 12:36
(21) ты, надеюсь, не на рабочей базе тренироваться собрался?
   userqwerty
 
24 - 28.06.19 - 12:37
(23) на копии))
   Случайный прохожий
 
25 - 28.06.19 - 12:37
(23) Думаешь его к рабочей подпустят? :)
   userqwerty
 
26 - 28.06.19 - 12:37
(23) можете в вацапе написать что делать, фото бы скинул что я сделал.
   dka80
 
27 - 28.06.19 - 12:39
(24) в смысле, что делать? запускай обработку в режиме предприятия и проверяй
   userqwerty
 
28 - 28.06.19 - 12:40
(27) на форме все есть все хорошо, нажимаю сформировать он не записывает,
   dka80
 
29 - 28.06.19 - 12:41
Поставь точку останова. Проверь чему равно обДок, ДатаДок. С чего ты решил, что не записывает? Ты форму обновлял?
   Случайный прохожий
 
30 - 28.06.19 - 12:45
(28) Кнопка к процедуре вообще привязана?
 
 Рекламное место пустует
   userqwerty
 
31 - 28.06.19 - 12:47
(30) вот это как проверить? в свойствах кнопки?
   userqwerty
 
32 - 28.06.19 - 12:49
(29) нужен отладчик внешних обработок ?
   dka80
 
33 - 28.06.19 - 12:50
   userqwerty
 
34 - 28.06.19 - 12:56
(33) это сделал, один фиг не реагирует.
   Случайный прохожий
 
35 - 28.06.19 - 13:02
Ну если про точки останова ты еще не слышал, то можно воспользоваться старым дедовским способом))
Помести
Сообщить("фыва");

в код процедуры и посмотри будет тебе что-либо выводиться или нет
   userqwerty
 
36 - 28.06.19 - 13:05
(35) а вот и сообщить не работает что то, я &насервере пишу, может изза этого
   dka80
 
37 - 28.06.19 - 13:08
&НаКлиенте
Процедура Сформировать() 

СформироватьНаСервере();

КонецПроцедуры 

&НаСервере
Процедура СформироватьНаСервере() 
обДок = Обработки.Документ.ПолучитьОбъект();
обДок.Дата = ДатаДок;
обДок.Записать(); 
КонецПроцедуры
   userqwerty
 
38 - 28.06.19 - 13:11
(35) &НаКлиенте
Процедура Сформировать(Команда)
    

Сообщить ("фыва");
КонецПроцедуры

вот это заработало., нашел ошибку
   userqwerty
 
39 - 28.06.19 - 13:15
(37) ошибка
{ВнешняяОбработка.ВнешняяОбработка4.Форма.Форма.Форма(12)}: Поле объекта не обнаружено (Документ)
обДок = Обработки.Документ.ПолучитьОбъект();
   dka80
 
40 - 28.06.19 - 13:17
обДок = Документ.ПолучитьОбъект();
   userqwerty
 
41 - 28.06.19 - 13:18
&НаКлиенте
Процедура Сформировать() 

СформироватьНаСервере();

КонецПроцедуры 

&НаСервере
Процедура СформироватьНаСервере() 
обДок = Документ.ПолучитьОбъект();
обДок.Дата = ДатаДок;
обДок.Записать(); 
КонецПроцедуры

вот так работает. спасибо ребята за терпение.
   userqwerty
 
42 - 28.06.19 - 13:19
(40) спасибо большое


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.