Вход | Регистрация
 

кнопки печати на формах исчезли

кнопки печати на формах исчезли
Я
   mvl_dimir
 
28.06.19 - 09:19
Всем здравствуйте. Решил я значит обновить 1С (конфигуратор и пользовательский). Сделал все как надо, ну я так думаю, когда обновление конфигуратора закончилось, я обнаружил такую проблему, что абсолютно все кнопки печати перестали отображаться. Почитал один форум, сказали поменять код на форме, а на какой форме, хрен знает, не сказали, я предполагаю что-то с совместимостью. Ну вот я думаю, у меня этих форм с кнопкой печати дохрена и больше, мне теперь нужно в каждую форму лезть и код менять? Есть какой-то способ сделать быстрее, например через расширение? Или же, я что-то не так сделал при обновлении. Какие варианты? Еще дам немного наводящей инфы, 1с долго не обновлялась, аж с апреля и вот в июне 26 числа вышло новое обновление, мб я перескочил остальные и случился конфликт? Вот код, который они просили вставить в форму: форма документа:
=======================================================
#Область  КомандыФормы

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    // СтандартныеПодсистемы.ПодключаемыеКоманды
    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды
    
КонецПроцедуры


// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды


#КонецОбласти
==========================================================

форма списка
=======================================================

#Область КомандыФормы

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    // СтандартныеПодсистемы.ПодключаемыеКоманды
    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды
КонецПроцедуры

// СтандартныеПодсистемы.ПодключаемыеКоманды
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Элементы.Список, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Элементы.Список);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды



#КонецОбласти
 
 
   unregistered
 
1 - 28.06.19 - 09:49
(0) Лучше пригласите специалиста.
Вы даже вопрос сформулировать не умеете нормально. Чего уж ждать от результатов ваших правок конфигурации.
   ДенисЧ
 
2 - 28.06.19 - 10:16
Интересно, а что такое "обновить конфигуратор"?
   mvl_dimir
 
3 - 28.06.19 - 11:04
Конфигурацию я пытался обновить, через конфигуратор. И что значит, не умею, какие именно слова вам не понятны?
   Случайный прохожий
 
4 - 28.06.19 - 11:37
В любой непонятной ситуации - чисти кэш
   Fish
 
5 - 28.06.19 - 11:41
(3) Рекомендую почитать для начала вот это: https://forum.mista.ru/rules.php#rec
   stix2010
 
6 - 28.06.19 - 11:42
(0) А Боинг Вы уже умеете водить?
   mvl_dimir
 
7 - 28.06.19 - 13:33
конечно умею

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует