Вход | Регистрация
 

А когда отрабатывает условное оформление формы?

А когда отрабатывает условное оформление формы?
Я
   RomaH
 
27.06.19 - 11:07
&НаКлиенте
Процедура НомерПолисаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
    
    ДлинаНомера = СтрДлина(Текст);
    
КонецПроцедуры


на форму повешено УО  - если ДлинаНомера <> 16 - тогда красный шрифт

черным показывает 15 и 17... вернее так

похоже по событию "кнопка нажата" - применяется УО, по событию "кнопка отпущена" срабатывает событие изменения текста ...

как все сложно ... цвето-музыка какая-то получается с УО,
 
 
   RomaH
 
1 - 27.06.19 - 11:33
прикольно

&НаКлиенте
Процедура НомерПолисаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
    
    ДлинаНомера = СтрДлина(Текст);
    ВызовСервера();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ВызовСервера()
    
КонецПроцедуры


вот так обновляем УО
   Вафель
 
2 - 27.06.19 - 11:34
в момент окончания редактирования

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.