Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Стандартн. период в мобильном приложении, ошибка- This.a.pop(...) set is not function

Стандартн. период в мобильном приложении, ошибка- This.a.pop(...) set is not function
Я
   SkillUp
 
26.06.19 - 15:57
Выбор стандартного периода в мобильном приложении, ошибка- This.a.pop(...) set is not function . Кто-то с подобным сталкивался?    

&НаКлиенте
Процедура УстановитьИнтервал(Команда)
    
    
    Диалог = Новый ДиалогРедактированияСтандартногоПериода();
    СтандартныйПериод = Новый СтандартныйПериод();
    
    ДатаНачала = Элементы.ДатаНачала;
    ДатаОкончания = Элементы.ДатаОкончания;
    
    СтандартныйПериод.ДатаНачала = ДатаНачала;
    СтандартныйПериод.ДатаОкончания = ДатаОкончания;
    Диалог.Период = СтандартныйПериод;
    
    ОписаниеОповещения = Новый ОписаниеОповещения("ОбработкаВыбораПериода",ЭтаФорма);
    
    Диалог.Показать(ОписаниеОповещения)
    
КонецПроцедуры



&НаКлиенте
Процедура ОбработкаВыбораПериода(Период,Параметры) Экспорт

    Если Период <> Неопределено Тогда
        
        Элементы.ДатаНачала = Период.ДатаНачала;
        Элементы.ДатаОкончания = Период.ДатаОкончания;
    
    КонецЕсли;

КонецПроцедуры
 
 
   SkillUp
 
1 - 26.06.19 - 16:17
И тишина...
   SkillUp
 
2 - 26.06.19 - 16:52
Может у кого-то что-то подобное будет :

вот так должно было быть:

&НаКлиенте
Процедура ОбработкаВыбораПериода(Период,Параметры) Экспорт

    Если Период <> Неопределено Тогда
        
        ЭтаФорма.ДатаНачала = Период.ДатаНачала;
        ЭтаФорма.ДатаОкончания = Период.ДатаОкончания;
    
    КонецЕсли;

КонецПроцедуры
   singlych
 
3 - 26.06.19 - 17:01
ДатаНачала = Элементы.ДатаНачала; 
ДатаОкончания = Элементы.ДатаОкончания; 

Элементы.ДатаНачала = Период.ДатаНачала; 
Элементы.ДатаОкончания = Период.ДатаОкончания; 

вот это все чушь
   singlych
 
4 - 26.06.19 - 17:02
но вряд ли имеет отношение к ошибке

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует