Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отражение документов в рег учете КА 2.4

Отражение документов в рег учете КА 2.4
Я
   tigrandis
 
26.06.19 - 13:12
1С:Предприятие 8.3 (8.3.13.1513)
1С:Комплексная автоматизация 2 (2.4.7.151)

Не пойму кто и как делает эти проводки, бух заявляет что программа не верно формирует проводки, кидает мне ссылку на документы открываю ДК и там реально не верно формировано, проводишь еще раз документ снова заходишь в проводки и "о чудо" все стоит как нужно. Документ Списание безнаоичных, до исправление стоит только 62.02-62.01, после добавляет правильную проводку 62.01 - 51
Хотелось бы узнать кто то сталкивался или раз работаешь в 1с то, будь добр перепроводи документы в ручную =) или может есть какое то лекарство, а то какой то бред (
 
 
   Фрэнки
 
1 - 26.06.19 - 13:25
так если совсем ничего не настроено (развернули голую базу, вбили реквизиты организации, расчетный счет и погнали шлепать документы)
никакие проводки вообще не появятся, пока месяц "закрывать" не начнешь.
Если у вас проводки как-то "сами" появляются, то ищи того, кто это все "включал".
   Фрэнки
 
2 - 26.06.19 - 13:33
Регламентное задание должно запускаться по какому-то расписанию. Если на момент запуска по расписание данные программы не соответствуют нужным, то и результаты проводок будут ненужные.
   tigrandis
 
3 - 26.06.19 - 15:20
(1) про это Я согласен, и все было бы логично если бы вообще не было никакних проводок, но там они есть + нет галки "ручные"
   Фрэнки
 
4 - 26.06.19 - 15:22
(3) в регламентных поискал? нет ничего? "само" оно никак не появится.
   tigrandis
 
5 - 26.06.19 - 15:56
(4) стоит авто отражение документов, вопрос почему в ручную нормально отражает, а так нет ??
   sqr4
 
6 - 26.06.19 - 16:02
(5) А ты количество ошибок этого релиза видел?
   Фрэнки
 
7 - 26.06.19 - 16:18
(5) ну нет такого "авто отражение" 
Где оно стоит-то?
Открываю обработку "Отражение документов в регламентированном учете" - там "автоматическое отражение по расписанию"

Мое предположение: если в момент срабатывания по расписанию данных для верного отражения не хватало, то и проводки будут предварительные. Когда после провалишься в документ, то и проводки станут другие.

Мне вот другое интересно: никто не пробовал как-то привязать отражение к проведению, чтоб не нужно было проваливаться в форму проводок интерактивно?
   sqr4
 
8 - 26.06.19 - 16:20
(7) Пробовал
   sqr4
 
9 - 26.06.19 - 16:22
Модуль проведениеСерверУТ 
&После("ЗаписатьНаборыЗаписей")
Процедура зр_ЗаписатьНаборыЗаписей(Объект) Экспорт
    
    Если Объект.Движения.Найти("ОтражениеДокументовВРеглУчете") = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Если Объект.Метаданные().Реквизиты.Найти("Организация") = Неопределено Тогда
        Организация = Справочники.Организации.ПустаяСсылка();
    Иначе
        Организация = Объект.Организация;
    КонецЕсли;
    
    СтруктураРеквизиты = Новый Структура("Ссылка, Дата, Организация", Объект.Ссылка, Объект.Дата, Организация);
    Статус = РеглУчетПроведениеСервер.ОтразитьДокумент(СтруктураРеквизиты, Истина);
    
    Объект.Движения.ОтражениеДокументовВРеглУчете.Записывать = Истина;
    Объект.Движения.ОтражениеДокументовВРеглУчете.Очистить();
    
    Движение = Объект.Движения.ОтражениеДокументовВРеглУчете.Добавить();
    Движение.Регистратор = Объект.Ссылка;
    Движение.Период = Объект.Дата;
    Движение.Организация = Организация;
    Движение.ДатаОтражения = Объект.Дата;
    Движение.Статус = Статус;
    Движение.Комментарий = "";
    
    Объект.Движения.Записать();
    
КонецПроцедуры
   sqr4
 
10 - 26.06.19 - 16:26
Работает не стабильно, при отмене проведения движения по регистру ОтражениеДокументовВРеглУчете остаются, короче промежуточная версия
 
 Рекламное место пустует
   tigrandis
 
11 - 26.06.19 - 16:26
(9) идея классная, думаю тоже сделаю, спс за код
   sqr4
 
12 - 26.06.19 - 16:27
по счет фактуре полученной помоему не работает
   Фрэнки
 
13 - 26.06.19 - 16:31
(9) Ок. Воспользуюсь, испытаем, как оно будет работать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует