Вход | Регистрация
 

заполнение тч формы определяемого размера суммой координат ячейки

заполнение тч формы определяемого размера суммой координат ячейки
Я
   JuixyJes
 
25.06.19 - 22:30
ТабличнаяЧасть1.Очистить();
    Для сч = 0 по ПолеВвода2 - 1 Цикл
        
        
        Для КолВоКол = 1 по ПолеВвода1 Цикл
            НСтр = ТабличнаяЧасть1.Добавить();
            
            Если   ЭлементыФормы.ТабличнаяЧасть1.Колонки.Количество()>= КолВоКол Тогда
                ЭлементыФормы.ТабличнаяЧасть1.Колонки.Удалить(КолВоКол-1);
                ЭлементыФормы.ТабличнаяЧасть1.Колонки.Добавить();
            Иначе
                ЭлементыФормы.ТабличнаяЧасть1.Колонки.Добавить();
            КонецЕсли;
            НСтр["Колонка" + КолВоКол]= Нстр.НомерСтроки + КолВоКол;

        КонецЦикла;
                
    КонецЦикла;
 
 
   JuixyJes
 
1 - 25.06.19 - 22:31
Что не так я тут сделала? Вроде и циклы не так страшно написаны
   JuixyJes
 
2 - 25.06.19 - 22:31
ПолеВвода1 это количество колонок
ПолеВвода2 это количество строк
   RomanYS
 
3 - 25.06.19 - 22:42
(2) А ТабличнаяЧасть1 это что?

Что ты хочешь сделать с колонками, да ещё в цикле по строкам?
Понимаешь ли ты, что
 ЭлементыФормы.ТабличнаяЧасть1.Колонки.Добавить();
не добавляет колонки в ТабличнаяЧасть1?
Если ТабличнаяЧасть1 это табличная часть, то туда колонки вообще не добавить кодом.
   JuixyJes
 
4 - 25.06.19 - 23:02
(3) Это табличная часть формы, колонки туда добавляются. Я знаю, ибо код работает , но вот сумму координат записать не получается
   JuixyJes
 
5 - 25.06.19 - 23:05
(3) ну и я бы не отказалась узнать как очистить ТЧ полностью, т.е. удалить и строки и колонки
   RomanYS
 
6 - 25.06.19 - 23:07
(4) "табличная часть формы" такого не бывает. На форме у тебя табличное поле, а вот что в нем - вопрос к тебе.

Колонки ты добавляешь в табличное поле, но не в источник. А твоя НСтр - это строка источника, в ней колонок твоих нет
   RomanYS
 
7 - 25.06.19 - 23:08
(5) Из табличной части нельзя удалить колонки или добавить. Они задаются в метаданных.
   JuixyJes
 
8 - 25.06.19 - 23:21
(6) оххх, моя голова. а как тогда добавить строки в табличное поле?
   Garykom
 
9 - 25.06.19 - 23:23
(8) Аспиринчику из анекдота любым способом на выбор?

;)
   JuixyJes
 
10 - 25.06.19 - 23:24
(7) ЭлементыФормы.ТабличнаяЧасть1.ДобавитьСтроку();
 
 Рекламное место пустует
   JuixyJes
 
11 - 25.06.19 - 23:24
Оно ведь, да?
   JuixyJes
 
12 - 25.06.19 - 23:26
и если оно то как мне в нее данные заносить?
   JuixyJes
 
13 - 25.06.19 - 23:29
(9) Егор, я наверное вам надоела)
   Garykom
 
14 - 25.06.19 - 23:37
Не пробовали хотя бы Митичкина почитать или Хрусталеву с Радченко?
   JuixyJes
 
15 - 25.06.19 - 23:42
(14) Ай ай ай, а копаться в чужой информации не хорошо, будете наказаны))
   RomanYS
 
16 - 25.06.19 - 23:55
(10) мимо
   JuixyJes
 
17 - 26.06.19 - 00:01
(16) а как тогда?
   RomanYS
 
18 - 26.06.19 - 00:07
(17) все действия с данными (и колонками) делать с источником. Если необходимо добавлять колонки динамически - заменить источник на таблицу значений (вместо табличной части).

Чтобы колонки ТЗ-источника появились на форме (в табличном поле) достаточно один раз вызвать
ЭлементыФормы.ТабличнаяЧасть1.СоздатьКолонки();
   JuixyJes
 
19 - 26.06.19 - 00:12
(18) Тоесть предлагаете создать ТЗ, а на ее данных основываясь заполнить табличное поле?
   RomanYS
 
20 - 26.06.19 - 00:15
(19) табличное поле не надо заполнять. Оно для отображения(!) данных источника. Достаточно правильно указать источник, заполнится оно "само".
   RomanYS
 
21 - 26.06.19 - 00:20
(19) ТЗ кстати тоже создавать необязательно, она тоже появится сама в реквизитах формы.

На самом деле (14) абсолютно прав. За пару часов ты бы решила эту задачку, ещё в голове что-нибудь бы осталось. В угадайку дольше будешь играть.
   JuixyJes
 
22 - 26.06.19 - 00:34
(21) Я не люблю читать, приятней коленки обстучать все, но сделать самой. Я так и на гитаре играю уже 9 лет и на фортепиано и на скрипке, вокал 7 лет. Все сама, потому и тут хочется самой, но уж совсем без помощи не получается
   СтепаDS
 
23 - 26.06.19 - 06:25
(22) "Я не люблю читать", глупость какая-то. Это не гитара и вокал, без теоретической базы не обойтись.
   catena
 
24 - 26.06.19 - 06:53
Кого-то мне это напоминает...

Мисти
Ну а что я могла не учесть? Советуйте!
И для среднестатической тетки - я совсем не дура.
/users.php?id=3566" target="_blank" class="registered-user">ДенисЧ
Документацию не читаешь
Мисти
А зачем мне документация?? Я через неделю всё забуду и никогда больше не буду это использовать!
   СтепаDS
 
25 - 26.06.19 - 08:15
(24) +100


Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует