Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Добавление в поле ввода нескольких значений

Добавление в поле ввода нескольких значений
Я
   JuixyJes
 
25.06.19 - 15:21
Доброго времени суток! Возник вопрос, как в поле ввода добавить несколько значений? В созданном мною справочнике есть реквизит - ссылка на справочник номенклатур. Как несколько позиций из справочника Номенклатура добавить в реквизит другого  справочника?
 
 
   butterbean
 
1 - 25.06.19 - 15:22
делай табличную часть
   JuixyJes
 
2 - 25.06.19 - 15:23
(1) а других вариантов быть не может?
   butterbean
 
3 - 25.06.19 - 15:23
(2) другие плохие
   Ёпрст
 
4 - 25.06.19 - 15:29
(2) может, тип ХранилищеЗначений, туда пихай что угодно. Но, оперировать такими  данными не есть гуд.
   JuixyJes
 
5 - 25.06.19 - 15:32
Добавила табличную часть, а можно в нее как то не по одной добавлять а несколько сразу?
Нашла там в свойствах Множественный выбор, он мне как то поможет?
   FIXXXL
 
6 - 25.06.19 - 15:33
(5) подбор из справочника сделай
   Ёпрст
 
7 - 25.06.19 - 15:33
(5) нужно открыть форму для выбора нескольких значений и обрабатывать потом выбранные значения, глядеть, есть ли ужо такоее значение в ТЧ и ежели нема - добавить
   JuixyJes
 
8 - 25.06.19 - 15:38
(7) Просто при попытке добавить я могу выделить несколько, а вот при нажатии кнопки добавить добавляется одно, простите за тафтологию :D Тоесть мне помимо установки свойства нужно и процедуру обработки выбранных значений написать?
   JuixyJes
 
9 - 25.06.19 - 15:41
и если это так, не подскажите пример как это сделать? А то совсем уже запуталась
   Ёпрст
 
10 - 25.06.19 - 15:42
(8) уф/оф ?
 
 Рекламное место пустует
   Ёпрст
 
11 - 25.06.19 - 15:42
так, если есть множественное выделение, нужно обрабатывать коллекцию ВыделенныеСтроки и .. их добавлять в тч
   JuixyJes
 
12 - 25.06.19 - 15:45
(10) уф
   JuixyJes
 
13 - 25.06.19 - 15:51
(11) а как это сделать?)
   Ёпрст
 
14 - 25.06.19 - 15:53
(12) ну вот, код для 2-х вариантов с Радченко

&НаКлиенте
Процедура Подбор(Команда)
//одиночный подбор

//ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора", , Элементы.Материалы);
//множественный подбор

//ПараметрыФормы = Новый Структура("ЗакрыватьПриВыборе", Ложь);
//ПараметрыФормы = Новый Структура("МножественныйВыбор", Истина);


//множественный подбор с использованием множественного выбора

ПараметрыФормы = Новый Структура("ЗакрыватьПриВыборе, МножественныйВыбор", Ложь, Истина);
ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора", ПараметрыФормы, Элементы.Материалы);

КонецПроцедуры
&НаКлиенте
Процедура МатериалыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
//одиночный подбор и множественный подбор

//НоваяСтрока = Объект.Материалы.Добавить();
//НоваяСтрока.Материал = ВыбранноеЗначение;


//подбор с множественным выбором

Для Каждого ВыбранныйЭлемент Из ВыбранноеЗначение Цикл
НоваяСтрока = Объект.Материалы.Добавить();
НоваяСтрока.Материал = ВыбранныйЭлемент;
КонецЦикла;

КонецПроцедуры

   Ёпрст
 
15 - 25.06.19 - 15:53
Создаешь кнопку и команду к ней.. далее переделываешь код на свои справочники и тч.
   Ёпрст
 
16 - 25.06.19 - 15:54
там 2 варианта, первый - просто множественный выбор в открываемой форме, второй (который расскоменчен) - множественный выбор с выделенными строками
   JuixyJes
 
17 - 25.06.19 - 16:47
(16) если использовать добавленную на форму табличную часть - все замечательно работает, а вот если это табличная часть справочника те же самые махинации не получаются

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует